LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   hdc: lost interrupt (https://www.linuxquestions.org/questions/slackware-14/hdc-lost-interrupt-334532/)

sybille 06-17-2005 08:41 AM

hdc: lost interrupt
 
Hello, all.

I'm running Slackware-current on a very old Compaq laptop (Presario 1230). Since I've read that Slackware 11.0 will include a 2.6.x kernel standard, I thought I'd see if I could run the 2.6.11.11 kernel in /testing on this system.


I followed the instructions in the README.initrd file, which means that I installed the needed packages, ran mkinitrd with appropriate arguments for my system, edited lilo.conf and ran /sbin/lilo. I also edited the new rc.modules file installed with the kernel-modules package to correspond to my setup.

When I boot, lilo presents me with the choice of booting into 2.4.31 or 2.6.11.11, which indicates that my installation is to some degree correct. I can still boot into 2.4.31 with no problems whatsoever.

Trying to boot into 2.6.11.11 produces the following error:
Code:

ide-cd: cmd 0x5a timed out
hdc: lost interrupt

This appears after successful identification of the cd-rom ("hdc: TOSHIBA CD-ROM XM-1802B, ATAPI CD/DVD-ROM drive"). When the error appears, booting stops and I must cut power.

I googled around for possible solutions, and I found that it can help to append "acpi=off" to lilo.conf. I tried that, and I also tried "apic=off". No luck.

Here is the relevant section of my current lilo.conf:
Code:

# Linux bootable partition config begins
image = /boot/vmlinuz-ide-2.4.31
  root = /dev/hda6
  label = Linux-2.4.31
  append="apm=power-off"
  read-only
image = /boot/vmlinuz-generic-2.6.11.11
  initrd = /boot/initrd.gz
  root = /dev/hda6
  label = Linux-2.6.11.11
  append="acpi=off apic=off apm=power-off"
  read-only
# Linux bootable partition config ends

Edit: I've tried different combinations in the append line, and I also just tried "pci=noapic" too. Same result each time.

Another edit: I googled a different part of the error message and found another boot option that I tried to append: "acpi=noirq". Maybe the only option is to recompile the 2.6.11.11 kernel so that acpi support is not included at all. Hmm. Normally, I don't keep a compiler installed, much less the kernel sources, but maybe I'll need to do this...or else I can just stay with 2.4.31 and wait to see what future releases in /testing might include.

Does anyone have other suggestions for what I might try?

I'll add that I've attempted to boot several versions of the 2.6 kernel from various liveCD's. In the past, I've had nothing but "kernel panic" errors. The fact that hardware detection is at least starting off OK with the kernel from /testing is encouraging in comparison, even if it's not yet working for me.

Thanks in advance. :)

piete 06-17-2005 05:07 PM

I realise it's not a lot of help since you wanted to explicitly avoid recompilation, but you seem to have all the other options that immediately sprang to my mind; and I hate leaving 0-reply threads alone =)

If you have a second machine (faster, hopefully!), you could actually compile the kernel on there and build a package for your laptop. Or install the raw toolchain and necessary bits & bobs long enough to compile your own kernel. I think the necessary toolchain and stuff is less than 100mb, but please don't quote me - I'm probably inventing the figure. The kernel source is nearer 250mb, and ramps up to a whopping 330mb after compilation. In short, if you can spare 500mb in the short term to make a new kernel, it'll probably help you.

I tend always to make a new kernel, even for my archiac Toshiba Portege 7020CT I have custom compiled 2.4.26 (2.6 had issues with my pcmcia network card). A 6Gb hard drive seems to go a long way =)

sybille 06-18-2005 12:23 PM

Thanks for the reply, piete. Here's what I've discovered, which I'm also posting for the sake of anyone that might google up this thread in the future.

A little more research seemed to confirm that the error message I receive is related to acpi. For example, the message is quite similar to the following: http://bugme.osdl.org/show_bug.cgi?id=2665
Although that bug report is marked closed with a code fix for kernels after a 2.6.6 release candidate version, finding it confirmed my hypothesis that it would be useful to try recompiling a 2.6.11.11 kernel without acpi.

So I did. I don't have another system I can compile on, so I took a whole lot of things out of the config in order to try to speed up the compile as much as possible, which means that I might have introduced some additional problems. In any case, the new kernel without acpi support still would not boot and gave the same error.

However, I think there may be another explanation that does not concern acpi. My laptop, the Compaq Presario 1230, has an unusual processor, the Cyrix MediaGX, which is classified as i586 with MMX. The processor uses the Cyrix 5220 IDE controller. Now, in the kernel config menu, support for this particular controller is marked "VERY EXPERIMENTAL" (with the caps, too :)).

I think my non-booting kernel just may demonstrate the reason for this. In booting (both with and without acpi support in the kernel), the 5220 IDE controller is recognized. The boot hangs just afterward, during detection of the IDE cd-rom.

So my conclusion is that this controller isn't working yet in the 2.6 kernel, which also explains why I've never successfully booted any version of the 2.6 kernel on the machine. There isn't really enough evidence to know for sure, but it seems a likely explanation to me.

Maybe someone is working on this, even though it's old and obsolete equipment (that nevertheless can do a lot still). I haven't yet discovered whether my feedback could be useful, and if so how to go about sharing it, but I've only googled a little at this point.

Anyway, I hope this information will help out anyone who might encounter it. The 2.4.31 kernel in slackware-current runs just fine, BTW, and that's what I'll be sticking with for the moment. (Although I might compile a pared-down version while I still have all the tools to do so installed...)


All times are GMT -5. The time now is 10:18 AM.