-   Slackware (
-   -   hd device remounted with commit=600 (

sanjioh 12-26-2012 02:13 PM

hd device remounted with commit=600
Hi everybody,
I'm using Slackware 14 on a laptop, with xfce as DE. I noticed that every time I start an X session, the option "commit=600" is added to the mount parameters specified in fstab for my root device. What is responsible of such a change? I experimented it when battery powered, I haven't tried on AC yet.

thanks a lot!!

bijo505 12-27-2012 10:26 AM


From the mount man...

Sync all data and metadata every nrsec seconds. The default value is 5 seconds. Zero means default"

Have a look at this URL too


sanjioh 12-27-2012 10:55 AM


thanks, but I know what that option does. What I don't know is which process (re)sets the mount options (remounting my root disc), adding commit as a parameter.
My defaults in fstab are:
defaults,noatime,discard (it's a ssd).
When I run xfce, they suddenly become


LukenShiro 01-01-2013 12:17 PM

It depends on /usr/lib64/pm-utils/power.d/journal-commit (from package pm-utils).
You can override it in e.g. /etc/pm/config.d/_my-sample-file_ with two entries:

sanjioh 01-03-2013 11:26 AM

Hi! yes, that's definetly the culprit. Thanks a lot for your answer, I'll go messing around with pm-utils :)

All times are GMT -5. The time now is 01:55 PM.