-   Slackware (
-   -   Having real battle, Slack64 13.0, realtek rtl8192se wireless. (

mrclisdue 02-25-2010 01:00 AM

Having real battle, Slack64 13.0, realtek rtl8192se wireless.
Firstly, this is from memory, and obtaining detailed outputs will be spotty since the problem machine is remote, and internet connectivity limited to minutes at a time, since the wireless is the issue.

Anyway, I've just converted a windows beginner into a linux beginner, and she's got this beautiful Toshiba l550 lappy, with this dreaded realtek rtl8192se wlan card.

There's bug reports and *some* solutions, plus drivers, here:

The puzzler is that it runs fine here in my home, but at the owner's home there are various connection issues, and if an internet connection is achieved, it's always dropped within a couple of minutes (same router, wrt4gl, same tomato firmware, *mostly* same type configuration....)

As stated, it stayed connected for over 5 straight days in my home.

In the above thread there are a few people who have mentioned that everything's working fine in the the buntu alpha 2 release - so I'm considering upgrading the lappy to -current and seeing if that does anything.

Just throwing this out there in case any one may have some ideas, suggestions as to what to look for, try, etc.

I've never tried ndiswrapper, but afaik, it's a no-go on 64.


throughthegreens 02-25-2010 03:28 AM

are you using wpa_supplicant to associate with the router? if so you may need to make sure you have ap_scan=1 in your wpa_supplicant.conf

mrclisdue 02-25-2010 08:14 AM

Thanks, but no - at the moment I'm connecting raw and open.

On the router side of the issue, the only difference I recall is with the tx power, and it's not huge.

I'm hoping to fiddle a with the router today, specifically with tx rate (which is currently *auto*).


onebuck 02-25-2010 08:39 AM


I would look at channel conflicts at the owners installation.

tdos20 02-25-2010 10:08 AM

Yes, I agree with onebuck - the issue must be location based or you would have also noticed problems on your network.

mrclisdue 02-25-2010 06:49 PM

Thanks kindly to onebuck & tdos20 for the suggestion.

I spent a few hours this afternoon trying different approaches with varying degrees of success, but encountered problems regardless, which ultimately affected other pc's on the wireless, and sometimes even caused the windows (gasp) wireless problems.

*Temporarily* I have completely opened the wireless on channel 6 (there *had* been MAC filtering, but that's been disabled), and the connection is good (not "great", as there can be occasional lag and packet loss, but it's been stable...)

Over the course of the next couple of days, I'll take baby steps towards properly securing the wireless, and if successful, I'll mark the thread solved.


onebuck 02-25-2010 09:00 PM


I would shutdown any wireless equipment in your control to see if the loses or stability changes. If the system performs within parameters then add each piece back until the problem is introduced.

Wall construction can be a real hassle. Where is the AP in proximity to the system(s) in question? Wall type?


moaoci 03-05-2010 11:03 PM

A new version of the driver RTL8172 / RTL8192SE has been created by realtek. The driver works very well on a Toshiba with standard Ubuntu 9.10 64bit while the previous versions of the driver did not see the network. I know it works on 64bit 9.10 Ubuntu but I don't know if it is a 64bit driver or if it is a 32bit driver fully compatible with 64bit system.

The driver file is rtl8192se_linux_2.6.0015.0127.2010.tar.gz and is 1905119 bytes long. Another version of the same file is 1860920 bytes long but the wifi is working on AC but is not working on battery. Last night I checked the realtek download site but it is an old rtl8192se driver. You should get it from realtek by emailing to realtek support at or to I prefer you get it from realtek but I will sent it when you request it by private email.

Driver file now available from Realtek download site

The driver works with a simple make + sudo make install + reboot , BUT remember, it has to be recompiled each time the linux kernel changes number. This driver works if lscpi shows DEVICE 8172 or RTL8172 at line 02:00.0 If it shows RTL8192, you need the RTL8192E driver.

mrclisdue 03-06-2010 06:16 AM

Thank you for the info.

I'll be working some more on that particular machine on Monday, so I'll check the driver version that's installed and try out the one you've mentioned if it isn't what I have.

I've felt all along that the underlying issue is the current state of the driver, and that the issue will be resolved very soon via updated drivers, so hopefully this is the one that does the trick.

As of yesterday, I had added wpa2 to the scenario. Plus, the connection *seems* to be more stable if I use a static ip. Strangely, I can only connect to the ap with this particular interface on channel 6.

Anyway, for the most part, I'd consider the issue 80% solved.

Thanks again for keeping me updated.

edit: I've emailed one of the folks you mentioned and am waiting to hear back. I don't see any option to pm you (other than sending you an email), though there is an option to leave a message in my profile, I don't get that same option with yours. Long story short is that I would like to get my hands on the driver asap, so if we can figure out a way, that would be cool....


mrclisdue 03-10-2010 11:43 AM

As of now, everything's wide open and working, seemingly flawlessly.

Thanks to all for your help, especially moaoci for turning me on to the yet-to-be-released drivers. Though I can't say it was the definitive solution (since the previous drivers were ok in a different location...), I know that it was a significant part of the problem.

Thanks to onebuck (thanks for *everything*) and tdos20 for their location thoughts. Because of the instability of this particular lappy's wireless connection in this location, I ended up adding a second wrt54gl 'tomatoed' router on-site, and set up WDS. Now everything's hunky dory.

I can't foresee that adding wpa2 to the mix will complicate things, but that's a matter for a different thread if it does, anyhow.


All times are GMT -5. The time now is 10:39 AM.