-   Slackware (
-   -   Has anyone upgraded ALSA on their own? (

em21701 08-20-2009 12:36 PM

Has anyone upgraded ALSA on their own?
From my exhaustive googling it appears the best chance to get my sound card going is to upgrade to ALSA 1.0.20. I have tried this and only made a mess of things. Has anyone successfully done this? If so, what was your procedure? I guess a more hopeful question might be <fingers_crossed> will it show up in -current soon? </fingers_crossed>

I am running kernel on Slackware64-current. I have 1.0.18 for alsa-lib and -utils and 1.0.17 for -oss. I have an Intel 82801I ICH9 HD Audio Controller with a VIA VT17085 Codec Chip. The proper kernel modules are loading but alas no sound. alsaconf has been run, no channels are muted in alsamixer. The silence is deafening and it's making me crazy. It appears that I am not the only slacker with some HD audio problems around here either.

Thanks in advance,

dugan 08-20-2009 12:47 PM

There's a similar thread here:

I have upgraded ALSA, but it was before I learned how to use SlackBuilds. I removed ALSA support from my kernel, removed the ALSA packages from my installation, and installed the tarballs from the ALSA homepage using ./configure; make; make install. The thread I just linked to suggests a better solution.

Ilgar 08-20-2009 01:44 PM

I also used to do it long ago, that is, installing the alsa-drivers package (my card needed the latest drivers). I didn't have any problems on my Slackware system.

/dev/me 08-20-2009 02:32 PM

My card wasn't included in the ALSA most distros shipped with when I bought my laptop, so I did it a couple of times. But it's been a while.

I think the biggest problem of upgrading ALSA is deciding which packages to build. There's 8 packages on the ALSA download page. I got away with only building alsa-driver and alsa-lib. YMMV

em21701 08-20-2009 04:35 PM

digging deeper into the thread that dugan posted, led me to a link where they explained how to merge the newest ALSA into the Kernel source and rebuild. I went that way and rebuilt my Kernel with the new files, but still no sound. I'll keep digging.

em21701 08-20-2009 05:39 PM

I finally have sound!! After adding the 1.0.20 driver I had to download and run ALSA's HDA Analyzer where I checked EAPD on Node [0x1c] PIN. MOre information can be found here. Apparently this bug is still yet to be fixed in a release.

em21701 08-20-2009 09:30 PM

Just to add a little more documentation:


alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=auto
options snd-hda-intel enable_msi=1


echo "Enabling EAPD for sound"
hda-verb /dev/snd/hwC0D0 0x1c SET_EAPD_BTLENABLE PCM

All times are GMT -5. The time now is 09:35 AM.