LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   hangs on booting (https://www.linuxquestions.org/questions/slackware-14/hangs-on-booting-162096/)

yisnixslow 03-25-2004 01:44 AM

hangs on booting
 
Hi all,

After installing slackware 9.1 on my PC (Intel Celeron, MMX, ~430MHz , 192MB RAM,Intel Corporation 810 Graphics Controller Hub,
AC'97 Sound Card,Display Memory: 4.0 MB,AC'97 Sound Card,CDRW Asus
) my system freezes everytime during bootup right after the line

"i810-rng hardware driver 0.98 loaded."

My system has 40 GB HDD Dual boot with win2k(35GB) & Slackware 9.1(5GB).

Even the live cd gets stuck at same point.I downloaded a fresh copy of live cd,verified checksum,burnt it but it made no difference.

Is there any parameter i should pass to make it work or use another kernel?How do I find out ?

Please help

Thanks a lot

whansard 03-25-2004 01:54 AM

if you use your slackware rescue cd ( the one you installed with), and find out the name of the module being loaded, you can find the module in /lib/modules/ . . . , and rename it. That way it cannot load. (and crash your box)

yisnixslow 03-25-2004 08:41 AM

thanx for reply whansard! But is there a way to find out which module to exclude during bootup? Is there some kind of script file present where i can find the sequence of modules loadup?

thanks a lot

whansard 03-25-2004 08:54 AM

that varies by distribution, and i don't have a slackware here to look at right now. i would certainly search for i810-mg.o or anything with i810 in it.

find /lib/modules -name "i810*" -print

urka58 03-25-2004 06:38 PM

I had a similar problem with i810_rng module, but fortunately my box didn't hang at boot.
If you could access the slack partion by a rescue disk there is a simple way to fix it by editing you /etc/hotplug/blacklist adding a line like this somewhere in the file
i810_rng
and occasionallly adding a comment as a reminder.
If you can't acces the slack partition in any way, try to reinstall not enabling hotplug features. (at some point during istallation you'll be asked if you want to enable this feature).
This should allow boot sequence skipping many steps.
Then, once you get your machine working, you can enable hotplug features by (as root)
# chmod u+rx /etc/rc.d/rc.hotplug
Hope this helps

yisnixslow 03-26-2004 11:58 AM

Hi,
That was great advice urka58 ! I simply disabled the hot plug feature and it worked like a charm.
Thanks a lot


All times are GMT -5. The time now is 09:43 PM.