-   Slackware (
-   -   Handbrake Problem in 13.37 (

TSquaredF 06-25-2011 12:24 PM

Handbrake Problem in 13.37
I'm having major problems getting Eric's Handbrake package to work on 13.37. I first installed libdvdnav & libdvdcss, then icu4c, libsoup, & webkitgtk, all from SlackBuilds. After having done that, I installed Eric's non-restricted Handbrake package. When I ran the program, it worked, but the Start, Pause & Add To Queue buttons were grayed out. My next step was to compile a Handbrake package from Eric's SlackBuild, but I got the same result. I'm sure I'm doing something simple wrong, but can't figure out what it is. Thanks in advance for any help.

Alien Bob 06-25-2011 05:57 PM

Did you forget to insert a video DVD into your computer?


TSquaredF 06-25-2011 06:41 PM

Thanks for the response, Eric. Yes, I had a DVD in the drive. Handbrake would recognize the DVD, source it & allow me to select individual videos on the DVD, but would not show the proper number of chapters (that stayed at 100), & the buttons were always grayed out. I also tried reading the DVD two ways, by reading /dev/sr0 & by mounting the DVD & selecting the VIDEO_TS(?) folder. Don't know what I'm doing wrong.

Cultist 06-25-2011 06:45 PM

Are you able to watch the dvd on your system? Does it work with any other dvds? It could maybe be that the particular dvd you're using has some weird copy protection scheme that handbrake doesn't support.

edit: Also, how does Alien's package differ from the one? I thought sbo's was unrestricted as well

Keith Hedger 06-26-2011 07:19 AM

The sbo package runs fine but shedloads of dependencies and a minor problem with the a52 decoder but once installed runs fine, try the package from sbo, or just compare the slackbuilds to see what the difference is

TSquaredF 06-26-2011 04:40 PM

@ Cultist: I can play DVDs with no problem (at least with Kaffeine & VLC, they will not play with MPlayer).
@ Keith Hedger: Have not ever tried the SBo generated package. Will go try that now & report back.

TSquaredF 06-29-2011 09:29 PM

Just to tie the ribbons on this thread, I never did figure out what was causing handbrake-0.9.4 not to work on either Slackware-13.37 or Slackware-current. I went so far as to completely strip all external packages from current & start over, installing the webkitgtk dependencies, then the Switch perl module, so as to install webkitgtk. Then installed Eric's handbrake-0.9.4 package & the Start, Pause, & "Add To Template" buttons were grayed out. Then this evening, I read this thread, where Eric told about his new handbrake-0.9.5 package. Downloading & installing that package solved my problems. Thanks to all for the help/suggestions & especially to Eric for the new package. How would us sheep get around without someone to show us the way?

All times are GMT -5. The time now is 01:46 AM.