LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Half-life server problem - blocked UDP packets? Slack 12.2. (https://www.linuxquestions.org/questions/slackware-14/half-life-server-problem-blocked-udp-packets-slack-12-2-a-741844/)

Ook 07-22-2009 12:43 AM

Half-life server problem - blocked UDP packets? Slack 12.2.
 
I have a clean install of Slackware 12.2. I'm running a half-life server on the box. The files are configured properly, and the configs work when I run the same file set on a Windows box (the server comes with windows and linux binaries so you can run the same file set under either OS). When I run it on the linux box, the server starts and runs and people can join from the Internet if they know my ip. This means that the server is setup correctly and the router is properly configured. The server does not show up on the Steam server list, and we suspect that the UDP heartbeat packets are being blocked somehow.

Is there any way for me to tell if UDP packets are being blocked or lost, such as a log file somewhere?

Ook 07-22-2009 01:55 PM

Problem solved. Turns out that the linux version of half-life server does not automatically set the master server. You have to do this manually or your server does not get listed. The Windows version does this automatically. I never would have guessed. And it had nothing at all to do with my Slack box.


All times are GMT -5. The time now is 11:54 AM.