-   Slackware (
-   -   gutenprint /gimp-print no drivers (

munkie_poo 04-07-2005 10:26 AM

gutenprint /gimp-print no drivers

Recently I'd been using SUSE 9.1 and I compiled the "gutenprint 5.x.beta3"
drivers for cups to get my Epson Photo R300 working.
In SUSE it worked almost perfect.

Ive changed Distro, and I now use Slackware 10.1. The drivers compile
and install fine (or at least seem to), I install the printer through
web interface (localhost:631), the new drivers are listed in cups and
the printer installs. When I try to print a test page in cups, I get an
error saying:

"Gutenprint Fatal error: Unable to find driver named "EPSON Stylus Photo

Ive tried reinstalling them with different ./configure options.. eg.
--with-cups --with-gimp2
and the same happens every time.

I hope you can help solve my problem.


gbonvehi 04-08-2005 02:50 AM

I would try with: ./configure --prefix=/usr
I don't think it'll help, since it seems some data moved correctly, but other not, but well, try anyways :)

It seems however you can use it with Gimpprint:

EDIT: Well, a little research showed that gutenprint are actually part of Gimpprint, you should try the latest version (5.0.0-beta is the latest, and the one at Slackware-current is 4.2.7) that from the search results i've seen has more support for your printer.

munkie_poo 04-08-2005 08:59 AM

If you read closer, I am using the the newer gutenprint 5.x beta3 and its these Ive been having problems with.

The gimpprint drivers included with slack do have support for this printer and they did work, but the newer gutenprint driver allow for printing to CDR's and other improvements.

I will try the 'prefix' this time and see what happens.

I have worked out (I hope correctly)that the drivers are actually installing to '/usr/share/cups/model/gutenprint/5.0/C'.

Also when adding the printer to cups, something is extracted into '/etc/cups/ppd'.

with all this in mind, could this be a permission problem?

any ideas on how I could diagnose this problem, Ive only used cups through the web interface and it doesnt help out too much with the problem.


gbonvehi 04-08-2005 09:53 AM

What I meant was that you should try to install the whole gimpprint 5.0.0, but anyway, those drivers should've worked, maybe you can ask in Gimpprint's site/forum/mailing-list.

PS: Up for any CUPS experience similar to this.

munkie_poo 04-08-2005 12:54 PM

"Gutenprint is a set of very high quality drivers for printers, with particular emphasis on inkjets. Gutenprint is the new name for the Gimp-Print project." ->

I thought gutenprint was the whole gimp-print, just changed name.

I just checked, Its gimp-print 5.0 beta2 then its gutenprint 5.0beta3

gbonvehi 04-08-2005 12:58 PM

You're right, I thought gutenprint was part of Gimp-print (I've a bad habit of reading just parts of a sentence and "guessing" it).
It's very weird since it doesn't mention that in Gimp-print's page ( :/

munkie_poo 04-09-2005 12:25 AM

I've managed to get it working :)

I was noticing some strange goings on happening. I just done fresh installs on two similar machines, one was working fine (I couldnt test cups on this machine as the printers not attached to it), the other was mis-behaving, users vanishing, cdroms not mountable, and other little niggly things that just arnt quite right.

Anywhoo I've re-installed slack to this machine using NFS install, and everything looks hunky dorey. Could probably do with a new cd drive, dont think its reading data correctly.

Thanks for the help.

All times are GMT -5. The time now is 05:33 PM.