LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-14-2013, 12:31 PM   #1
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 2,993

Rep: Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737
GUI Log In with Xfce?


I've been asked and don't know -- is there support/ability/whatever for a GUI log in with Xfce with run level 4? /etc/inittab says
Code:
#   4 = X11 with KDM/GDM/XDM (session managers)
I just use run level 3 and startx (happily) and don't know how to answer the question (or how to set it up if it is supported).

Any ideas?
 
Old 08-14-2013, 12:47 PM   #2
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: Slackware, Slackware64
Posts: 1,489

Rep: Reputation: 662Reputation: 662Reputation: 662Reputation: 662Reputation: 662Reputation: 662
I'm using a personally themed GDM, which works great. I started from the Salix SlackBuild and theme and adapted it to my needs. The stock GDM is quite ugly, but highly configurable.

The most simple solution for you would be to install a package from my MLED repo.

http://www.microlinux.fr/slackware/

Go to the subdirectory corresponding to your architecture, and then download the gdm package. You also have to download and install libgnomecanvas, as this is a dependency. Should work out of the box.

Cheers,

Niki

PS: once GDM is installed, simply switch from runlevel 3 to 4, and that's it.

PPS: of course you're free to ignore all this and simply use XDM, the ugliest login manager on the planet.

Last edited by kikinovak; 08-14-2013 at 12:49 PM.
 
1 members found this post helpful.
Old 08-14-2013, 01:08 PM   #3
GazL
Senior Member
 
Registered: May 2008
Posts: 3,312

Rep: Reputation: Disabled
Are you talking about an automated login? If so, what about changing /etc/rc.d/rc.4 to run "su - guiuser -c 'startx'" ? Would that not work?
 
Old 08-14-2013, 01:08 PM   #4
bormant
Member
 
Registered: Jan 2008
Posts: 89

Rep: Reputation: 37
I'm using SLiM from http://slackbuilds.org/repository/14.0/system/slim/
 
Old 08-14-2013, 01:25 PM   #5
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 2,993

Original Poster
Rep: Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737
Quote:
Originally Posted by GazL View Post
Are you talking about an automated login? If so, what about changing /etc/rc.d/rc.4 to run "su - guiuser -c 'startx'" ? Would that not work?
Nope, just the GUI that presents drop-down user name and box for password in Xfce. That particular machine (not mine) has three users and they're just looking for a gooey form instead of log in, startx (apparently that's confusing?). I dunno why.
 
Old 08-14-2013, 01:28 PM   #6
GazL
Senior Member
 
Registered: May 2008
Posts: 3,312

Rep: Reputation: Disabled
Ahh I see. Well I just use xdm and it starts whatever environment you configured in xwmconfig.
 
Old 08-14-2013, 01:55 PM   #7
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 2,993

Original Poster
Rep: Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737
Well, that was interesting.

On my box, Xfce, I changed the run level to 4, did init 4, and the thing stated up the KDE log in page.

Hm.

Looked in /etc/X11/xinit and, sure enough
Code:
ls -l xinitrc
lrwxrwxrwx 1 root root 12 Aug 14 14:46 xinitrc -> xinitrc.xfce
So, what am I missing here?
 
Old 08-14-2013, 03:16 PM   #8
maciuszek
Member
 
Registered: Nov 2010
Location: Toronto, Ontario
Distribution: Slackware + FreeBSD
Posts: 59

Rep: Reputation: 17
look in /etc/rc.d/rc.4.
either give xdm a higher priority in the execution order or change the executable permission of the kdm binary.
[Edit: the second alternative also encapsulates the subalt of uninstalling the package altogether (probably the cleanest solution, even if pkgtools doesn't care for such alterations)]

Last edited by maciuszek; 08-14-2013 at 03:22 PM.
 
1 members found this post helpful.
Old 08-14-2013, 03:25 PM   #9
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,357
Blog Entries: 2

Rep: Reputation: 3980Reputation: 3980Reputation: 3980Reputation: 3980Reputation: 3980Reputation: 3980Reputation: 3980Reputation: 3980Reputation: 3980Reputation: 3980Reputation: 3980
Ir doesn't matter at all what xinitrc is linked to when starting in runlevel 4. When the KDM login page shows up just put in your username and choose from the dropdown list (I think it is named "session" or something similar) that you want to run XFCE. KDM will remember that choice (as do most other display managers, not sure about XDM), so that you don't have to do that every time.
 
Old 08-14-2013, 04:03 PM   #10
GazL
Senior Member
 
Registered: May 2008
Posts: 3,312

Rep: Reputation: Disabled
xdm runs /etc/X11/xdm/Xsession, which runs ~/.xsession or /etc/X11/xinit/xinitrc if the user doesn't have a ~/.xsession. xwmconfig will create the appropriate ~/.xsession for the user when it is run.

kdm uses a different mechanism to find its startup scripts, but I don't install KDE so I can't say much about that.
 
Old 08-14-2013, 08:14 PM   #11
perbh
Member
 
Registered: May 2008
Location: Republic of Texas
Posts: 222

Rep: Reputation: 37
I just tried it out - moved xdm to the top of the list in /etc/rc.d/rc.4 - works perfectly! (well, as someone has pointed out, xdm isn't exactly the star o' the show)

Last edited by perbh; 08-15-2013 at 09:01 AM.
 
Old 08-14-2013, 08:57 PM   #12
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,789
Blog Entries: 15

Rep: Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729
Technically XDM is just the default X11 Display Manager, it's not actually associated with Xfce.

GDM (Gnome Display Manager) is about as close to what you'd get for something near a native display manager for Xfce, but Xfce doesn't have an actual display manager suite.
 
Old 08-15-2013, 01:51 AM   #13
solarfields
Member
 
Registered: Feb 2006
Location: Outer Shpongolia
Distribution: Slackware
Posts: 446

Rep: Reputation: 114Reputation: 114
get GDM from SBo:

http://slackbuilds.org/repository/14.0/system/gdm/

and you can look for nice themes:

http://gnome-look.org/index.php?xsor...ontentmode=150
 
Old 08-15-2013, 07:00 AM   #14
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,199

Rep: Reputation: 290Reputation: 290Reputation: 290
If init 4 works, and you want it to always use a gui login, then edit /etc/inittab:

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:

change it to:

id:4:initdefault:

That way it will boot straight into kdm or xdm, or which comes first in rc.4
 
Old 08-15-2013, 08:51 AM   #15
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 2,993

Original Poster
Rep: Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737
Bearing in mind that this is for a non-techie friend (not for me), I tried all the suggested methods on my work system. Got GDM and libgnomecanvas, built and installed, changed the default run level to 4 in /etc/inittab, reboot (coulda just done init 4, but what the heck). Up it pops, log in, log out, log in as somebody else, log out. Works.

OK, let's see what XDM does. Moved that to the top of the list in /etc/rc.d/rc.4, init 4, log in, log out, works (not pretty, no eye candy, but who cares -- eye candy isn't the point, simplicity is).

And, of course, the first go-round started up KDE's session manager and who knows what KDE pollution that can cause (yeah, eye candy to beat the band but... who needs it to log in on dang terminal?).

Trouble with using the simple, XDM, is that I tell a lie and I have to remember to tell the same lie when update rolls around -- either comment-out the GDM and KDE sections of rc.4 or edit it and move XDM to the top of the list. Either way, not desirable (I know my friend, simple is mandatory, complicated is not appreciated. Guy has a black screen with three icons on it, Firefox, Thunderbird and Terminal, anything else is nope, don't want it, you can imagine his reaction to KDE).

So, anyway, thanks to all for the input. I'm sticking with run level 3 and startx and I'll go tell my friend's system a lie and see what he thinks. He's probably going to bitch about the full-screen gray, but I don't want to find out where to fix that until he's a happy camper (I know it's in one of the config files, just don't know which one, but I'll find it).

Thanks again, all is well that ends.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GUI network manager for XFCE cccc Debian 6 06-07-2012 12:40 AM
[SOLVED] Can't log in with GDM (or GUI) but can log in via CLI with no password after updates. kev717 Sabayon 1 09-12-2010 06:12 PM
No GUI after Debian-xfce install navy80 Linux - Newbie 18 04-13-2009 06:25 PM
i can't log in to XFCE mechmg93 Debian 2 12-12-2006 02:23 PM
Start with xfce GUI psychobuffalo Linux - Newbie 2 08-24-2005 11:12 AM


All times are GMT -5. The time now is 06:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration