-   Slackware (
-   -   (gucharmap:12280): GLib-GIO-ERROR **: Settings schema 'org.gnome.Charmap' is not inst (

glorsplitz 12-01-2012 01:44 PM

(gucharmap:12280): GLib-GIO-ERROR **: Settings schema 'org.gnome.Charmap' is not inst
slackware 64/14/3.2.29 stable up to date, full install

was looking into what /bin/[ is and didn't know what [ is called to google it, I tried to run kde/utilities/character map, it didn't run, so from command line gucharmap did

(gucharmap:12280): GLib-GIO-ERROR **: Settings schema 'org.gnome.Charmap' is not installed

Trace/breakpoint trap


I looked but I can't find anything bug wise for slackware, there's other mentions of bugs with gnome for other distros but I use kde.

ljb643 12-01-2012 02:16 PM

To fix the gucharmap failure, try running this as root:

# glib-compile-schemas /usr/share/glib-2.0/schemas
While the above does get run as part of certain packages' install scripts, it doesn't get run for gucharmap, which does need it. So depending on the order of package installation, the output files might not include gucharmap's required file. And if it is missing, you get that error.

Note gucharmap is on the Xfce menu as Accessories > Character Map. If you try it and it does nothing, check ~/.xsession-errors for the error above, and try running this command.

glorsplitz 12-01-2012 02:55 PM

Thank you ljb643, that was it.

bobzilla 12-01-2012 04:29 PM

Strangely enough script for gucharmap does contain a reference to glib-compile-schemas:

if [ -e usr/share/glib-2.0/schemas ]; then
  if [ -x /usr/bin/glib-compile-schemas ]; then
    /usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1


But for some reason it doesn't get executed.

Btw, I also solved the problem by manually executing glib-compile-schemas some time ago.

ljb643 12-01-2012 05:37 PM


Originally Posted by bobzilla (Post 4840902)
Strangely enough script for gucharmap does contain a reference to glib-compile-schemas:

OK, good catch. The commands are in the source package's but never make it into the install package (see /var/log/scripts/gucharmap*). There is a bug in gucharmap.SlackBuild - it neglects to zcat into the package staging area.

(Somebody should report this...)

vtel57 12-03-2013 09:27 PM

I know this is a year old post, but I just developed this issue where gucharmap would no longer function on my Slack64 14 systems (KDE or Xfce). This fix above posted by ljb643 still worked like a champ!

Thanks, and Merry, Happy, Seasons Greetings, and all that. :)

All times are GMT -5. The time now is 10:53 AM.