LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   GTK 2.2 Compile? (https://www.linuxquestions.org/questions/slackware-14/gtk-2-2-compile-40413/)

Allen614 01-05-2003 06:46 PM

GTK 2.2 Compile?
 
Because of boredom-ignorance I tried to compile GTK 2.2 from source once more. After reading several HowTos, I still get this error.

creating libtool
checking for Win32... no
checking for aclocal flags...
checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding GLIB or finding the wrong
*** version of GLIB. If it is not finding GLIB, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
*** to the installed location Also, make sure you have run ldconfig if that
*** is required on your system
***
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/.
bash-2.05a#
I would appreciate any help. My New Years Resolution was not to destroy anymore innocent keyboards.

Excalibur 01-05-2003 07:26 PM

Slackware 8.1 installs glib-1.2.10. You will need to download, build, install. glib 2.0.0 or greater.

If you believe that you have done that, then make sure they are located in the /usr/lib directory tree as libglib* with version 2 numbers. If they are present, then try running the command "ldconfig" and then reattempt your build.

Good luck.

Allen614 01-05-2003 10:07 PM

"ldconfig" That was the problem. Thanx


All times are GMT -5. The time now is 04:08 AM.