-   Slackware (
-   -   gst-plugins-(good and ugly) not building, but bad does (

samac 09-06-2009 08:45 AM

gst-plugins-(good and ugly) not building, but bad does
The error message that I am getting is

/usr/lib/ could not read symbols: File in wrong format
. I am using Slackware64-13.0 (multi-lib), sbopkg 0.30.1 (13.0 repository). I had a look at the slackbuilds and and modified them to be the same as gst-plugins-bad but I still got the same error.

It is strange that it is not looking in /usr/lib64 for, but libgobject is in both.

Has anyone else seen this behaviour.


weibullguy 09-06-2009 09:33 AM

Try setting your PKG_CONFIG_PATH var to your 64-bit paths before you execute the configure script. For example

PKG_CONFIG_PATH="/usr/lib64/pkgconfig:/usr/local/lib64/pkgconfig" ./configure --prefix=/usr --libdir=/usr/lib64
See if that gets good and ugly to build.

ponce 09-06-2009 09:46 AM

i built 'em with a queue (the only way to pass options/export variables to slackbuilds that I know I can use with sbopkg)

gst-plugins-good | LDFLAGS="-L/usr/lib64 -L/lib64"
gst-plugins-bad | LDFLAGS="-L/usr/lib64 -L/lib64"
gst-plugins-ugly | LDFLAGS="-L/usr/lib64 -L/lib64"

save as /var/lib/sbopkg/queues/gst-plugins.sqf and

sbopkg -b gst-plugins.sqf
and accept queuefile options with Q

queues are great :D

weibullguy 09-06-2009 10:06 AM

Well, I'm not a Slackware user so I don't know the finer points of your package manager. The good and ugly configure scripts are looking for gobject.pc to get information regarding libgobject. The configure script is finding /usr/lib/pkgconfig/gobject.pc which is the one installed by your 32-bit glib. Obviously, they need to find /usr/lib64/pkgconfig/gobject.pc if you're building 64-bit good and ugly plugins. Therefore, you need to tell the configure script where to look. You do that with the PKG_CONFIG_PATH variable. Set it however your package manager requires it be set.

Ooops, I didn't notice poncez was replying to the OP; thought he was the OP.

Ilgar 09-06-2009 10:08 AM

sbopkg lets you set build options (check the menu with the options README,..., Build). You can use the option


LDFLAGS='-L/usr/lib64 -L/lib64'
to compile the package, as poncez suggested.

samac 09-06-2009 01:58 PM

Thanks poncez, that worked.


All times are GMT -5. The time now is 01:48 AM.