-   Slackware (
-   -   grub rescue? what in tarnation? (

chexmix 03-01-2013 08:23 PM

grub rescue? what in tarnation?
Hi everyone,

OK, this one is a complete mystery to me. I took my newish (Slack64 14.0) laptop in to work today to play around with perlbrew (we are considering using it at work). Everything seemed copacetic.

Tonight, I brought the laptop home, turned it on and was greeted with


GRUB loading.
Welcome to GRUB!

error: no such device: <slew of characters>
Entering rescue mode ...
grub rescue>

... which, err ... okay, but I have never used or installed grub on this machine! Only LILO.

What on earth could have happened?

I've tried booting from my Slack 14.0 DVD but have so far had no luck getting the machine to boot from the CD/DVD drive. I'm totally mystified.

If I issue an 'ls' command at the 'grub rescue' prompt, I see


(hd0) (hd0,1) (hd1) (hd1,5) (hd1,1)
I would be eternally grateful if anyone could shed some light on what could have happened.



chexmix 03-01-2013 09:03 PM

Well, I finally got the machine to boot from the Slack DVD.

But I still don't know where GRUB is coming from ... :S

I re-ran /sbin/lilo, but it didn't help.

chexmix 03-01-2013 09:10 PM

Uh, okay. I guess this is solved.

It seems the system was trying to boot from the external HD. Once I disconnected that and rebooted, all was well.

What GRUB is doing on that drive, I don't know. I'll deal with that tomorrow.

zrdc28 03-01-2013 11:48 PM

Go into the bios and set it first boot from hdd and you can leave the ext drive hooked up.

All times are GMT -5. The time now is 09:42 AM.