LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   grub hiccough (https://www.linuxquestions.org/questions/slackware-14/grub-hiccough-854180/)

business_kid 01-04-2011 12:39 PM

grub hiccough
 
I have the grub slackbuild instead of lilo and installed over a failed grub installation (all my partition numbers got wiped and they were out of order)

# grub install <anything I have tried so far> returns a silly error.
# grub setup <anything I have tried so far> returns a silly error.

Grubconfig did something. Grubconfig is some bash script bundled with grub. I have a working menu.lst, but it comes up with another table, something like the o/p of fdisk -l interpreted. For the linux partitions, it runs (hd0,x)/boot/vmlinuz This fails with an error, and I get an error message but no time to read it, after which I see menu.lst and I get my correct choices

Any idea how I can end this madness? It doesn't feel reliable as a method of booting.

syg00 01-04-2011 03:34 PM

Reading the doco is usually a good start. Error messages are generally put out for a reason.
I don't know grubconfig - must be specific to the slackbuild. Reading it should tell you what it's doing, and how it has set things up.

"install" and "setup" are sub-commands to (classic/legacy) grub, not parameters.

Larry Webb 01-04-2011 04:25 PM

I am curious, let us know if or when and how you fixed.

business_kid 01-05-2011 04:32 AM

I think I found it.Grub has installed to /boot/boot/grub as well as /boot/grub.

So I said haha, I'll check that and went and renamed /boot//boot/ to /boot/junk.
"Error, can't find grub files . . . " :-//.
That sends me back in with the install dvd one last time to sort that out. It's at times like this you are glad it's not a netbook.

Other possibly related collateral damage is that windows doesn't boot(even with /boot/boot/grub), as grub as supplied doesn't seem to like ntfs 'invalid partition type 7' (& middle digit from grub). That's hardly kosher.

business_kid 01-05-2011 05:55 AM

Well, I got it finally talking some sense. Getting /boot/boot out of the way normalised things and grub went back to being the dodgy boot loader it always was. I still somehow prefer it, because it is never as inscrutably awkward as lilo can be. Is that heresy for a slacker?

Thanks to all who offered wisdom on this.

EDIT: windows still doesn't boot. That has it's (low) place on the to-do list.

syg00 01-05-2011 03:11 PM

The /boot/boot is because of a symlink on "." (I think). Used to be explained in a FAQ, but the doco is disappearing.
For the NTFS issue, use "rootnoverify" instead of "root" for that stanza.


All times are GMT -5. The time now is 12:50 PM.