-   Slackware (
-   -   GRUB Error 15 Slackware 12 (

zeelog 01-07-2008 02:20 PM

GRUB Error 15 Slackware 12
I tried to install Slackware 12 DVD to /dev/hda2 on my 1 gig memory
system. Everything seemed to go right, though I noticed the install
didn't ask as may questions as past setup programs, but when I tried to
boot Slackware 12 it failed. I got this error message:
GRUB Error 15
Slackware 10, and latter, Slackware 11, both installed on this same
computer with no problems. What do I do now? Reinstall 10 or 11 ?
The Slackware 12 iso file passed the md5sum test, and the DVD passed
the check for flaws. Duh? Anybody got any ideas?

MoonMind 01-07-2008 03:20 PM

Probably an error on installation or some inapproriate entry in GRUB's menu.lst... Error 15 is "File not found", so either check the file (/boot/grub/menu.lst on my system - you need to know where / is, obviously) or try to reinstall either the system or GRUB.



jfxg 01-08-2008 10:58 AM

Slack 12 changed from the 2.4 kernel to 2.6 I have read that around 2.6.20 all drives changed to, in your case sda2. Slack still uses LILO so do you have have menu.lst some ware else, if so than try changing on the kernel line root=/dev/hda2 to sda2. The thing I normally do whith this happens is type 'c', without quotes to get a grub prompt. if this doesnt work type ESC to get out of the graphics mode and then type 'c'. at the grub prompt type help. look at find and geometry. I think the drive goes in Pren's eg (hd1),try it one way or the other. ESC gets you back to the menu and e allows you to edit an entry.
good luck

gearheadgeek 08-07-2009 06:00 PM

I don't know if this is your problem, but I just discovered a solution to the error 15 problem and maybe Google can help someone.

Grub 0.97 at least, maybe earlier, changed the location or method of saving the default. When it reads menu.lst and sees 'savedefault', it looks for .../grub/default which does not exist because 0.91 that I was using stores it somewhere else or someother way. Running 'grub-set-default 0' will let it boot as will removing 'savedefault' from the entry you are trying to boot. It took months to find this :(

All times are GMT -5. The time now is 06:26 PM.