-   Slackware (
-   -   google-earth-7.1.1-1580 failure (

perbh 08-27-2013 09:29 AM

google-earth-7.1.1-1580 failure
Downloaded the latest deb-file (I'm running 32-bit)and used the sbo-scripts - everything installed fine but the sucker bombs out when I try to run it.
And yes - have removed the persian font and set up the lib-link.
I'm using 14.0 and 3.7.1-kernel, intel graphics (not i915!)

Below is the error-message when starting it from a terminal:

$ google-earth
[0827/] Not implemented reached in bool net::HaveOnlyLoopbackAddresses()
[0827/] No URLRequestContext for OCSP handler.
[0827/] No URLRequestContext for OCSP handler.
[0827/] No URLRequestContext for OCSP handler.
[0827/] No URLRequestContext for OCSP handler.
[0827/] No URLRequestContext for OCSP handler.
[0827/] No URLRequestContext for OCSP handler.
[0827/] No URLRequestContext for OCSP handler.
Google Earth has caught signal 11.

We apologize for the inconvenience, but Google Earth has crashed.
 This is a bug in the program, and should never happen under normal
 circumstances. A bug report and debugging data have been written
 to this text file:


Please include this file if you submit a bug report to Google.

Does anyone have any suggestions?
Also (by looking at the first error-line - about loopback), I'm using a fixed ip-address but 'localhost' is (as always) set to ...

willysr 08-27-2013 09:38 AM

I also have the same error messageon the latest Google Earth (, but it worked normally after that
it seems that it requires 3D Acceleration hardware such as ATI and NVidia to work well

perbh 08-27-2013 09:48 AM

*big sigh* Thank you for the heads-up - so that means I'm screwed with this rig unless I go out and buy a nvidia-card and install the nvidia-driver (and no, I'm not touching ati!!)?

Does anyone have a version-6-something of google-earth? I used to use that and it worked fine, but then there is this irresistible urge to have the latest and shiniest ...

Oh and btw - I probably have the 1888-build - at least I downloaded the latest but the sbo-script said 1580, but the md5sums didn't match - so yes, guess I have 1888.

Also - mine crashes with the same error-message each time. removing and reinstall x times - still no difference. Running it several times - still crashing.

perbh 08-27-2013 10:33 AM

Hmmm - the 'most recent' is build-1580. There are several hits on build-1888, but they all (eventually) points back to google-earth download - and that is 1580.
Guess I just have to wait and see ... darn it!!

Sorry folks - I had only looked at the .info-file which carried '1580', so when I changed that to '1888' the resulting package still came out as '1580' - forgot to look in the .Slackbuild-file which has '1580' - the .info-file is seemingly not used ...
Seeing my md5sum is different from what's in .info - I guess I have the '1888'-version after all - still doesn't work though - no matter what I call it.

perbh 08-27-2013 01:43 PM

The rpm-version works when using rpm2tgz!! I still get the same error-message as in my first post, but it doesn't crash!
Go figger!

stereo 09-23-2013 12:07 PM

I have Slackware Current 32bit and Google Earth from Willies github and all works but no picture, only white frame.
When I right-click and select reload I get

404. Thatís an error.

The requested URL / was not found on this server. Thatís all we know.

willysr 09-23-2013 01:53 PM

Can you post a screenshot?

Can you also mention your machine specs? especially the GPU

stereo 09-23-2013 02:08 PM


Originally Posted by willysr (Post 5033307)
Can you post a screenshot?

Can you also mention your machine specs? especially the GPU

I can tell you right now that I'm using AMD radeon hd6750 with 13.8 beta driver. I am not at home but will post screenshot in a few hours.

stereo 09-23-2013 06:56 PM

Machine spec: AMD Athlon II x2 2.8 GHz, 6 GB ddr3, AMD Radeon HD6750 1GB ddr5.
System spec: Slackware-current, kernel 3.10.9, xorg 1.14.3, amd vga driver 13.8 beta.

I tought that problem is with my system but I tried at my friends computer that has nouvae driver, nvidia 6150se onboard vga, Slackware 14 and has the same problem.

Screenshots —> and

Google earth instaled from

Sorry for late answer.

willysr 09-23-2013 10:01 PM

I haven't tried with onboard VGA yet as i have NVidia GPU at my home
let me try on my workstation which has onboard NVidia VGA

willysr 09-23-2013 10:30 PM

Try the solution explained on this Google Forum: Adding this line:
export LC_NUMERIC=en_US.UTF-8
LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH ./googleearth-bin "$@"

stereo 09-23-2013 11:12 PM

No luck, all the same.

willysr 09-24-2013 09:48 AM

Hm... i got the same output, a white background with some text, but no images actually
this is on my main desktop:

Update: I tested with another location, this time a garden in Singapore and it does have image. Probably your location doesn't have image on Google's database. Check it out:

stereo 09-24-2013 02:40 PM

If it matters, locations with no picture in google earth has pictures on google maps. On some locations I do have text just like in your screenshots.

Thanks for effort anyway :)

willysr 09-24-2013 07:11 PM

i tested with the latest and it has the same problems :)

All times are GMT -5. The time now is 03:11 AM.