LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 10-24-2013, 05:49 PM   #1
pramono
LQ Newbie
 
Registered: Feb 2013
Location: Localhost
Distribution: Slackware
Posts: 20

Rep: Reputation: Disabled
Google Chrome 30 error nss 4.13.5 upgrade


hello slacker, google chrome error 30 in slackware 14, after I read at this http://www.linuxquestions.org/questi...-a-4175479232/ apparently nss default slackware 14 version not compatible to the chrome 30. but after I upgraded to version 3.15 nss chrome can not also be used, anybody helpme..
this error chrome
Code:
pramono@darkstar:~$ google-chrome
[2273:2300:1025/051137:FATAL:nss_util.cc(396)] NSS_VersionCheck("3.14.3") failed. NSS >= 3.14.3 is required. Please upgrade to the latest NSS, and if you still get this error, contact your distribution maintainer.
Aborted
this version nss on my machine
Code:
pramono@darkstar:~$ ls /var/log/packages/mozilla-nss-*
/var/log/packages/mozilla-nss-3.15.2-i486-2

Last edited by pramono; 10-24-2013 at 05:58 PM.
 
Old 10-24-2013, 06:05 PM   #2
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 836

Rep: Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620
Try adding these to the top of your /etc/ld.so.conf:

/lib
/usr/lib
 
1 members found this post helpful.
Old 10-24-2013, 06:33 PM   #3
pramono
LQ Newbie
 
Registered: Feb 2013
Location: Localhost
Distribution: Slackware
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by volkerdi View Post
Try adding these to the top of your /etc/ld.so.conf:

/lib
/usr/lib
I already follow, but it still does not work.
 
Old 10-24-2013, 06:51 PM   #4
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 836

Rep: Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620
OK, try running ldconfig (or rebooting) and try it again. You should see /opt/google/chrome/chrome linked to the libraries in /usr/lib if you check it with ldd.
 
1 members found this post helpful.
Old 10-24-2013, 07:11 PM   #5
pramono
LQ Newbie
 
Registered: Feb 2013
Location: Localhost
Distribution: Slackware
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by volkerdi View Post
OK, try running ldconfig (or rebooting) and try it again. You should see /opt/google/chrome/chrome linked to the libraries in /usr/lib if you check it with ldd.
thanks volkerdi. problem is solved. im rebooting my machine. thanks for helpfull.
 
Old 11-21-2013, 10:06 AM   #6
Ook
Member
 
Registered: Apr 2004
Location: Hell, Arizona
Distribution: Slackware 14.1
Posts: 326

Rep: Reputation: 25
I just wanted to pitch in here. I, too, have this problem:

./chrome: /usr/lib/seamonkey/libnss3.so: version `NSS_3.14.3' not found (required by ./chrome)

When trying to run chrome. The solution was, as indicated above, to do exactly this:

1) build and install the mozilla-nss package. I used the one found in the Slackware 14.1 source, which is 3.15.2.
2) As Volkerdi said, add these lines to the top of /etc/ld.so.conf:
/lib
/usr/lib
3) Run ldconfig (or reboot)

If I do not do all three steps, it won't work. If you forget to edit ld.so.conf, it won't work, if you don't run ldconfig or reboot, it won't work. If I do these three exact steps, chrome works great.

There seems to be a lot of confusion as to how to get this to work, so I wanted to consolidate what was mentioned above and say that this worked very well for me.

Edit 12/27/2013: On one of my systems I had to *remove* /usr/lib64/seamonkey from the bottom of /etc/ld.so.conf. Do this with care - I haven't had any problems, but I'm not sure what issues doing so may cause.

Interesting to note that the system where I did not have to do this is a 32 bit Slackware 14.0 system, and the system where I had to do it is a 64 bit Slackware 14.0 system. YMMV.

Last edited by Ook; 11-27-2013 at 09:42 AM.
 
1 members found this post helpful.
Old 12-04-2013, 08:12 PM   #7
pramono
LQ Newbie
 
Registered: Feb 2013
Location: Localhost
Distribution: Slackware
Posts: 20

Original Poster
Rep: Reputation: Disabled
Smile

Quote:
Originally Posted by Ook View Post
I just wanted to pitch in here. I, too, have this problem:

./chrome: /usr/lib/seamonkey/libnss3.so: version `NSS_3.14.3' not found (required by ./chrome)

When trying to run chrome. The solution was, as indicated above, to do exactly this:

1) build and install the mozilla-nss package. I used the one found in the Slackware 14.1 source, which is 3.15.2.
2) As Volkerdi said, add these lines to the top of /etc/ld.so.conf:
/lib
/usr/lib
3) Run ldconfig (or reboot)

If I do not do all three steps, it won't work. If you forget to edit ld.so.conf, it won't work, if you don't run ldconfig or reboot, it won't work. If I do these three exact steps, chrome works great.

There seems to be a lot of confusion as to how to get this to work, so I wanted to consolidate what was mentioned above and say that this worked very well for me.

Edit 12/27/2013: On one of my systems I had to *remove* /usr/lib64/seamonkey from the bottom of /etc/ld.so.conf. Do this with care - I haven't had any problems, but I'm not sure what issues doing so may cause.

Interesting to note that the system where I did not have to do this is a 32 bit Slackware 14.0 system, and the system where I had to do it is a 64 bit Slackware 14.0 system. YMMV.
Thankyou Ook.
 
Old 01-11-2014, 10:41 AM   #8
prastowo
LQ Newbie
 
Registered: Jan 2014
Posts: 1

Rep: Reputation: Disabled
ld.so got the wrong nss library

I found that the problem came from an old firefox installation. It happened that /etc/ld.so.conf.d had firefox.conf with a line of /opt/firefox. I removed the /etc/ld.so.conf.d/firefox.conf and rerun ldconfig. Now chrome-browser runs well on my computer.
 
1 members found this post helpful.
Old 01-20-2014, 10:24 PM   #9
pramono
LQ Newbie
 
Registered: Feb 2013
Location: Localhost
Distribution: Slackware
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by prastowo View Post
I found that the problem came from an old firefox installation. It happened that /etc/ld.so.conf.d had firefox.conf with a line of /opt/firefox. I removed the /etc/ld.so.conf.d/firefox.conf and rerun ldconfig. Now chrome-browser runs well on my computer.
that's good bro, what you come from Indonesia ?
 
  


Reply

Tags
chrome


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error starting Google Chrome. hackum Slackware 10 05-06-2011 01:40 PM
[SOLVED] google chrome: zlib and nss errors Vlinux6 Linux - Software 1 02-11-2011 09:21 AM
[SOLVED] Google Talk Plugin, Slackware64-Current, Google Chrome (Latest) and Multilib - Error Gavin Harper Slackware 3 01-04-2011 07:45 AM
[SOLVED] Google-Chrome Error (Error 9 (net::ERR_UNEXPECTED): Unknown error) smoooth103 Slackware 4 12-04-2010 07:42 PM
Build Chrome on Slackware-current fail--No package 'nss' found grissiom Slackware 12 09-06-2008 04:43 AM


All times are GMT -5. The time now is 12:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration