LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-03-2004, 08:54 AM   #1
munkie_poo
Member
 
Registered: Apr 2004
Location: Newcastle, UK
Distribution: Slackware 10.2
Posts: 134

Rep: Reputation: 15
gnome problem after swaret upgrade


Hi,
Ive recently upgraded slack 10 with swaret (10.0 not current) and Ive come across a few problems. First it was Xorg.conf.. which I have working now.

Now the problem I have is with gnome, whenever I log into gnome I get multiple error messages popping up, telling me that nautilus has quit unexpectedly.

Also there is no applications menu and I cant do anything in gnome really except use the action menu to log out.

Im using the normal gnome off the slack 10 CD, not dropline.

Also what I've done is, I noticed that swaret upgraded 'gnome-vfs' to version 2.8, so I uninstalled it and replaced it with the 2.6 version (as its gnome 2.6).

I first thought it was a gdm problem as there was no login screen.. So I switched 'rc.4' to load kdm. I tried logging into gnome again with the same problem.

KDE works fine, so I thought sod it, I'll live without gnome.. until I tried running firestarter, then it gave a gtk error, could not create interface.

Back into 'rc.4' I returned to gdm. I now have the login screen, firestarter + kde work but gnome still has the same problems.

anyone have any ideas?

thanks
 
Old 11-03-2004, 10:10 AM   #2
jtp51
Member
 
Registered: Dec 2002
Location: Omaha, Nebraska
Distribution: Ubuntu 8.10
Posts: 79

Rep: Reputation: 15
I've had the exact same issues.

Which kernel are you running?

After I reinstalled, yes... I had to reinstall... the way I got things to work was:

1. Use kernel 2.6.7

2. If you want sound, make sure you have Alsa compiled and set-up correctly.

3. Install the latest version of swaret

3b. Sound again: Double-check to make sure that if you upgrade Alsa, you don't blow it up by upgrading it with swaret. Geez... that's a killer.

4. In LQ: do a search for Shilo's swaret.config file, might be under a post by noxious...

5. Run swaret with Shilo's instructions that are with his swaret.config file.

That has worked for me on older hardware and my workstation at home without issues.

Be sure to take your time!

Last edited by jtp51; 11-03-2004 at 10:11 AM.
 
Old 11-03-2004, 11:51 AM   #3
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware 14.2
Posts: 1,268

Rep: Reputation: 59
if all else fails read the changelogs and see what you were supposed to remove/install that swaret didn't do.
 
Old 11-03-2004, 12:55 PM   #4
munkie_poo
Member
 
Registered: Apr 2004
Location: Newcastle, UK
Distribution: Slackware 10.2
Posts: 134

Original Poster
Rep: Reputation: 15
1/
Im using the standard 2.4 kernel, I was wanting to avoid upgrading the kernel as I use an alcatel speedtouch usb modem and I heard there was a few problems with the 2.6 kernel.


2/ um

3/
I use swaret 1.6.2.1, I think theres a newer version but its a pre-release.

4/
I followed shilo's guide...'heres how I do it all'.... I changed the swaret.conf like it says, but I didnt change it to current, only to 10.0 as the current aren't to stable. then I added a new address 'REPOS_ROOT=LinuxPackagesDOTNET%http://www2.linuxpackages.net/packages/Slackware-10.0'


I found the post by noxious and it mentions that it could be libcroco that could be the problem. I'll have a experiment with this.

I didnt get anywhere with libcroco, but I tried running nautilus from in kde and I recieved this error:

(nautilus:1495): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-
2.0/modules/libfile.so' (libfam.so.0: cannot open shared object file: No such fi
le or directory)


Ive installed 'fam' and it seems to work ok now.

thanks

Last edited by munkie_poo; 11-04-2004 at 03:52 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Gnome after swaret upgrade noxious Slackware 16 09-13-2004 05:42 AM
swaret upgrade from 9.1 to 10? virii Slackware 5 07-16-2004 02:16 PM
After swaret --upgrade -a....... Mingthefirst Slackware 2 07-09-2004 02:42 AM
Upgrade of Slack Gnome to current via swaret justaguynsrq Slackware 8 04-07-2004 06:38 AM
problem with swaret after a big upgrade Quartzophobia Slackware 5 02-17-2004 02:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration