LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   gnome problem after swaret upgrade (https://www.linuxquestions.org/questions/slackware-14/gnome-problem-after-swaret-upgrade-250605/)

munkie_poo 11-03-2004 09:54 AM

gnome problem after swaret upgrade
 
Hi,
Ive recently upgraded slack 10 with swaret (10.0 not current) and Ive come across a few problems. First it was Xorg.conf.. which I have working now.

Now the problem I have is with gnome, whenever I log into gnome I get multiple error messages popping up, telling me that nautilus has quit unexpectedly.

Also there is no applications menu and I cant do anything in gnome really except use the action menu to log out.

Im using the normal gnome off the slack 10 CD, not dropline.

Also what I've done is, I noticed that swaret upgraded 'gnome-vfs' to version 2.8, so I uninstalled it and replaced it with the 2.6 version (as its gnome 2.6).

I first thought it was a gdm problem as there was no login screen.. So I switched 'rc.4' to load kdm. I tried logging into gnome again with the same problem.

KDE works fine, so I thought sod it, I'll live without gnome.. until I tried running firestarter, then it gave a gtk error, could not create interface.

Back into 'rc.4' I returned to gdm. I now have the login screen, firestarter + kde work but gnome still has the same problems.

anyone have any ideas?

thanks

jtp51 11-03-2004 11:10 AM

I've had the exact same issues.

Which kernel are you running?

After I reinstalled, yes... I had to reinstall... the way I got things to work was:

1. Use kernel 2.6.7

2. If you want sound, make sure you have Alsa compiled and set-up correctly.

3. Install the latest version of swaret

3b. Sound again: Double-check to make sure that if you upgrade Alsa, you don't blow it up by upgrading it with swaret. Geez... that's a killer.

4. In LQ: do a search for Shilo's swaret.config file, might be under a post by noxious...

5. Run swaret with Shilo's instructions that are with his swaret.config file.

That has worked for me on older hardware and my workstation at home without issues.

Be sure to take your time!

ringwraith 11-03-2004 12:51 PM

if all else fails read the changelogs and see what you were supposed to remove/install that swaret didn't do.

munkie_poo 11-03-2004 01:55 PM

1/
Im using the standard 2.4 kernel, I was wanting to avoid upgrading the kernel as I use an alcatel speedtouch usb modem and I heard there was a few problems with the 2.6 kernel.


2/ um

3/
I use swaret 1.6.2.1, I think theres a newer version but its a pre-release.

4/
I followed shilo's guide...'heres how I do it all'.... I changed the swaret.conf like it says, but I didnt change it to current, only to 10.0 as the current aren't to stable. then I added a new address 'REPOS_ROOT=LinuxPackagesDOTNET%http://www2.linuxpackages.net/packages/Slackware-10.0'


I found the post by noxious and it mentions that it could be libcroco that could be the problem. I'll have a experiment with this.

I didnt get anywhere with libcroco, but I tried running nautilus from in kde and I recieved this error:

(nautilus:1495): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-
2.0/modules/libfile.so' (libfam.so.0: cannot open shared object file: No such fi
le or directory)


Ive installed 'fam' and it seems to work ok now.

thanks


All times are GMT -5. The time now is 03:12 PM.