LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-14-2014, 04:19 AM   #1
slacksam
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Slackware, Salix, slarm64
Posts: 211

Rep: Reputation: 38
Question glade 3.18.2 on slackware 14.1: "undefined symbol: g_type_add_instance_private"


Hi,
some time ago I managed to install glade 3.18.2 on Slackware 14.1 (see also py3cairo slackbuild fails and pygobject3 slackbuild fails) but since then I haven't used it, yet.
But when I start glade from a terminal window, it throws me this error message:
Quote:
glade: symbol lookup error: glade: undefined symbol: g_type_add_instance_private
and exits.

What's the reason for this error and how can I fix it?
 
Old 06-14-2014, 05:40 AM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 4,705

Rep: Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809
I think that version of glade requires newer glib2 than what we have in Slackware 14.1
See here: http://upstream-tracker.org/compat_r...at_report.html

my suggestion is to downgrade to glade 3.8.3

Last edited by willysr; 06-14-2014 at 05:42 AM.
 
Old 06-14-2014, 06:36 AM   #3
slacksam
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Slackware, Salix, slarm64
Posts: 211

Original Poster
Rep: Reputation: 38
Thanks for your reply, willysr.

Now I upgraded glib2 from version 2.36.4 to version 2.38.2 and the error message has changed to
Quote:
glade: symbol lookup error: glade: undefined symbol: gtk_widget_class_set_template_from_resource
When upgrading to version 2.40.0, the error message is the same.

Glade 3.8.3 seems to work fine, but I'd also like to use a more current version.
 
Old 06-14-2014, 06:44 AM   #4
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 4,705

Rep: Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809
You will need to upgrade to GTK+3-3.10 or newer to fix that problem
https://developer.gnome.org/gtk3/sta...ndex-3-10.html

However, upgrading glib/gtk+3 may require you to rebuild/patch other applications depending on both libraries

Last edited by willysr; 06-14-2014 at 06:45 AM.
 
Old 06-14-2014, 07:33 AM   #5
slacksam
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Slackware, Salix, slarm64
Posts: 211

Original Poster
Rep: Reputation: 38
Now I upgraded gtk+3 from version 3.8.2 to 3.13.1 and the error message now is:
Quote:
(glade:10158): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:2597:41: Expected a valid selector

(glade:10158): GLib-GIO-ERROR **: Settings schema 'org.gtk.Settings.FileChooser' does not contain a key named 'startup-mode'
Trace/breakpoint trap


Glade 3.8.3 still seems to work fine.
 
Old 06-14-2014, 09:14 AM   #6
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 4,705

Rep: Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809Reputation: 1809
you have to upgrade other GTK+ related libraries as well such as pango, gdk-pixbuf, atk, gobject-introspection, and many more....
that's why it's recommended to stick with the one supplied with Slackware

See this : http://www.gtk.org/download/linux.php
 
  


Reply

Tags
error message, fix, glade, slackware 14.1, symbol


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get install snmpd gives error" undefined symbol: boot_DynaLoader" renuaseri Linux - Newbie 9 07-29-2016 12:15 AM
Error message "undefined symbol" when executing the command import from gasrine Linux - Software 1 11-23-2010 09:43 AM
plesk + php 4.3.2 upgrade error - "undefined symbol: ap_signal" p_s_shah Linux - Server 0 10-30-2007 12:41 PM
Slackware 11 - Lilypond 2.10.25 - "undefined symbol: FT_Sfnt_Table_Info" ErV Linux - Software 1 06-04-2007 07:42 PM
avgscan "relocation error" "undefined symbol: __dynamic_cast_2" Monster_user Linux - Software 0 02-22-2006 11:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration