LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-08-2003, 01:47 AM   #16
Carpo
Member
 
Registered: Aug 2003
Location: Somewhere
Distribution: Gentoo (for now)
Posts: 364

Rep: Reputation: 30

hmmmm - i did remove a few fonts the kde font installer did not like - it did complain of a few bad ttf,

I'll will do as you say and install them in grps (not one by one, would take to long have about 300 i need to install)

thanks for your help

Last edited by Carpo; 09-08-2003 at 01:48 AM.
 
Old 09-08-2003, 07:57 PM   #17
wpichl
LQ Newbie
 
Registered: Sep 2003
Location: Austria
Distribution: Slackware
Posts: 3

Rep: Reputation: 0
A supplement to the font discussion in this thread:

I have downloaded several fonts from the Internet which did not work in X resp. KDE. Originally they were TTF fonts, later I converted them into Type1.
In both cases their names appear in the list (-> fontpath OK) but they are not displayed. A default font (arial or something like that) appears instead.

O.K., suppose these fonts are corrupted.

But surprisingly the corrupted fonts work well in Staroffice 6, on the screen as well as in printing !

Difficult to understand....
 
Old 11-14-2003, 11:00 AM   #18
simbolo
Member
 
Registered: Mar 2002
Location: US, CT
Distribution: Gentoo
Posts: 56

Rep: Reputation: 15
gnome-font-properties

I have follwed all of the intructions, installed the new bitstream font package that Patrik so kindly provided, but my problem is that when X starts my fonts are very very tiny in GTK2 and KDE apps. Then when i run gnome-font-properties and do not change anything just hit OK then the next GTK2 or KDE app i start is using properly sized TTF font until i restart X then it goes back to teeny tiny fonts.

Anyone have an idea what is happening?

Last edited by simbolo; 11-14-2003 at 11:01 AM.
 
Old 11-18-2003, 10:10 PM   #19
barazor
Member
 
Registered: Dec 2001
Distribution: slack 9.1
Posts: 44

Rep: Reputation: 15
i follow all the steps and for some odd reason i keep getting this error:

kyle@scarabrae:/usr/X11R6/lib/X11/fonts/TTF$ xset +fp /usr/X11R6/lib/X11/fonts/TTF/
xset: bad font path element (#175), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax

anybody have a fix for me? i don't any of that stuff should be at fault, since i chmoded the files and used mkfontdir and such

[edit] i just noticed that gaim uses all the new fonts...but no dice for anything else

Last edited by barazor; 11-18-2003 at 10:16 PM.
 
Old 11-19-2003, 11:18 AM   #20
Rodrin
Member
 
Registered: May 2003
Location: Upstate NY, U.S.
Distribution: Slackware
Posts: 248

Rep: Reputation: 31
Well, the command looks like the proper syntax from here. It's also possible, I guess, that one of the elements already in your font path is incorrect in your XF86Config file. You could check that. The font files appear to have the correct permissions since they are working for gaim, a fontconfig enabled program. It would appear that your problem lies either in your X configuration or in the fonts.dir or fonts.scale files, simply judging by which programs have a problem and which don't. You should note that the xset statements should not be necessary at all to get the fonts to work for all your programs. They are only necessary to add fonts to an Xsession that is already started. You do not need these statements if you have restarted your server.

Last edited by Rodrin; 11-19-2003 at 11:21 AM.
 
Old 11-19-2003, 01:43 PM   #21
barazor
Member
 
Registered: Dec 2001
Distribution: slack 9.1
Posts: 44

Rep: Reputation: 15
i noticed this when i exited from X:

Could not init font path element /usr/X11R6/lib/X11/fonts/TTF/, removing from list!

any ideas? i could always get my fonts to work before(through xfstt) but i'm a bit stumped on this. i can only get programs that use fontconfig to recognise them
 
Old 11-19-2003, 04:24 PM   #22
barazor
Member
 
Registered: Dec 2001
Distribution: slack 9.1
Posts: 44

Rep: Reputation: 15
i figured it out!

i decided to try adding fonts by their corresponding alphabet letter(to save time). when i got to "F", i would get the xset +fp... error. turns out that i had 2 fonts that started with "F" but they had spaces in the file name. apparently xset doesn't like that, so i changed it and i'm on my way
 
Old 12-26-2003, 11:59 AM   #23
paledread
LQ Newbie
 
Registered: Aug 2003
Distribution: debian
Posts: 22

Rep: Reputation: 15
truetype fonts install

Thanks to Rodrin for that superb original post back in May. It simplified the whole process of installing Truetype fonts.

Just a couple extra notes that seemed to be necessary (for me in Slackware 9.1).

Fonts starting with an uppercase letter need to be renamed to start with a lowercase letter. The presence of fonts starting with an uppercase letter seems to stop some apps (for me, the gimp and gnp+) from recognising all of the newly installed Truetype fonts. In fact to be sure, I changed all characters in the font name to lowercase. Not sure if this is necessary. Rerun fc-cache, mkfontscale, and mkfontdir after changing the font names.

The fonts.scale file seems to need permissions of 444. Easy to change this to 644 without trying, when you change permissions on the *.ttf files, and it seemed to create problems for me until changed back to 444.

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help - it's driving me nuts! n4ogl Linux - Newbie 4 11-13-2005 09:28 PM
Yast is driving me nuts! brianthegreat SUSE / openSUSE 16 10-31-2005 10:15 AM
Driving me nuts!! jappstam12345 Linux - Newbie 7 03-11-2005 05:51 PM
This is driving me nuts! dareino Fedora 4 06-30-2004 02:17 AM
driving me nuts!!! ihatebillgates Linux - Newbie 6 12-12-2003 07:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration