LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-27-2018, 07:27 AM   #1
jkh2cpu
Member
 
Registered: Feb 2014
Location: Michigan, USA
Distribution: slackware
Posts: 36

Rep: Reputation: Disabled
GIMP-2.10.0 is out.


It's out on git at least. When should we expect to see it show up in slackware-current? While we're at it, darktable is a great way to begin the editing process of RAW files.

I've been using 16 bit gimp since it showed up on git in spring, 2012. It's always been better than the 8 bit version, no matter what the bumps in the road were like.

John.
 
Old 04-27-2018, 11:47 AM   #2
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 4,149
Blog Entries: 1

Rep: Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463
Oops! Sorry, I didn't see this topic until I had already posted a similar message in the "Requests for -current" thread.

Last edited by cwizardone; 04-27-2018 at 11:48 AM.
 
Old 04-27-2018, 12:00 PM   #3
ziprun
Member
 
Registered: Apr 2018
Posts: 31

Rep: Reputation: Disabled
I asked in "Requests for -current" but I'll ask again here: We can expect gimp for 14.2 to be updated very soon, yes?
 
1 members found this post helpful.
Old 04-27-2018, 12:04 PM   #4
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 8,416

Rep: Reputation: 3445Reputation: 3445Reputation: 3445Reputation: 3445Reputation: 3445Reputation: 3445Reputation: 3445Reputation: 3445Reputation: 3445Reputation: 3445Reputation: 3445
Quote:
Originally Posted by ziprun View Post
I asked in "Requests for -current" but I'll ask again here: We can expect gimp for 14.2 to be updated very soon, yes?
No.

Stable only gets security updates.

Last edited by dugan; 04-27-2018 at 12:10 PM.
 
2 members found this post helpful.
Old 04-27-2018, 04:23 PM   #5
Ne01eX
Member
 
Registered: Mar 2018
Location: Ekaterinburg region, Ural, Russian Federation
Distribution: Slackware, RTK GNU/Linux
Posts: 173

Rep: Reputation: 22
Post

0. Look this attach:

1. My list of dependencies for gimp-2.10.0:

Code:
aalib = 1.4rc5
alsa-lib = 1.1.6
atk = 2.28.1
babl = 0.1.46
bzip2 = 1.0.6
cairo = 1.15.12
expat = 2.2.5
fontconfig = 2.13.0
freetype = 2.9
fribidi = 0.19.7
gcc = 7.3.0
gcc-g++ = 7.3.0
gdk-pixbuf2 = 2.36.12
gegl = 0.3.34
gexiv2 = 0.10.8
ghostscript = 9.23
glib2 = 2.56.1
glibc = 2.27
gtk+2 = 2.24.32
harfbuzz = 1.7.6
ilmbase = 2.2.1
json-c = 0.13.1_20180305
json-glib = 1.2.8
lcms2 = 2.9
libICE = 1.0.9
libSM = 1.2.2
libX11 = 1.6.5
libXcursor = 1.1.15
libXext = 1.3.3
libXfixes = 5.0.3
libXmu = 1.1.2
libXpm = 3.5.12
libXt = 1.1.5
libgudev = 232
libjpeg-turbo = 1.5.3
libmng = 2.0.3
libmypaint = 1.3.0
libpng = 1.6.34
librsvg = 2.42.3
libtiff = 4.0.9
libwebp = 0.6.1
libwmf = 0.2.8.4
openexr = 2.2.1
openjpeg = 2.3.0
pango = 1.42.1
poppler = 0.64.0
xz = 5.2.3
zlib = 1.2.11
2. If you need other scripts, then tell me, I will attach it. :-)

Best regards, Standartenführer S and R, Aleksandr "Ne01eX" Sayfulin.

Attached Files
File Type: txt GIMP-2.10.x-TREE.tar.lz.txt (8.1 KB, 20 views)
 
Old 04-27-2018, 06:11 PM   #6
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 910

Rep: Reputation: 200Reputation: 200Reputation: 200
A great time to be on -current
 
1 members found this post helpful.
Old 05-02-2018, 08:19 PM   #7
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 910

Rep: Reputation: 200Reputation: 200Reputation: 200
Thanks PV and team:

Code:
Tue May  1 20:43:20 UTC 2018
[...]
l/gexiv2-0.10.8-x86_64-1.txz:  Added.
  Required by gimp-2.10.0.
l/json-c-0.13.1_20180305-x86_64-1.txz:  Added.
  Looks like we're getting this package back since libmypaint needs it.
[...].
x/libmypaint-1.3.0-x86_64-1.txz:  Added.
  Required by gimp-2.10.0.
x/mypaint-brushes-1.3.0-noarch-1.txz:  Added.
  Required by gimp-2.10.0.
xap/gimp-2.10.0-x86_64-1.txz:  Upgraded.
Gratuitous screenshot here...

 
1 members found this post helpful.
Old 05-02-2018, 08:45 PM   #8
Mobile1
Member
 
Registered: Jun 2006
Location: Abbotsford, B.C.
Distribution: Slackware64 14.2
Posts: 163

Rep: Reputation: 26
Quote:
Originally Posted by andrew.46 View Post
A great time to be on -current
I'm on -current and GIMP still doesn't work.
 
1 members found this post helpful.
Old 05-02-2018, 09:22 PM   #9
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 910

Rep: Reputation: 200Reputation: 200Reputation: 200
Quote:
Originally Posted by Mobile1 View Post
I'm on -current and GIMP still doesn't work.
Works like a dream here.... error messages on your system?
 
Old 05-02-2018, 09:25 PM   #10
Mobile1
Member
 
Registered: Jun 2006
Location: Abbotsford, B.C.
Distribution: Slackware64 14.2
Posts: 163

Rep: Reputation: 26
Quote:
Originally Posted by andrew.46 View Post
Works like a dream here.... error messages on your system?
None when running it from KDE GUI - but if I run it at the Command Line - there is an error. I'm on a different computer right now, don't recall the error - something to due with a missing library file.
 
1 members found this post helpful.
Old 05-02-2018, 09:26 PM   #11
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,369

Rep: Reputation: Disabled
I would guess you failed to install the new dependencies in current.
 
2 members found this post helpful.
Old 05-02-2018, 09:38 PM   #12
Mobile1
Member
 
Registered: Jun 2006
Location: Abbotsford, B.C.
Distribution: Slackware64 14.2
Posts: 163

Rep: Reputation: 26
Quote:
Originally Posted by orbea View Post
I would guess you failed to install the new dependencies in current.
Yep, you are correct.
 
Old 05-02-2018, 09:53 PM   #13
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 910

Rep: Reputation: 200Reputation: 200Reputation: 200
Quote:
Originally Posted by Mobile1 View Post
None when running it from KDE GUI - but if I run it at the Command Line - there is an error
Hmmm.... from command line I get this:

Code:
andrew@illium~$ gimp
GEGL-Message: 12:48:19.696: Module '/usr/lib64/gegl-0.4/ff-load.so' load error: libavformat.so.57: cannot open shared object file: No such file or directory
GEGL-Message: 12:48:19.700: Module '/usr/lib64/gegl-0.4/ff-save.so' load error: libavformat.so.57: cannot open shared object file: No such file or directory
Missing fast-path babl conversion detected, Implementing missing babl fast paths
accelerates GEGL, GIMP and other software using babl, warnings are printed on
first occurance of formats used where a conversion has to be synthesized
programmatically by babl based on format description

*WARNING* missing babl fast path(s): "R'G'B' double" to "CIE Lab double"
Certainly the libavformat issue is my own problem as I use the git FFmpeg which at the moment has:

Code:
libavformat    58. 10.100 / 58. 10.100
while doubtless the stock -current FFmpeg holds the required version. I had no idea that Gimp used libavformat but this does not effect running the application as far as I can see...
 
Old 05-02-2018, 11:35 PM   #14
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,369

Rep: Reputation: Disabled
If you are using the git ffmpeg then your only choice at the moment is to rebuild gegl with --without-libavformat, gegl doesn't currently build with the newer ffmpeg API in their git master.
 
1 members found this post helpful.
Old 05-03-2018, 01:17 AM   #15
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 910

Rep: Reputation: 200Reputation: 200Reputation: 200
Quote:
Originally Posted by orbea View Post
If you are using the git ffmpeg then your only choice at the moment is to rebuild gegl with --without-libavformat, gegl doesn't currently build with the newer ffmpeg API in their git master.
Thanks, I have done this and now just the message:


Code:
andrew@illium~$ gimp
Missing fast-path babl conversion detected, Implementing missing babl fast paths
accelerates GEGL, GIMP and other software using babl, warnings are printed on
first occurance of formats used where a conversion has to be synthesized
programmatically by babl based on format description

*WARNING* missing babl fast path(s): "R'G'B' double" to "CIE Lab double"
which a casual google reveals has puzzled many people...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: GIMP 2.10 Development Continues, GIMP 2.9.4 Lands New Features After 8 Months LXer Syndicated Linux News 0 07-13-2016 04:31 AM
LXer: GIMP Painter And GIMP Paint Studio Transform GIMP Into The Ultimate Painting Tool LXer Syndicated Linux News 0 02-08-2011 05:40 PM
LXer: Gimp Paint Studio(GPS)- A collection of brushes and accompanying tool presets for GIMP LXer Syndicated Linux News 0 02-02-2011 02:13 AM
LXer: Gimp Paint Studio [Gimp Optimized for Drawing and Painting] LXer Syndicated Linux News 0 05-04-2009 01:30 PM
printing on HP PhotoSmart from Gimp 2.2, gimp-print drivers needed? pearman Debian 2 08-05-2005 04:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration