-   Slackware (
-   -   Ghostview trouble on Slackware 12.0 (

trashbird1240 08-14-2007 10:03 PM

Ghostview trouble on Slackware 12.0

I've switched my work machine to Slackware 12.0 and am really enjoying (finally have the widescreen working!).

However, I'm having this seemingly common problem with Ghostview and its brethren:


ERROR: /invalidfont in findfontESP Ghostscript 815.04: Unrecoverable error, exit code 1

So it's clear that the fonts needed for the document are not found. However I've checked all the font paths, re-run the scripts and to no avail.

I say "common" because I reproduced the same problem at home, and I've seen plenty of posts about it. I tried deleting the font configuration files in my home directory, but that did not help. I have all the packages installed, and I've re-run the mkfontdir and fontconfig scripts as suggested in UPGRADE.TXT.

I've also read posts by people describing the same problem leading to the exact printer problem I've been having at home (where I rely on gimp-print).

It seems like an easy thing to fix, if I just knew how to fix it ;)

Has anyone solved this?


trashbird1240 08-15-2007 10:06 AM

Solved according to this thread:

upgradepkg --reinstall  ghostscript-fonts-std-8.11-noarch-1.tgz

All times are GMT -5. The time now is 12:46 AM.