-   Slackware (
-   -   Getting Sound to work with intel8x0 in Slackware 12 - alsaconf finds hda-intel (

thethinker 01-24-2008 02:42 PM

Getting Sound to work with intel8x0 in Slackware 12 - alsaconf finds hda-intel
Hey all,
I'm trying to get my sound card to work with my new install of Slack 12. I found my soundcard and it claims to use the driver intel8x0. So I downloaded the drivers, util, tools, and lib from the ALSA site and installed them. The problem is that when I run alsaconf, the driver it wants to use is snd-hda-intel, not the one I got which is supposed to work. I've tried using hda-intel (by unmuting sound, changing permissions etc), but it doesn't seem to work.

So I tried to insert the correct module by hand: modprobe snd-intel8x0, snd-pcm-oss, snd-mixer-oss, and snd-seq-oss (as per ALSA wiki). They go in fine, but it still doesn't seem to work. In addition, when I restart the system goes back to using hda-intel as the sound card (using lsmod to check).

So, perhaps if we can start with some way to convince my system to load intel8x0 instead of hda-intel. Once that gets loaded on restart I think I might have more luck, so where can I do that by hand/convince alsaconf that it's the right thing to do?

Or does anyone know enough about this sound card:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
To know if hda-intel is actually ok?

Thanks for any help.

animeresistance 01-24-2008 04:15 PM

I got some similar problem, i have 2 soundcards, but 1 is not working and is on the motherboard, the other is a soundblaster, slackware recognized both soundcards, but it only used the one on the MB (VIA) i just removed the modules of the VIA soundcard manually and now it only uses my soundblaster card =). I hope this work for you ... but first you must check if you have both modules of the soundcard loaded, you should use lsmod to check it ... for removing modules you can use rmmod, if you are not sure you can check the manual .. bash$: man rmmod ...

Hope this help you ....

jespinal 01-24-2008 04:28 PM


When you say that it does not works; do you refer to some kind of error message?

If you are getting no sound, but did not get any error message; have you tried to use alsamixer to adjust the sound?


Hangdog42 01-24-2008 05:30 PM

I've got that sound chip in my laptop and it runs fine with snd-hda-intel. However, when I did a new install of Slackware 12, it didn't work. It only started when I made my custom kernel ( I have seen some postings elsewhere suggesting that the hda_intel driver was broken in a couple of kernel versions, so you might try a different kernel version.

drumz 01-24-2008 06:45 PM

Just to back up Hangdog42, I've got that same card. It doesn't work on kernels <= 2.6.22, but it does work on >=2.6.23 (or so I've read). I haven't upgraded my kernel yet, but when I do I'll post back with my results.

thethinker 01-24-2008 09:06 PM

jaspinel: I get no sound at all. No error messages, no fuzzing, nothing. I tried raising the volume with alsamixer (also with Xfce sound and kmix) but that doesn't help. I've also tested aplay, play, and cat <file> /dev/dsp.

Other: I have no tried a new kernel yet, I am running the default slack 12 which I think is before 2.6.23, so perhaps that will work. Redoing an entire kernel is scary, but I have some experience with recompiling so maybe I will give it a shot. Would you guys suggest getting the new kernels from the main source page (I forget where) or are there more that would work on the slackware install disks?

duryodhan 01-25-2008 04:05 AM

try running speaker-test.

cat /dev/random > /dev/dsp doesn't work for me either , but I can listen to songs.

gopi.d 01-25-2008 04:27 AM

i guess you have loaded the wrong modules intel8x0 is for old oss modules for alsa it is snd-hda-intel. you can just type alsaconf in terminal and the script will do the rest of all after running the script run alsamixer and set the volume and run alsactl store to store the settings. if it does not work download the latest alsa drivers and compile with optins for your card.

drumz 01-25-2008 09:16 AM

I just upgraded to kernel and sound works for me now. You'll need snd_hda_intel either compiled in or as a module. If you don't want to upgrade your kernel, you could try upgrading alsa like others have suggested.

Also, make sure to run alsamixer and make sure everything's not muted.

thethinker 01-25-2008 09:54 AM

speaker-test didn't work. It ran very nicely but didn't give me any sound. I've gotten new drivers from the ALSA website (I'm running 1.0.15 now), alsaconf still detects hda-intel, but still no sound. I haven't messed with any options when I modprobe it because I haven't found any sites that talk about options that work. I guess kernel recompile is the next reasonable step! (I'm running, so according to the above hda-intel might be broken in mine).

EDIT: As a sidenote, I HAVE updated 1.0.15. I recompiled the drivers, so is there any reason ALSA might be finding the wrong version of hda-intel? When I modinfo hda-intel, it tells me the directory is my kernel directory, not the place where I installed the new ALSA drivers. Do I need to recompile my kernel AFTER installing the new drivers?

trunix 01-26-2008 03:03 PM

had the same problem and fixed it here is the report.

thethinker 01-26-2008 07:30 PM

Yup, I found it yesterday thanks everyone! For the record, it's a crazy bug that affects just my card, putting the model is as 3stack works great (since it's a Sager laptop perhaps). Anyway, issue closed!

All times are GMT -5. The time now is 06:56 PM.