LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-19-2014, 06:50 PM   #46
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 2,446

Rep: Reputation: 251Reputation: 251Reputation: 251

Quote:
Originally Posted by dugan View Post
Got help from this thread. SOLVED] Proper pulseaudio setup for Slackware64-current They were:

Install alsa-plugins as well as pulseaudio

Add start-pulseaudio-x11 to ~/.config/openbox/autostart (because I'm using openbox)

Add to /etc/rc.d/rc.local:

Code:
if [ -x /etc/rc.d/rc.pulseaudio ]; then
	/etc/rc.d/rc.pulseaudio start
fi
Make /etc/rc.d/rc.pulseaudio executable and start it up

Add the following ~/.asoundrc

Code:
pcm.pulse {
    type pulse
}
ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}
......
This thread renewed my interest in using the HDMI audio on my video card and I finally managed to get it to work, sort of, via (ugh) PulseAudio.
Sort of means it works for system notifications and playing DVDs/CD, but I haven't been able to make it work via a browser on such sites as YouTube and HBO Go.

When I tried to start PulseAudio with the rc.local file it generated this error:

Quote:
E: [pulseaudio] core-util.c: Failed to create secure directory (/var/lib/pulse/.config/pulse): No such file or directory
Starting pulseaudio...
W: [pulseaudio] authkey.c: Failed to open cookie file '/var/lib/pulse/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authorization key '/var/lib/pulse/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to open cookie file '/var/lib/pulse/.pulse-cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authorization key '/var/lib/pulse/.pulse-cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to open cookie file '/var/lib/pulse/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authorization key '/var/lib/pulse/.config/pulse/cookie': No such file or directory
No protocol specified
E: [pulseaudio] client-conf-x11.c: xcb_connection_has_error() returned true
E: [autospawn] core-util.c: Failed to create secure directory (/var/lib/pulse/.config/pulse): No such file or directory
W: [autospawn] lock-autospawn.c: Cannot access autospawn lock.
E: [pulseaudio] main.c: Failed to acquire autospawn lock
Any ideas?
Thanks.

Last edited by cwizardone; 07-22-2014 at 11:11 PM. Reason: Typo.
 
Old 07-20-2014, 01:17 PM   #47
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 2,446

Rep: Reputation: 251Reputation: 251Reputation: 251
Before shutting down the computer last night I commented out the instructions in rc.local to start rc.pulseaudio and checked the ~/.asoundrc file. Maybe I was so tired I couldn't see the error, but just to be on the safe side I deleted the file and created a new one using Dugan's example (copy and paste).
This morning there were no errors on bootup and all sound is being ran through pulseaudio, including flash, widevine, etc.
I'm not too happy about using anything created by pottering (sp), but it does fix the low volume problem I've had since the .3.9.5 kernel. I don't know what is "under the hood," but it works and works well, and for the first time can I fully use the HDMI audio on the Nvidia card, AND turn the volume up enough that the monitor speakers are useful.
With the equalizer in VLC and other applications, the sound is pretty good. There is suppose to be an equalizer for pulseaudio, but I can't find a package for Slackware64 or a script on slackbuilds. If the pulseaudio equalizer is half as good as the others, the quality should get close to that of external speakers.
Thanks, Dugan.
 
Old 07-20-2014, 01:56 PM   #48
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,687

Rep: Reputation: Disabled
Quote:
Originally Posted by cwizardone View Post
I'm not too happy about using anything created by pottering (sp), but it does fix the low volume problem I've had since the .3.9.5 kernel. I don't know what is "under the hood," but it works and works well, and for the first time can I fully use the HDMI audio on the Nvidia card, AND turn the volume up enough that the monitor speakers are useful.
One of the most-visited and referred-to (especially on other distro forums) articles on my blog is http://alien.slackbook.org/blog/addi...-sound-levels/ . You do not need Pulseaudio to crank up the sound on your computer if ALSA is having issues with your hardware. The pre-amp will compensate sufficiently in most cases.

Eric
 
2 members found this post helpful.
Old 07-20-2014, 05:28 PM   #49
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 2,446

Rep: Reputation: 251Reputation: 251Reputation: 251
Thank you for the suggestion, but it didn't work with this computer. I tried both of your suggested configurations and both with "hw" or "plug" and there was no pre-amp to be found in the alsamixer.
Thanks, again, for the thought.
 
Old 09-29-2014, 10:11 PM   #50
dugan
Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 5,633

Original Poster
Rep: Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766
Quote:
Originally Posted by genss View Post
.asoundrc in HOME
Code:
pcm.!default {
  type hw
  card 1
  device 3
}
Code:
defaults.pcm.card 1
defaults.pcm.device 3
defaults.ctl.card 1
I found out something quite important today: the two are not equivalent.

The first one overrides all of the PCM default settings in /usr/share/alsa/alsa.conf. That means that it throws away all of the plugin settings that would otherwise be there for the default PCM device (including DMix), and thus limits you to only playing one sound at a time.

The second one overrides only the settings listed, and keeps the rest at default. That means that it keeps the software mixing settings, etc. With the second one, you get the same ALSA settings that you usually get (software mixing and all): just outputting to the HDMI port.

Reference:
https://wiki.archlinux.org/index.php...e#Basic_syntax

I'm going to be trying again with the following settings, because for me it's device 7 that's listed as valid:

Code:
defaults.pcm.card 1
defaults.pcm.device 7
defaults.ctl.card 1
If I get the out-of-sync, delayed audio again, then I'm not going to try to solve it with Pulseaudio. I'm going to conclude that it's a hardware issue and give up. I'll post another update about that within a week.

UPDATE: Okay, this isn't working. If I watch a Super Mario Bros. speedrun on Youtube (which is a a good way to test for A/V sync issues), I can see the audio and video becoming less and less synchronized as time goes on. It's not as bad as I've had with other setups (it gets to be mistimed by less than a second now), and it gets better immediately if I turn off player and start it again. But if I have perfect A/V sync with my USB sound card and glitchy A/V sync over HDMI, which one am I going to choose?

Last edited by dugan; 09-30-2014 at 11:56 AM.
 
1 members found this post helpful.
Old 09-30-2014, 09:30 AM   #51
genss
Member
 
Registered: Nov 2013
Posts: 632

Rep: Reputation: Disabled
the first version does not have ctl
Code:
ctl.!default {
        type hw;
        card 1;
}
as per the reference you linked, they should do exactly the same

as for the sync issue
it's probably nvidia's hdmi implementation
try asking here

how much is it out of sync ?
48000/44100 times or less ?
 
Old 09-30-2014, 09:49 AM   #52
dugan
Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 5,633

Original Poster
Rep: Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766
Quote:
Originally Posted by genss View Post
how much is it out of sync ? 48000/44100 times or less ?
That's an interesting question. I can't determine that by eyeballing it. What do you recommend trying?

And, I checked again: the nested version and the three-line versions are not the same. The nested version has no DMix, and the three-line version has DMix. The reference that I linked to does claim (or at least clearly imply) that they should be the same, but there's an earlier section about syntax that directly contradicts that. It's the section about syntax that seems to be correct.

Last edited by dugan; 09-30-2014 at 09:51 AM.
 
Old 09-30-2014, 10:40 AM   #53
genss
Member
 
Registered: Nov 2013
Posts: 632

Rep: Reputation: Disabled
good to know
in this config it is explicitly stated what the output card will be, and that dmix is a plug used for the !default output

anyway
to test, something like
play -n synth 30 sin 347
where synth 30 means synthesize for 30 sec
and a stop watch to measure real time
or a video where you pick a sync time by a sound/video frame as a keypoint

Last edited by genss; 09-30-2014 at 10:41 AM. Reason: "a"
 
Old 09-30-2014, 11:54 AM   #54
dugan
Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 5,633

Original Poster
Rep: Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766
Oh btw, I've seen this in guides for other distros:

Code:
defaults.pcm.card NVidia
It doesn't work on Slackware. Does anyone know why?
 
Old 09-30-2014, 12:16 PM   #55
dugan
Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 5,633

Original Poster
Rep: Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766
Here's another "the nested format with the exclamation point throws out the rest of the PCM section; the inline format overrides only the exact keys listed" post:

http://www.mail-archive.com/alsa-use.../msg26200.html

Last edited by dugan; 09-30-2014 at 12:17 PM.
 
Old 09-30-2014, 10:16 PM   #56
dugan
Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 5,633

Original Poster
Rep: Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766
I wonder if this is the "hardware issue" that's causing my A/V sync woes:

HDMI's Lip Sync and audio-video synchronization for broadcast and home video

Last edited by dugan; 09-30-2014 at 10:20 PM.
 
Old 09-30-2014, 11:06 PM   #57
dugan
Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 5,633

Original Poster
Rep: Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766
Trying Pulseaudio now. Interestingly, the A/V sync seems to be a lot better (so far).
 
Old 10-09-2014, 01:11 AM   #58
dugan
Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 5,633

Original Poster
Rep: Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766
Yep. Hardware issues. It just started happening with Pulseaudio.
 
Old 10-26-2014, 08:21 PM   #59
Bertman123
Member
 
Registered: Jun 2010
Distribution: Slackware 14.1 64 bit MLED with XFCE 4.12
Posts: 286

Rep: Reputation: 56
I have just started reading this thread to try to get pulseaudio set up. I'm running slack 14.1 64 bit, but not running a multilib setup. I like pulseaudio as it's easier to switch back and forth from my laptops built in sound to my usb headset. I can get my usb headset to work by putting this in .asoundrc in my home folder.

pcm.!default {
type hw
card LX3000
device 0
}

ctl.!default {
type hw
card LX3000
device 0
}


I've noticed that I don't get sound when watching videos in chrome or chromium. I'm not into games and don't use skype, but is there a setup for pulseaudio? I know that it's possible for them to work, as other distros use pulseaudio and it is easy to switch between the internal sound card and usb headset with no issues.

I installed pulseaudio, pavucontrol, and alsa-plugins from sbopkg. When I run this command - /usr/bin/start-pulseaudio-x11 - I get the error below.

$ /usr/bin/start-pulseaudio-x11
N: [pulseaudio] main.c: User-configured server at {e667ecc9de8aeb375cf7fafa544c03f1}unix:/tmp/pulse-bCoMUIyY8gg2/native, which appears to be local. Probing deeper.
Failure: Module initialization failed
 
Old 10-27-2014, 09:13 AM   #60
dugan
Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 5,633

Original Poster
Rep: Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766Reputation: 1766
Quote:
Originally Posted by Bertman123 View Post
I can get my usb headset to work by putting this in .asoundrc in my home folder.

pcm.!default {
type hw
card LX3000
device 0
}

ctl.!default {
type hw
card LX3000
device 0
}


I've noticed that I don't get sound when watching videos in chrome or chromium.
Please try changing that (in its entirety) to:

Code:
defaults.pcm.card LX3000
ctl.pcm.card LX3000
Earlier in this thread (it should be on the same screen), I covered how that's different. If that doesn't work for you, then use the card number and not its name.

As for launching Pulseaudio, all I did to launch it was run the executable called "pulseaudio" after starting X; as I was running OpenBox, I put "pulseaudio &" in ~/.config/openbox/autostart.

Last edited by dugan; 10-28-2014 at 11:50 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] no sound ati video card HDMI Shadowmeph Linux Mint 3 01-27-2014 12:00 AM
(RHEL 5.6) No sound after installing NVIDIA Video Card with hdmi neoserdes Linux - Hardware 7 05-08-2012 03:10 AM
No sound through inboard HDMI on Fedora 12 with proprietary NVIDIA video driver rcx11 Linux - Hardware 9 08-21-2010 08:29 PM
Debian Video Card Question, Nvidia and HDMI bruceam Linux - Hardware 5 07-31-2009 12:29 PM
Missing the perimeter of my desktop - Video Card / DVI-HDMI waffe Linux - Hardware 3 04-20-2009 01:23 PM


All times are GMT -5. The time now is 03:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration