LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-02-2010, 03:12 PM   #1
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Scientific, Ubuntu, Fedora
Posts: 373

Rep: Reputation: 33
getting rid of akonadi


I don't use kontact cos it's still not reliable enough for me, so in the past I have just disabled akonadi (and nepomuk) in the checkboxes in systemsettings.
In Slackware though, this doesn't seem to do it, as each boot akonadi starts up again, runs for 20secs or so, then gives me error messages.

I tried removing the akonadi package with pkgtool, but this seemed to cause other hard-to-nail-down kde probs which required a reinstall in the end.

So, anyone know how I can either get rid of it, or make it be quiet?

This is the error message if anyone wants to take a look.

Cheers

Spoov

Code:
Akonadi Server Self-Test Report
===============================

Test 1:  SUCCESS
--------

Database driver found.
Details: The QtSQL driver 'QMYSQL' is required by your current Akonadi server configuration and was found on your system.

File content of '/root/.config/akonadi/akonadiserverrc':
[%General]
Driver=QMYSQL
SizeThreshold=4096
ExternalPayload=false

[QMYSQL]
Name=akonadi
Host=
User=
Password=
Options="UNIX_SOCKET=/root/.local/share/akonadi/db_misc/mysql.socket"
ServerPath=/usr/libexec/mysqld
StartServer=true


Test 2:  SUCCESS
--------

MySQL server found.
Details: You currently have configured Akonadi to use the MySQL server '/usr/libexec/mysqld'.
Make sure you have the MySQL server installed, set the correct path and ensure you have the necessary read and execution rights on the server executable. The server executable is typically called 'mysqld', its locations varies depending on the distribution.

Test 3:  SUCCESS
--------

MySQL server is executable.
Details: MySQL server found: /usr/libexec/mysqld  Ver 5.1.46 for slackware-linux-gnu on i486 (Source distribution)


Test 4:  SUCCESS
--------

No current MySQL error log found.
Details: The MySQL server did not report any errors during this startup into '/root/.local/share/akonadi/db_data/mysql.err'.

Test 5:  SUCCESS
--------

MySQL server default configuration found.
Details: The default configuration for the MySQL server was found and is readable at <a href='/usr/share/config/akonadi/mysql-global.conf'>/usr/share/config/akonadi/mysql-global.conf</a>.

File content of '/usr/share/config/akonadi/mysql-global.conf':
#
# Global Akonadi MySQL server settings,
# These settings can be adjusted using $HOME/.config/akonadi/mysql-local.conf
#
# Based on advice by Kris K√ƒ¬∂hntopp <kris@mysql.com>
#
[mysqld]
skip_grant_tables
skip_networking

# strict query parsing/interpretation
# TODO: make Akonadi work with those settings enabled
#sql_mode=strict_trans_tables,strict_all_tables,strict_error_for_division_by_zero,no_auto_create_user,no_auto_value_on_zero,no_engine_substitution,no_zero_date,no_zero_in_date,only_full_group_by,pipes_as_concat
#sql_mode=strict_trans_tables

# use InnoDB for transactions and better crash recovery
default_storage_engine=innodb
# case-insensitive table names, avoids trouble on windows
lower_case_table_names=1
character_set_server=latin1
collation_server=latin1_general_ci
table_cache=200
thread_cache_size=3
log_bin=mysql-bin
expire_logs_days=3
#sync_bin_log=0
# error log file name, relative to datadir
log_error=mysql.err
log_warnings=2
# log all queries, useful for debugging but generates an enormous amount of data
#log=mysql.full
# log queries slower than n seconds, log file name relative to datadir (for debugging only)
#log_slow_queries=mysql.slow
#long_query_time=1
# log queries not using indices, debug only, disable for production use
#log_queries_not_using_indexes=1
# maximum blob size
max_allowed_packet=32M
max_connections=256
# makes sense when having the same query multiple times
# makes no sense with prepared statements and/or transactions
query_cache_type=0
query_cache_size=0

innodb_file_per_table=1
innodb_log_buffer_size=1M
innodb_additional_mem_pool_size=1M
# messure database size and adjust
# SELECT sum(data_length) as bla, sum(index_length) as blub FROM information_schema.tables WHERE table_schema not in ("mysql", "information_schema");
innodb_buffer_pool_size=80M
# size of average write burst, keep Innob_log_waits small, keep Innodb_buffer_pool_wait_free small (see show global status like "inno%", show global variables)
innodb_log_file_size=64M
innodb_flush_log_at_trx_commit=2



Test 6:  SKIP
--------

MySQL server custom configuration not available.
Details: The custom configuration for the MySQL server was not found but is optional.

Test 7:  SUCCESS
--------

MySQL server configuration is usable.
Details: The MySQL server configuration was found at <a href='/root/.local/share/akonadi/mysql.conf'>/root/.local/share/akonadi/mysql.conf</a> and is readable.

File content of '/root/.local/share/akonadi/mysql.conf':
#
# Global Akonadi MySQL server settings,
# These settings can be adjusted using $HOME/.config/akonadi/mysql-local.conf
#
# Based on advice by Kris K√ƒ¬∂hntopp <kris@mysql.com>
#
[mysqld]
skip_grant_tables
skip_networking

# strict query parsing/interpretation
# TODO: make Akonadi work with those settings enabled
#sql_mode=strict_trans_tables,strict_all_tables,strict_error_for_division_by_zero,no_auto_create_user,no_auto_value_on_zero,no_engine_substitution,no_zero_date,no_zero_in_date,only_full_group_by,pipes_as_concat
#sql_mode=strict_trans_tables

# use InnoDB for transactions and better crash recovery
default_storage_engine=innodb
# case-insensitive table names, avoids trouble on windows
lower_case_table_names=1
character_set_server=latin1
collation_server=latin1_general_ci
table_cache=200
thread_cache_size=3
log_bin=mysql-bin
expire_logs_days=3
#sync_bin_log=0
# error log file name, relative to datadir
log_error=mysql.err
log_warnings=2
# log all queries, useful for debugging but generates an enormous amount of data
#log=mysql.full
# log queries slower than n seconds, log file name relative to datadir (for debugging only)
#log_slow_queries=mysql.slow
#long_query_time=1
# log queries not using indices, debug only, disable for production use
#log_queries_not_using_indexes=1
# maximum blob size
max_allowed_packet=32M
max_connections=256
# makes sense when having the same query multiple times
# makes no sense with prepared statements and/or transactions
query_cache_type=0
query_cache_size=0

innodb_file_per_table=1
innodb_log_buffer_size=1M
innodb_additional_mem_pool_size=1M
# messure database size and adjust
# SELECT sum(data_length) as bla, sum(index_length) as blub FROM information_schema.tables WHERE table_schema not in ("mysql", "information_schema");
innodb_buffer_pool_size=80M
# size of average write burst, keep Innob_log_waits small, keep Innodb_buffer_pool_wait_free small (see show global status like "inno%", show global variables)
innodb_log_file_size=64M
innodb_flush_log_at_trx_commit=2



Test 8:  SUCCESS
--------

akonadictl found and usable
Details: The program '/usr/bin/akonadictl' to control the Akonadi server was found and could be executed successfully.
Result:
Akonadi 1.3.1


Test 9:  ERROR
--------

Akonadi control process not registered at D-Bus.
Details: The Akonadi control process is not registered at D-Bus which typically means it was not started or encountered a fatal error during startup.

Test 10:  ERROR
--------

Akonadi server process not registered at D-Bus.
Details: The Akonadi server process is not registered at D-Bus which typically means it was not started or encountered a fatal error during startup.

Test 11:  ERROR
--------

Nepomuk search service not registered at D-Bus.
Details: The Nepomuk search service is not registered at D-Bus which typically means it was not started or encountered a fatal error during startup.

Test 12:  SKIP
--------

Protocol version check not possible.
Details: Without a connection to the server it is not possible to check if the protocol version meets the requirements.

Test 13:  ERROR
--------

No resource agents found.
Details: No resource agents have been found, Akonadi is not usable without at least one. This usually means that no resource agents are installed or that there is a setup problem. The following paths have been searched: '/usr/share/akonadi/agents /usr/share/akonadi/agents'. The XDG_DATA_DIRS environment variable is set to '/usr/share:/usr/share:/usr/local/share', make sure this includes all paths where Akonadi agents are installed to.

Directory listing of '/usr/share/akonadi/agents':
birthdaysresource.desktop
contactsresource.desktop
icalresource.desktop
imapresource.desktop
kabcresource.desktop
kcalresource.desktop
knutresource.desktop
kolabproxyresource.desktop
localbookmarksresource.desktop
maildirresource.desktop
maildispatcheragent.desktop
mboxresource.desktop
microblog.desktop
mtdummyresource.desktop
nepomukcalendarfeeder.desktop
nepomukcontactfeeder.desktop
nepomuktagresource.desktop
nntpresource.desktop
notesresource.desktop
pop3resource.desktop
vcarddirresource.desktop
vcardresource.desktop
Directory listing of '/usr/share/akonadi/agents':
birthdaysresource.desktop
contactsresource.desktop
icalresource.desktop
imapresource.desktop
kabcresource.desktop
kcalresource.desktop
knutresource.desktop
kolabproxyresource.desktop
localbookmarksresource.desktop
maildirresource.desktop
maildispatcheragent.desktop
mboxresource.desktop
microblog.desktop
mtdummyresource.desktop
nepomukcalendarfeeder.desktop
nepomukcontactfeeder.desktop
nepomuktagresource.desktop
nntpresource.desktop
notesresource.desktop
pop3resource.desktop
vcarddirresource.desktop
vcardresource.desktop

Environment variable XDG_DATA_DIRS is set to '/usr/share:/usr/share:/usr/local/share'

Test 14:  ERROR
--------

Current Akonadi server error log found.
Details: The Akonadi server did report error during startup into <a href='/root/.local/share/akonadi/akonadiserver.error'>/root/.local/share/akonadi/akonadiserver.error</a>.

File content of '/root/.local/share/akonadi/akonadiserver.error':
Database process exited unexpectedly during initial connection! 
executable: "/usr/libexec/mysqld" 
arguments: ("--defaults-file=/root/.local/share/akonadi//mysql.conf", "--datadir=/root/.local/share/akonadi/db_data/", "--socket=/root/.local/share/akonadi/db_misc/mysql.socket") 
stdout: "" 
stderr: "100802 13:31:59 [ERROR] Fatal error: Please read "Security" section of the manual to find out how to run mysqld as root!

100802 13:31:59 [ERROR] Aborting

100802 13:31:59 [Note] /usr/libexec/mysqld: Shutdown complete

" 
exit code: 1 
process error: "Unknown error" 
"[
0: akonadiserver(_Z11akBacktracev+0x35) [0x8051f35]
1: akonadiserver() [0x80523fe]
2: [0xffffe400]
3: /lib/libc.so.6(gsignal+0x47) [0xb6e1aa67]
4: /lib/libc.so.6(abort+0x182) [0xb6e1c2e2]
5: /usr/lib/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x84) [0xb7499dc4]
6: akonadiserver(_ZN15FileDebugStream9writeDataEPKcx+0xc4) [0x8053364]
7: /usr/lib/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0x8e) [0xb753248e]
8: /usr/lib/libQtCore.so.4(+0x10c6b5) [0xb75456b5]
9: /usr/lib/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x3d) [0xb7546bcd]
10: akonadiserver(_ZN6QDebugD1Ev+0x43) [0x804d7b3]
11: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer25startMysqlDatabaseProcessEv+0x1c65) [0xb7704d15]
12: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer20startDatabaseProcessEv+0x263) [0xb7707533]
13: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServerC1EP7QObject+0x7d) [0xb770774d]
14: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer8instanceEv+0x58) [0xb7708bf8]
15: akonadiserver(main+0x2ea) [0x804cd3a]
16: /lib/libc.so.6(__libc_start_main+0xe6) [0xb6e05b86]
17: akonadiserver() [0x804c981]
]
" 


Test 15:  ERROR
--------

Previous Akonadi server error log found.
Details: The Akonadi server did report error during its previous startup into <a href='/root/.local/share/akonadi/akonadiserver.error.old'>/root/.local/share/akonadi/akonadiserver.error.old</a>.

File content of '/root/.local/share/akonadi/akonadiserver.error.old':
Database process exited unexpectedly during initial connection! 
executable: "/usr/libexec/mysqld" 
arguments: ("--defaults-file=/root/.local/share/akonadi//mysql.conf", "--datadir=/root/.local/share/akonadi/db_data/", "--socket=/root/.local/share/akonadi/db_misc/mysql.socket") 
stdout: "" 
stderr: "100802 13:31:59 [ERROR] Fatal error: Please read "Security" section of the manual to find out how to run mysqld as root!

100802 13:31:59 [ERROR] Aborting

100802 13:31:59 [Note] /usr/libexec/mysqld: Shutdown complete

" 
exit code: 1 
process error: "Unknown error" 
"[
0: akonadiserver(_Z11akBacktracev+0x35) [0x8051f35]
1: akonadiserver() [0x80523fe]
2: [0xffffe400]
3: /lib/libc.so.6(gsignal+0x47) [0xb6e8ea67]
4: /lib/libc.so.6(abort+0x182) [0xb6e902e2]
5: /usr/lib/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x84) [0xb750ddc4]
6: akonadiserver(_ZN15FileDebugStream9writeDataEPKcx+0xc4) [0x8053364]
7: /usr/lib/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0x8e) [0xb75a648e]
8: /usr/lib/libQtCore.so.4(+0x10c6b5) [0xb75b96b5]
9: /usr/lib/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x3d) [0xb75babcd]
10: akonadiserver(_ZN6QDebugD1Ev+0x43) [0x804d7b3]
11: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer25startMysqlDatabaseProcessEv+0x1c65) [0xb7778d15]
12: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer20startDatabaseProcessEv+0x263) [0xb777b533]
13: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServerC1EP7QObject+0x7d) [0xb777b74d]
14: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer8instanceEv+0x58) [0xb777cbf8]
15: akonadiserver(main+0x2ea) [0x804cd3a]
16: /lib/libc.so.6(__libc_start_main+0xe6) [0xb6e79b86]
17: akonadiserver() [0x804c981]
]
" 


Test 16:  SUCCESS
--------

No current Akonadi control error log found.
Details: The Akonadi control process did not report any errors during its current startup.

Test 17:  SUCCESS
--------

No previous Akonadi control error log found.
Details: The Akonadi control process did not report any errors during its previous startup.
 
Old 08-02-2010, 03:29 PM   #2
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,541

Rep: Reputation: 1062Reputation: 1062Reputation: 1062Reputation: 1062Reputation: 1062Reputation: 1062Reputation: 1062Reputation: 1062
I just use removepkg and the thing goes away (look and see if it's still in /var/log/packages). Might want to init 3 so KDE isn't running when you do it.
 
Old 08-02-2010, 04:08 PM   #3
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Scientific, Ubuntu, Fedora
Posts: 373

Original Poster
Rep: Reputation: 33
i'm kind of reluctant to do that again cos i started getting weird probs last time; multimedia probs and things taking ages to start up. I did remove it using a konsole terminal though, so maybe that was the prob. Or it might have been an unrelated problem i spose..
 
Old 08-02-2010, 05:27 PM   #4
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,541

Rep: Reputation: 1062Reputation: 1062Reputation: 1062Reputation: 1062Reputation: 1062Reputation: 1062Reputation: 1062Reputation: 1062
First thing I do after installation (after giving it one try) is removepkg that thing. I don't really know just what the heck it's supposed to (and I suspect I don't want it doing whatever it does actually do in any event). Haven't had any problems with anything (in 32-bit and 64-bit installations) after removing it. Just shut down X (so you've got the white-on-black console), log in as root, removepkg and startx again.

What the heck, remove it and if things get weird reinstall it from the distribution media, eh?

Should work, give it a shot.
 
Old 08-02-2010, 06:45 PM   #5
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Scientific, Ubuntu, Fedora
Posts: 373

Original Poster
Rep: Reputation: 33
Well I did it, and it seems fine, thanks both.

I had a bit of trouble with X though again - how are you supposed to 'shut down' X properly? I logged out to kdm, then pressed ctrl+alt+F1, which opened up a console but with no prompt. To get a prompt to login I needed to open another console (tty?) with ctrl+alt+F5, which worked ok, but then i couldn't restart X 'cos it said there was already an X running (on the F1 login?).
I'm also finding that inittab needs to be set to default init 5, otherwise if i start in init 3 I can't then startx, it just gives errors leaving me trapped in consoles.

Something dodgy with my X maybe?

Last edited by spoovy; 08-02-2010 at 06:47 PM.
 
Old 08-03-2010, 05:51 AM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,921

Rep: Reputation: 6592Reputation: 6592Reputation: 6592Reputation: 6592Reputation: 6592Reputation: 6592Reputation: 6592Reputation: 6592Reputation: 6592Reputation: 6592Reputation: 6592
In Slackware, runlevel 5 behaves exactly the same as runlevel 3. So... if you experience differences that is an indication of a misconfigured system.
In runlevel 3 (or 5) you should be able to use "startx" to start X. If you get errors instead, please post those errors.

Shutting down X when you are in runlevel 4 can mean a few things.

First, if you mean you want to go back to graphical mode (runlevel 3) then you can press Ctrl-Alt-F6 while in X, which opens the one console (tty) which Slackware keeps open for cases like this. There you can logon as root, and issue "init 3" which will end your X session and kill all programs running in that session. If you then type "init 4" you will be transported back to a fresh KDM login screen. Or if instead you type "startx" you will land directly into a new X session.

Alternatively if you just want to re-initialize the X-server you can logout in runlevel 4, which drops you to the KDM login manager. There you press Ctrl-Alt-Backspace to forcibly kill the X-server. The init system will than restart KDM for you. This is the fast but ugly way.

Eric
 
2 members found this post helpful.
Old 08-03-2010, 07:17 AM   #7
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Scientific, Ubuntu, Fedora
Posts: 373

Original Poster
Rep: Reputation: 33
Sorry my mistake that should read

Quote:
I'm also finding that inittab needs to be set to default init 4, otherwise if i start in init 3 I can't then startx,
Still got my redhat on, thinking init 5 was default x runlvl.

I do need to set inittab to 4 as default though, cos if i try to default to 3 i just get a black screen at bootup, no cursor even. I thought this was an X fault at first but it can't be cos X isn't started in runlvl 3 is it? I think it's something to do with the rc.udev script, cos if I de-executable that, then I can then boot into init 3, but then i can't startx.

Something is definately not right, and i'm not entirely happy with this workaround either (having to default to runlvl 4) or no console even.

writing as I think, I suppose it makes sense, if i disable udev it won't find my screen hardware, hence startx will then throw up an error. So the real problem is why the udev script if executable causes a blank screen.

sorry for the ramble. Any ideas?
 
Old 08-03-2010, 08:03 AM   #8
JackHair
Member
 
Registered: Aug 2009
Location: Netherlands
Distribution: Slackware64-current
Posts: 167

Rep: Reputation: 39
On my laptop I also only get a black screen in runlevel 3 unless I pass vga=771 to lilo, then runlevel 3 works fine.
 
Old 08-03-2010, 10:19 AM   #9
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Scientific, Ubuntu, Fedora
Posts: 373

Original Poster
Rep: Reputation: 33
Strangely Jackhair, you commented on my original post on this topic - http://www.linuxquestions.org/questi...13-1-a-822890/ Except you wrote vga=773 in that post rather than 771. I followed your advice, using vga=773 (grub instead of lilo though) and that was the only way I could get it to boot even in runlvl 4!!

I will try 771 instead, see if that makes any difference.



EDIT - Makes no difference, I still can't boot straight into init 3 without disabling udev.

Last edited by spoovy; 08-03-2010 at 10:46 AM.
 
Old 08-03-2010, 02:02 PM   #10
JackHair
Member
 
Registered: Aug 2009
Location: Netherlands
Distribution: Slackware64-current
Posts: 167

Rep: Reputation: 39
Ah that's right I actually meant to type 773 here too. To bad it doesn't work for you, guess you'll have to wait for someone with more knowledge about these problems.
 
Old 08-03-2010, 02:25 PM   #11
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,367

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
What video card do you have? What drivers are you using? Is KMS involved?

"vga = ask" in lilo.conf (remember to rerun lilo) is the failsafe option, which uses no framebuffer at all. However, depending on your graphics card and how it is setup, it may ignore your lilo options and have to be adjusted differently (I know intel is problematic, but I cannot remember if ATI has issues with KMS by default as well).
 
Old 08-03-2010, 02:57 PM   #12
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Scientific, Ubuntu, Fedora
Posts: 373

Original Poster
Rep: Reputation: 33
i'm using a laptop with integrated intel gm965 graphics chip. drivers are built in to the kernel as far as I know, i've never had to mess with additional drivers before.

As for KVM, really no idea sorry, i'm using the standard as-shipped 2.6.33.4-smp kernel if that helps?

I got this from lshw -

Code:
description: VGA compatible controller
             product: Mobile GM965/GL960 Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 03
             width: 64 bits
             clock: 33MHz
             capabilities: msi pm vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:29 memory:f0000000-f00fffff memory:d0000000-dfffffff(prefetchable) ioport:1800(size=8)
        *-display:1 UNCLAIMED
             description: Display controller
             product: Mobile GM965/GL960 Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2.1
             bus info: pci@0000:00:02.1
             version: 03
             width: 64 bits
             clock: 33MHz
             capabilities: pm bus_master cap_list
             configuration: latency=0
             resources: memory:f0100000-f01fffff
 
Old 08-03-2010, 08:53 PM   #13
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,367

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
See this thread and other KMS threads (just a search away) for some help (though I don't have an intel card so I don't know if you will find the ultimate answer to your problem or not).
 
Old 08-05-2010, 09:55 AM   #14
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Scientific, Ubuntu, Fedora
Posts: 373

Original Poster
Rep: Reputation: 33
Great T3Slider thanks, it appears that was the problem, and a pretty common one.

So I have got it working, booting in rl3 and allowing startx. I don't know if I correctly understand what I did though, as I seem to have prevented KMS loading, then changed driver anyway? I would've thought one or the other?? I did the following -

1) I added "nomodeset" to grub.cfg, which I believe stops KMS loading?
2) I also removed all reference to vga=???, which then allows automatic screen size detection??
3) used pkgtool to remove the xf86=intel video driver and then install the older one. Cos the newer one isn't compatible with...?? KMS?

Is this the best way to go about changing modules? I would have tried modprobe -r or rmmod but I couldn't find a module which related to xf86=intel using lsmod so I just removed the whole package.

Cheers

Last edited by spoovy; 08-05-2010 at 09:57 AM.
 
Old 08-05-2010, 01:47 PM   #15
selfprogrammed
Member
 
Registered: Jan 2010
Location: Minnesota, USA
Distribution: Slackware 13.37, 14.2
Posts: 387

Rep: Reputation: 81
Unhappy

I am getting the same akonadi errors, "not registered with D-Bus".
I do not have a clue as to what it wants (yet).
My Akonadi errors show up in a window when KDE starts up.
Akonadi puts up a progress slider, then takes a while to try to start itself, then aborts with these error messages, then repeats.
It was going on its third or fourth attempt to start when I finally intervened by clicking on a cancel button on the error messages.
That finally stopped it and let the rest of KDE finish loading.

I am planning on doing a removepkg on it too, because whatever PIM functions it performs are rather vague and probably unnecessary.
The pkgtool description could have been more informative.
I only installed in a desperate attempt to make some other KDE errors go away. This KDE 4 is really screwed up.

I got that "things taking forever to start up" problem too.

Last edited by selfprogrammed; 08-05-2010 at 01:53 PM.
 
  


Reply

Tags
akonadi


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slack13.1 and akonadi bg4 Slackware 30 06-11-2010 01:20 AM
Akonadi x42bn6 Linux - Newbie 5 12-11-2009 06:07 AM
can someone explain akonadi for me? mma8x Linux - Software 1 12-03-2009 05:01 PM
Has Anyone Gotten Akonadi to Work? tronayne Slackware 13 10-23-2009 08:02 PM
Akonadi/QT QMySQL Help!! kapz Linux - Desktop 8 06-25-2009 04:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration