LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-07-2016, 11:58 AM   #1
ewlabonte
Member
 
Registered: Mar 2005
Distribution: FreeSlack version of Slackware 14.1
Posts: 107

Rep: Reputation: 15
Getting networkmanager started in chroot environment


After screwing up changing lilo.conf and being unable to log back in, I decided to learn how to chroot into my root directory from the installation media and get basic resources working. I figured out how to chroot in (mounting /proc, /dev, and /sys, etc.) but I can't seem to get network manager working. I ran it, and got the error message that dbus needed to be running. So I started rc.messagebus. Then I could start network manager. But when I run nmtui, even though my wifi network shows when I choose to edit, it doesn't show up when I choose to activate. I ran nmtui-connect along with the ssid for my wifi connection and got the message that that ssid couldn't be found. Is there something else that needs to be running to get networkmanager started?
 
Old 09-07-2016, 11:48 PM   #2
mpapet
Member
 
Registered: Nov 2003
Location: Los Angeles
Distribution: debian
Posts: 547

Rep: Reputation: 72
If you are trying to chroot to fix something and need the Internet for it, don't start network-manager. Join your access point manually.

http://unix.stackexchange.com/questi...h-command-line
 
Old 09-08-2016, 03:25 AM   #3
allend
LQ Guru
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 5,006

Rep: Reputation: 1754Reputation: 1754Reputation: 1754Reputation: 1754Reputation: 1754Reputation: 1754Reputation: 1754Reputation: 1754Reputation: 1754Reputation: 1754Reputation: 1754
I use the wpa_supplicant approach.

My startup is here. http://www.linuxquestions.org/questi...ml#post5518194

My /etc/wpa_supplicant.conf. The lines starting with #old require your local values (and the #old removed).
Code:
# See /usr/doc/wpa_supplicant-0.7.3/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=root
eapol_version=1
ap_scan=1
fast_reauth=1
#country=US

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=0
#  ssid="your_essid_here"
#old  ssid="OPTUSA4680E8"
# RSN is WPA2 protocol
  proto=RSN
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
#  psk=your_64_char_psk_here
# Format is one of:
#old  psk=a895812ddbd2c70ece741f4c2765da52e7da966829b91450fc731d4f63d83a68
#old  psk="PFSLYHUMQTHHSQH47982"
  priority=10
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
network={
  key_mgmt=NONE
  priority=0
}
 
Old 09-08-2016, 05:05 AM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,257

Rep: Reputation: 5359Reputation: 5359Reputation: 5359Reputation: 5359Reputation: 5359Reputation: 5359Reputation: 5359Reputation: 5359Reputation: 5359Reputation: 5359Reputation: 5359
You can of course also follow the instructions on-screen when you boot the computer from your installation media. At the end of the boot, you will see these instructions:
Code:
In a pinch, you can boot your system from here with a command like:

boot: huge.s root=/dev/sda1 rdinit= ro 

In the example above, /dev/sda1 is the / Linux partition.
Note that there is a SPACE character between "rdinit=" and "ro".
Essentially, it allows you to boot your harddisk-installed Slackware with the kernel and initrd from the installation medium. No need for manual chroots or fussing with the rc scripts.
And when logged in, you can fix your /etc/lilo.conf and re-run the "lilo" command so that next time you do not have to use the installation medium to boot the computer.
 
4 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
chroot environment shiva1990 Linux - Newbie 2 01-25-2011 08:55 AM
yum Error: NetworkManager conflicts with bind-chroot btb Fedora 1 10-21-2005 03:55 AM
getting started in chroot environment Mystified Linux From Scratch 3 03-28-2005 09:11 AM
Out of the chroot environment? R2RO Linux - Networking 0 05-14-2003 04:01 PM
Getting in and out and in again in the CHROOT environment? kRu_ZaDeR Linux From Scratch 8 01-13-2003 12:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration