-   Slackware (
-   -   generic kernel boot time parameters ignored (

shadowsnipes 12-20-2008 08:24 PM

generic kernel boot time parameters ignored
When I use the generic kernel (in Slackware 12.2) my append statements are ignored. If I type parameters in manually at the LILO prompt they are ignored as well.

Anybody else having this problem? It all works fine on a custom kernel ( I have previously been using.

Here is a sample from my lilo.conf

image = /boot/vmlinuz-generic-smp-
  initrd = /boot/initrd.gz
  root = /dev/hdb5
  append="single mp3player=on bootFast=yes"
  label = __Auto_Music__
  read-only  # Partitions should be mounted read-only for checking

Nikosis 12-20-2008 09:52 PM

Just out of curiosity,

The usual reason to use an initrd is because you need to load kernel
modules before mounting the root partition. Usually these modules are
required to support the filesystem used by the root partition (ext3,
reiserfs, xfs), or perhaps the controller that the hard drive is attached
to (SCSI, RAID, etc). Essentially, there are so many different options
available in modern Linux kernels that it isn't practical to try to ship
many different kernels to try to cover everyone's needs. It's a lot more
flexible to ship a generic kernel and a set of kernel modules for it.
what is the reason of using initrd other than this one above, isn't better to build a custom kernel ?.

shadowsnipes 12-21-2008 12:25 AM

If time were infinite then I would always build a custom kernel, but time is limited so sometimes using a generic kernel with initrd is best. It is also useful for people who don't know how to make a good custom kernel for their setup.

Nikosis 12-21-2008 01:19 AM

Fair enough.
For a quite some time I'd have been using a custom kernel and never used initrd, so I've always been curious about this one.
Thanks for an answer, and sorry for interruption.

bgeddy 12-21-2008 08:04 AM

I've installed 12.2 in a VM. The first thing I do after an install is create an initrd and add the generic kernel to lilo (as per the CHANGES_AND_HINTS.TXT) and have been looking into various things that needed kernel parameters passing,( init=/bin/bash to be exact), and have noticed the generic kernel seems to ignore this parameter but the huge one honors it.

As a test I tried passing "single",1 and "S" but all were ignored with the generic kernel. At first I thought I had forgotten to pass the parameters but /proc/cmdline showed that in fact I had supplied them.

I presume this has something to do with the kernel config but I haven't investigated it further.


what is the reason of using initrd other than this one above, isn't better to build a custom kernel ?.
@Nickosis - this is from the CHANGES_AND_HINTS.TXT on your install media..


Use one of the provided generic kernels for daily use. Do not report
bugs until/unless you have reproduced them using one of the stock
generic kernels. You will need to create an initrd in order to boot
the generic kernels - see /boot/README.initrd for instructions.
Although I realise some hardware will require a custom kernel I have had great success with the generic kernels now with the recent releases.

All times are GMT -5. The time now is 04:58 AM.