LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-22-2013, 01:59 PM   #1
andreas-r
Member
 
Registered: Jan 2013
Location: Denmark
Distribution: Ubuntu 12.10 & Slackware 14, 64bit
Posts: 46

Rep: Reputation: 0
Generic kernel and full screen login?


I switched to the generic kernel suggested by the mkinitrd script. It worked fine but now the login console is a tiny 640x480 block in the middle of the screen which sort of sucks if I choose to do some work in that environment.

This makes sense - I guess I've prevented the graphics driver from being loaded at start-up. Is there an easy way to have the other advantages from a generic kernel but have the graphics drivers load so the console is full screen?

Thanks!

Last edited by andreas-r; 01-22-2013 at 02:18 PM.
 
Old 01-22-2013, 02:34 PM   #2
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 248

Rep: Reputation: Disabled
Edit lilo.conf and locate that line vga = normal,or edit other vga options.
 
Old 01-22-2013, 04:47 PM   #3
andreas-r
Member
 
Registered: Jan 2013
Location: Denmark
Distribution: Ubuntu 12.10 & Slackware 14, 64bit
Posts: 46

Original Poster
Rep: Reputation: 0
'vga = normal' is already uncommented. Also tried 'vesa framebuffer console @ 1366x768' and 'normal VGA console' together and by themselves but when I 'lilo -v' it gives me error or unknown token.

It happened after I changed the image in lilo.conf so suppose it's related to switching to generic kernel.

Last edited by andreas-r; 01-22-2013 at 04:49 PM.
 
Old 01-22-2013, 05:12 PM   #4
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 248

Rep: Reputation: Disabled
What is your graphic card?
 
Old 01-22-2013, 05:28 PM   #5
andreas-r
Member
 
Registered: Jan 2013
Location: Denmark
Distribution: Ubuntu 12.10 & Slackware 14, 64bit
Posts: 46

Original Poster
Rep: Reputation: 0
It's intel hd graphics 3000.
 
Old 01-22-2013, 05:32 PM   #6
andreas-r
Member
 
Registered: Jan 2013
Location: Denmark
Distribution: Ubuntu 12.10 & Slackware 14, 64bit
Posts: 46

Original Poster
Rep: Reputation: 0
I should probably mention that i run Slackware in VirtualBox. Couldn't get the right resolution before installing VBOX additions.
 
Old 01-23-2013, 03:59 AM   #7
andreas-r
Member
 
Registered: Jan 2013
Location: Denmark
Distribution: Ubuntu 12.10 & Slackware 14, 64bit
Posts: 46

Original Poster
Rep: Reputation: 0
Code:
vga = 791
in 'lilo.conf' gives me a 1024x768x64k console so the vga settings were of course the place to look - I just mistook the comment '#vesa framebuffer console @ 1366x768' for the actual code to do this. I'm new to Slack
Cheers!
 
Old 01-23-2013, 06:30 AM   #8
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD, Slackware
Posts: 1,217

Rep: Reputation: 375Reputation: 375Reputation: 375Reputation: 375
Quote:
Originally Posted by andreas-r View Post
I should probably mention that i run Slackware in VirtualBox. Couldn't get the right resolution before installing VBOX additions.
Just a guess as I haven't used virtualbox for over a year, but you might need to reinstall that as the driver may have been built for the huge kernel.
 
Old 01-23-2013, 06:40 AM   #9
andreas-r
Member
 
Registered: Jan 2013
Location: Denmark
Distribution: Ubuntu 12.10 & Slackware 14, 64bit
Posts: 46

Original Poster
Rep: Reputation: 0
Thanks for replying! Maybe you missed my last post - adding 'vga = 791' as described above actually fixed it.
 
  


Reply

Tags
generic, login


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change Ubuntu 12.04 login screen to require full credentials? taylorkh Ubuntu 5 06-07-2012 12:01 PM
typing "S" to go to login screen in ubuntu 3.0.0-17-generic levimaen Linux - Newbie 4 04-05-2012 12:54 PM
Slackware current goes to KDE login screen when I Esc from full-screen youtube videos Robert.Thompson Slackware 2 04-11-2011 04:43 PM
[SOLVED] setting up initrd / generic kernel in Grub2...can't load generic Ubunoob001 Slackware 8 01-05-2011 11:37 PM
RedHat Generic Login Screen bfloeagle Linux - General 8 02-07-2004 05:35 PM


All times are GMT -5. The time now is 02:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration