-   Slackware (
-   -   General question about Pulseaudio (

kikinovak 03-21-2013 04:16 PM

General question about Pulseaudio

I'm currently building the screencasting app Kazam, after reading a positive review about it by a competent colleague.

Among other things, Kazam has Pulseaudio as runtime dependency. Now I don't know much about Pulseaudio, except it's a sound server, and I remember it vaguely as "the thing that caused audio to be a mess in many major distributions".

1) Correct me if I'm wrong.

2) Can I install it on a Slackware desktop + Xfce without wrecking my audio?



adamk75 03-21-2013 04:33 PM

pulseaudio does sometimes have problems, though they are not nearly as common now as they were when distributions started using it by default in its early days.

You can certainly install it on Slackware:

I doubt very much it will wreck your audio, but if you do run into problems with PA that you just can't fix, you can always uninstall it.


Beelzebud 03-21-2013 06:16 PM

Pulse is actually not bad these days. The early versions broke a lot of things, but I tried it out recently and it solved a lot of issues I was having with 5.1 surround, and switching from USB headphones/mic to the soundcard on the fly.

stormtracknole 03-21-2013 06:19 PM

If you install pulseaudio, make sure to install pavucontrol. Takes a while to build all the dependencies, but it is well worth it.

TobiSGD 03-21-2013 08:01 PM

Is Pulseaudio actually usable on Slackware? I am interested in the per application volume control feature and just installed it, including all dependencies on Slackware 14 32 bit, but I can't really test it, neither AlienBob's VLC nor the standard MPlayer seem to be compiled with Pulseaudio options.
Do I miss something here?

adamk75 03-21-2013 08:04 PM

if you install the alsa-plugins slackbuild, and build it with PA support, you can get all alsa apps use PA seemlessly.

TobiSGD 03-21-2013 08:20 PM

Thanks, I will try that.
Doesn't work, I seem to be missing something essential, time to search for more information about pulseaudio.

Found it, I had to create a file /etc/asound.conf with the content:

# Use PulseAudio by default
pcm.!default {
  type pulse
  fallback "sysdefault"
  hint {
    show on
    description "Default ALSA Output (currently PulseAudio Sound Server)"

ctl.!default {
  type pulse
  fallback "sysdefault"

# vim:set ft=alsaconf:

I got that from the Arch package alsa-pulseaudio, as always the ArchWiki was a great help.
Pulseaudio works fine now and if it turns out to be stable I will run it on all my systems.

kikinovak 03-22-2013 01:43 AM

Thanks for all your answers, folks. I got the problem sorted out, in an unexpected way.

I had made some first tests with gtk-recordmydesktop, and found the result with the default settings to be completely unusable. But after some more fiddling, the recordmydesktop command line backend is in fact a quite neat tool, with many handy options, and which does things as expected. Plus, it's already shipping in extra/, so no need to install the kitchen sink for that.

Here's a first result:



andrew.46 03-23-2013 11:12 PM

Hmmm... I might have a try as well as I believe it is the only sure way to get sound with FFmpeg / X11grab...

All times are GMT -5. The time now is 08:32 PM.