-   Slackware (
-   -   General insatiability when connecting Nokia phone(via USB) in data mode (

FeyFre 08-15-2011 05:22 PM

General insatiability when connecting Nokia phone(via USB) in data mode
2 Attachment(s)

A few days ago I decided to remember my youth and tried to connect my old mobile phone to PC.
Phone is Nokia 6233. Connecting via USB data cable DKU-2(replaced by CA-53 nowadays).
Unfortunately most of retries slackware tries to detect phone is unsuccessful, especially after first successful connect and disconnect.
Here content of dmesg (dmesg.log attachment) after series of unsuccessful retries. Note, time interval 87-258.16 contains unsuccessful retries to detect device - all this time I tried to reconnect plug into my phone, until on 258.73 phone was at last successfully detected(and I have mounted file system on /dev/sdc1 successfully(when trying to mount sdc - console hangs)).
Then I unmounted filesystem and detached plug from phone.
Next retries are fault always. Moreover it seems there are was deadlocks/timeouts in kernel. See attachment dmesg.err (a couple of retries to connect phone after first successful retry).
In standard Nokia mode(when phone mapped as serial port) no successful retries either.
Last time I tried to connect Nokia phone was near 3 years ago or less - it worked without any problems with Slackware 12.2(pppd over ttyUSB1 associated with phone worked perfectly).
For now I'm on slackware 13.37 (with out-of-box generic kernel). In dualbooted Windows system there is no any problems - newly attached phone detected instantly(I think this means it is not hardware problem)
Does any body have such problems now? Or I'm so unlucky alone? Any advices?

guanx 08-15-2011 07:43 PM

I had the same problem with a Siemens phone before I replaced the failing cable.

FeyFre 08-16-2011 05:41 PM

Cable is good, as I said I have installed Windows on the same machine and using the same hardware (including cable) have no any problems.

All times are GMT -5. The time now is 04:44 AM.