LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   GDM Broken After Upgrade Via Swaret (https://www.linuxquestions.org/questions/slackware-14/gdm-broken-after-upgrade-via-swaret-160361/)

2Gnu 03-20-2004 07:35 PM

GDM Broken After Upgrade Via Swaret
 
After upgrading some packages, X not longer starts normally. It tries, then errors saying that an X server is already running, do I want to try another display. Answering yes or no causes the same symptom, restart attempt and fails.

Killing all GDM pids and running startx gets me into KDE. I normally run XCFE4 from GDM.

XFree86.log said that there were multiple X servers running and no screens defined (paraphrasing as the log has been overwritten.

Packages upgraded:
Mar 20 14:14 atk-1.6.0-i486-1.tgz
Mar 20 14:14 coreutils-5.2.1-i486-1.tgz
Mar 20 14:16 gimp-2.0pre4-i486-1.tgz
Mar 20 14:16 glib2-2.4.0-i486-1.tgz
Mar 20 14:17 gtk+2-2.4.0-i486-1.tgz
Mar 20 14:17 pango-1.4.0-i486-1.tgz

What can I do to further diagnose?
Anyone else having trouble with one of these packages? If so, which ones might I downgrade and to what?

note to self: Do not blindly upgrade just because swaret says that you can.

Minderbinder 03-20-2004 08:18 PM

Are you running dropline gnome? Those packages look like some of the ones that won't be updated in dropline until gnome 2.6 is released next week.

2Gnu 03-20-2004 08:24 PM

Only the vanilla Gnome is installed. Rarely used, but it's there.
No Dropline.

GrayGhost 03-20-2004 09:41 PM

I had the same problem yesterday after my swaret --upgrade. I had to switch to KDM in /etc/rc.d/rc4 to get a log in manager GDM kept giving me the same error.

patfins 03-20-2004 09:42 PM

I have the same problem.

Downgrade from gtk+2-2.4.0-i486-1.tgz back to gtk+2-2.2.4-i486-1.tgz.

2Gnu 03-21-2004 12:28 AM

Downgrading to 2.2.4 fixed it. Thanks for all of the responses.
Much appreciated.


All times are GMT -5. The time now is 04:13 AM.