-   Slackware (
-   -   gaupol: add options to mplayer (

lopuh 10-09-2012 12:02 PM

gaupol: add options to mplayer
Slackware 13.37.0
Xfce 4.6.2
gaupol 0.19.1


$ mplayer -vo null -ao null -frames 0 -v Video03-01.vob|grep stream:
==> Found video stream: 0
==> Found audio stream: 128
==> Found audio stream: 129

How to add option (-aid 129) to the command?
I try edit preferences, but can't.

kakaka 10-10-2012 10:39 PM

If you are trying to select audio channel ID 129 from mplayer, have you tried:


mplayer -aid 129

lopuh 10-11-2012 09:16 AM

Gaupol preferences looks like read only, i can't type.

kakaka 10-11-2012 12:39 PM

Hi lopuh!

Despite the mention of gaupol, in your original post, your subject talks about adding options to mplayer, and you illustrate a separate command line use of mplayer. Somehow when I tried to view the PNG file it was too fuzzy/out of focus. I couldn't really see what you were trying to show us. So you could have been trying to use the mplayer command separately.

If your issue is within gaupol, and you are using the gaupol which is a subtitle editor, if you are using version 0.17.1 or a compatible version, then you should be able to go through these menu selections, Edit==>Preferences==>Preview; on the Preview menu, in the Video Player section, the Application selection has a choice of Custom. When you choose that, you can type in your own command to use whatever external command you'd like for preview. I just typed in another mplayer command line. When you move your mouse pointer into the box where you can type the command, you should see a list displayed, of the four gaupol related values which can be used within the external command, such as $MILLISECONDS, etc.

Hope this helps.

lopuh 10-11-2012 03:26 PM

Thank you very much, dear kakaka, for your help.
Application: Custom - that's what i need)

All times are GMT -5. The time now is 08:36 AM.