-   Slackware (
-   -   Gambas: Package or SlackBuild and dependencies? (

gargamel 10-02-2010 03:18 PM

Gambas: Package or SlackBuild and dependencies?
Hello everyone,

after reading a couple of magazine articles I am interested in trying out Gambas (the BASIC development environment). A first web search for a recent Slackware package or SlackBuild gave no useful results. So I tried to compile from source, but that's not quite as easy, due to dependencies.

So, what I am looking for, is:

a Gambas Slackware package
if not available: a SlackBuild script

and an overview, which packages contain the dependencies.

Thanks in advance for all useful hints and pointers!


EDIT: I just found a 32-bit package at I'll try how far I can get with it...

easuter 10-03-2010 09:16 AM

VectorLinux uses Gambas a lot for its in-house system tools, and they have a SlackBuild here:

From their dependencies file it appears you may need the following:


mysql >= 5.0.24a-i486-1,sqlite >= 2.8.17-i586-4vl58,sqlite3 >= 3.4.1-i586-1vl58,postgresql >= 8.2.4-i586-1vl58,unixODBC >= 2.2.11-i586-4vl58,kdelibs >= 3.5.6-i586-2vl58

linus72 10-03-2010 09:33 AM

you can get premade pkgs/source from too

gargamel 10-03-2010 10:36 AM

thanks, I took a look at both of them.

The Vector Linux packages are quite old...
The stuff is up-to-date, but not working out of the box on my Slackware64-13.1-stable system. I am struggling with the dependencies. I was able to meet most of them, by installing additional packages, but I don't seem to get rid of complaints regarding missing gb.qte and gb.sqlite2. The latter won't hurt, probably, but the first one certainly does!

Does anyone know, what needs to be installed in order to meet the gb.qte requirement?

I'll keep trying a little bit, but if I don't get it working soon, I'll try something else...


gargamel 10-03-2010 10:50 AM

What's missing, is apparently a library qt-mt. Does anyone happen to know, in which package it is included?



GrapefruiTgirl 10-03-2010 10:52 AM

I may be using a different version of Slack than you, but here's what I see on mine:

root@reactor: grep qt-mt /var/log/packages/*

Your package name/version may vary slightly.

gargamel 10-03-2010 11:16 AM

Thanks, have the same here. Now the question is: Why is qt-mt not found, although it is obviously there?


GrapefruiTgirl 10-03-2010 11:21 AM

Possibly because the directory where it's located is either not in your linker's path (check /etc/ and/or you need to add the directory where it's located, to your $LDFLAGS environment variable prior to running configure, make, etc...

I didn't read the whole thread, but are you using a slackbuild, or building from scratch? If from scratch, then examining the slackbuild can provide clues. :)

gargamel 10-03-2010 01:23 PM

I've tried both, using the SlackBuild script from and compiling from scratch.



The bold line has been added by the SlackBuild, I guess...



All times are GMT -5. The time now is 09:19 PM.