LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Fundamental issues with -current on new laptop (https://www.linuxquestions.org/questions/slackware-14/fundamental-issues-with-current-on-new-laptop-4175624289/)

mcnalu 02-23-2018 04:33 AM

Fundamental issues with -current on new laptop
 
Sorry for the vague title on this thread but I'm currently mystified. Here's the story.

Got a new laptop, an ASUS ZenBook UX550V. Came with windows and it works fine so no hardware issues. I was able to install Slackware 14.2 alongside Windows 10 on the hard drive after careful reading of README_UEFI.txt. But, X won't start and the wireless chip isn't available and there are many other problems, though no stability issues.

So after a bit of reading I found that Kaby Lake isn't supported by the 4.4 kernels but by 4.10.3 the kernel had pretty good support for it. As -current is on 4.14, I decided to try that. First I tried liveslak from AlienBob but that failed to start (comment left about that on his recent blog post which he just answered).

I then upgraded the 14.2 hard drive install using slackpkg exactly as per these instructions and that went smoothly and the system booted up OK. But there were serious problems and still no X. Simple commands such as lspci or uname -a caused the shell to hang in a way that was immune to ^C or ^Z. I could login in at another shell but found I was unable to shutdown the PC. It hung at "Unmounting remote systems."

Any suggestions of what to check? I'm a little nervous of poking around too much when I can't shutdown cleanly. However, by accident I discovered that if I used the 4.4.115 kernel in -current then the system is stable (yes, I know that's not a good idea, but better than a definitely borked system!) but of course I've no support for the Kaby Lake etc.

willysr 02-23-2018 04:51 AM

Hi

I had the same problem when i bought my new laptop last year because at that time, Kaby Lake is not yet supported by the kernels used in -current (4.9.x), but it was working well with kernel 4.4.x used in Slackware 14.2. So i compiled my own kernel using 4.10.x and it boots fine until i'm stuck with X issue and finally solve it.

I have made a blog post about that issue. You can try the same solution and see if it works on your machine.

mcnalu 02-23-2018 07:06 AM

Thanks Willy. In fact I had seen your post already (but didn't realise it was your blog!). The kernel in -current just now is 4.14.20 so it should have good Kabyake support. Unfortunately something else is seriously wrong making things unstable on my new hardware. Is it worth me alerting Pat do you think?

If I have time this weekend I'll try and compile an older kernel and see how that works.

kjhambrick 02-23-2018 07:33 AM

Oops... I missed in the OP that you're running -current ... never mind.

but thanks to willysr for the link to his blog entry !

mcnalu 02-23-2018 10:55 AM

An update.

I was able to get liveslak booting up by using a different USB stick. But had the exact same instability problems as for installed -current. The kernel was 4.14.18.

I decided to try out Ubuntu 7.10 which comes with a 4.13.x kernel. At first it seemed good as it got to the graphical desktop very quickly and WiFi and keyboard backlight etc were all working. But issuing sudo lspci caused it to hang as did trying to shut down.

mcnalu 02-23-2018 11:30 AM

Marking this as solved. Solution is to add the following kernel parameters at boot:

acpi_osi=! acpi_osi="Windows 2009"

Found it by searching web for "lspci hang", eg

https://wiki.archlinux.org/index.php...lspci_hangs.29

and here are solutions reported on a variety of systems

https://github.com/Bumblebee-Project...ment-234494238

I whooped when lspci worked and did a wee dance when KDE fired up and I saw keyboard backlight, wireless etc are all working in slackware. No tweaking of xorg.conf or anything else was needed.


All times are GMT -5. The time now is 04:06 AM.