-   Slackware (
-   -   Fujitsu P1120 Slackware Install No CD (

hotplainrice 03-04-2004 07:14 AM

Fujitsu P1120 Slackware Install No CD
Hi guys,

I just got a new Fujitsu P1120 notebook which is cool cos its really cool. I'm a noob and of course as usual, having troubles with linux installations. :newbie:

This notebook has no FDD, no CDROM, a Realtek RTL8139 NIC, Intersil PRISM Wireless LAN PCI card. This thing can boot USB floopy drive and I just bought a new generic USB floopy drive. Now I have FDD, no CDROM, 30Gb so I'm planning a NFS install or Hard drive install. I would prefer to do a NFS internet slackware-current install but I have no idea how on earth to execute it. If that isn't a option, the second choice is HDD install. Someone guide me, I don't even know what folders or files on the FTP site to download into the HDD( I don't even how much space I should allocate for the partition to store the installation files). Step-by-step instructions please.

Thanks in advance.

Rodrin 03-04-2004 11:05 AM

And while you're at it, would you mind doing my dishes, taking my car out for a wash and some gas, and, um, do you have 300 dollars I can borrow? ;-)

Here's a link that could give you some pointers, although this person was installing Mandrake. It has other links also that could prove helpful:
Linux (Mandrake 9.1) on a Fujitsu P1120

I can also point out the likelihood that for a network install you will need probably either the bare.i or the bareacpi.i bootdisk image from Slackware's /bootdisks directory as well as the images install.1, install.2, and network.dsk from the /rootdisks directory.

hotplainrice 03-05-2004 05:00 AM

Thanks Rodrin, I did it. I tried to boot bare.i, bareacpi.i bootdisk image but I got the same error as in this post

I emailed Simon from that link, he couldn't help me because he explained me that Mandrake automates stuff for him.

The similarity between my case and the link I posted is we are both using USB FDD ( I don't have any built-in drives )

And I found SuckSlack and SlackFTP to do the install over the internet..

I even tried scsi.s image since USB stuff is SCSI emulated and got the same error.

gnashley 03-05-2004 06:14 AM

grab the boot image for RUNT linux (slack9.1 based). This boot disk loads the USB drivers . To start an install you don't need so much. Take a lok at my minimal install HOWTO for a few pointers:

hotplainrice 03-05-2004 10:04 AM

gnashley, when I boot the disk from my USB FDD, what do I do next so that I can continue with install.1 rootdisk in my USB FDD. Thanks for the guide.

gnashley 03-05-2004 01:08 PM

The boot message from the RUNT floppy explains how to continue. You'll of course need the install.1 and install.2 images burned to floppy.
If you are dual booting then you have a way to download the needed files. just save them on a FAT partition. You'll need to duplicate the slackware download directory structure with a 'slackware' directory and 'a', 'ap', 'l', 'n', and 'x' inside that. As you download the packages save them in their respective directories. Be sure to download the *.txt files also. Also download all the tagfiles, install.end, etc.
Then during the install you'll choose to install from a partition. (Don't pre-mount it.) So, then it'll ask you to specify the partition( /dev/hda5 for instance). Then it'll ask for the exact directory. If you have made a 'slackware' directory at the 'top' (e.g. E:\slackware) then just tell it 'slackware'.
I find it clumsy to download whole directories, so you might try just downloading a bare minimum to start with. Then when you download more, you can put it anywhere on the FAT, navigate to the directory (within running slack) and do: installpkg *.tgz.
You can start with just a few packages to keep your download times to a minimum. The other day I did a fully extendable install of 32MB, so it should only take about 20MB of downloaded packages to start.
Another method would be to download ZipSlack, unzip it onto a FAT partition(100MB), then follow the directions in the faq.txt in the / dir to copy that over to a Linux partition. Then turn the FAT into a swap partition or use it for something else. This actually is the easiest way to install slack. You just unzip the ZipSlack file then with a text editor edit the linux.bat file that's in the / directory so that it points to the partition where you unzipped. Then boot into DOS, or with a DOS bootdisk. Or also, instead of using the linux.bat/loadlin method, you can just boot with the Slackware bootdisk and at the first prompt type: mount root=/dev/hda? replace the ? with the correct partition #.
I should have asked: is the computer installed with another OS, and what, if so?

Rodrin 03-05-2004 01:16 PM

Out of curiosity, have you tried booting from the Slackware bare.i disk by typing usbfloppy at the boot prompt? I only ask because in the instructions for creating your own Runt install, I don't see anything about doing something special to make USB drivers available from the boot floppy, so it makes me wonder if that's because they're already present on the Slackware boot disk.

hotplainrice 03-05-2004 06:21 PM

- Results from testing with Slacks bare.i

boot: usbfloppy
Could not find kernel image: usbflopp.y

I'm sorry if I'm wasting your time.

The last error messages after it recognizes my MITSUMI USB FDD

VFS: Cannot open root device "sdb1" or 08:11
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 08:11

It does provide the driver but its doing whats it suppose to do, boot RUNT. (Hope I'm not wrong) How do I get it to load install.1 and install.2? Get another floppy drive and get the RUNT bootdisk to mount root on it? :tisk:

hotplainrice 03-05-2004 07:45 PM

And I forgot to mention that my default OS is Windows Xp.

gnashley 03-06-2004 03:04 AM

try the suggestion that Rodrin gave but using the RUNT bootdisk- at the `boot:` prompt type `usbfloppy` then ENTER. If that doesn't work try (at boot:) usb root=\dev\sda1
I have only used the RUNT disk to boot ZipSlack so I'm not exactly sure if this will work.
If you can't get it to work use the ZipSlack method to install. Make a 100MB partition with your XP and format it using FAT filesystem. Unzip ZipSlack there and then use the RUNT or bare.i bootdisk to boot and type mount root=\dev\hda5 rw. This will boot zipslack. Then using fdisk or cfdisk from within Slack you can create a Linux type 83 partition and format it iwth your choice of filesystem (I recommend reiser). Then follow directions in faq.txt to copy that over to the linux partition.
then reboot again with the floppy and point it to the new partition:
mount root=\dev\hda6 ro
Then run lilo and you should be all set. You can add any more packages you want afterward.

Rodrin 03-06-2004 01:12 PM

My mistake. I wasn't paying close enough attention. I failed to note that RUNT uses Syslinux to boot from the floppy, so usbfloppy is one of the Syslinux menu items in its config file. To fairly test whether this would work from the Slack floppy you would need to boot with the append line that Syslinux feeds to the kernel when you choose usbfloppy, which is as follows:

initrd=initrd.gz root=/dev/sdb1 vga=normal rw SLACK_KERNEL=bare.i

The key parts to this are the root option and the initrd file, since it actually contains the USB modules necessary to load your USB devices. Since the initrd.gz file here will not fit on the Slack disk, there would be a problem trying to include it. There may be a way around this. I will look into it further.

I hate to advise someone to use trial and error methods (although I do it all the time myself), but it's possible that a custom boot disk made from a copy of the Slack boot disk with the system~1.gz file (and perhaps the config file as well) removed to make room for the initrd.gz file from the RUNT bootdisk would work by typing at the boot prompt

initrd=initrd.gz root=/dev/sdb1

(or possibly using /dev/sda1). Of course this would amount to little different than the RUNT boot disk, so that may be all that you need if you hand it the usbfloppy option as gnashley suggested.

If usbfloppy doesn't work, the shortcut to try the RUNT bootdisk with the /dev/sda1 root option is just to type usb at the boot prompt. This may well be the problem you had with your last attempt at using the RUNT floppy, because it seems to be programmed under the assumption that a USB jump drive will be sda and the USB floppy will be sdb. So the floppy would probably be sda if you have no other USB devices (or something else using up SCSI drive device files). It won't work with just the root option because you need the USB modules in the initrd.gz file.

hotplainrice 03-06-2004 07:53 PM

I'm sorry but I have no idea what is initrd and where do I find? I did a ZipSlack install according to gnashley but I'm still curious whether your suggestion would work..

Rodrin 03-06-2004 08:15 PM

If you look on the RUNT boot floppy you will find initrd.gz (I believe it's formatted MS-DOS (FAT16) so you will be able to see its contents even from Windows). This file contains modules for USB connectivity. This is what gives RUNT the ability to boot from a USB floppy or a USB pen drive.

If you want to test this out, you could first try booting from the RUNT floppy by typing at the boot line usb instead of usbfloppy since this will boot using /dev/sda1 instead of /dev/sdb1 as usbfloppy does, but it also includes the initrd.gz file on the floppy which loads USB modules for your kernel. If you just try to boot with root=/dev/sda1 appended at the boot prompt, the initrd.gz file will not be loaded and you will have no USB connectivity so the kernel cannot possibly find your floppy drive. If booting the RUNT floppy by typing usb at the boot prompt makes it so the kernel can find the drive, you can probably use the install.1 and install.2 disks for your root disks. If not, it is still possible you could make a floppy with some combination of files from the Slack bare.i floppy and the RUNT boot floppy that would work.

I wanted to clarify this a little more. In the last post you made before you got Zipslack going you said that the RUNT floppy recognized your USB floppy drive, but then it said that it could not find the root drive that you had specified. You did not actually specify the root drive yourself, but by picking the usbfloppy option in Syslinux (which is the method used to boot the system from these floppies) you told the kernel to boot with the options this menu choice specified (and which I showed in an earlier post) which included both /dev/sdb1 as the root device and initrd.gz from the floppy as the initrd file (an initrd file is optional to boot a kernel, but is necessary in this case to load the USB drivers). So that attempt correctly loaded the initrd file, including the USB driver modules, but it did not correctly identify the device which the USB floppy was recognized as. Apparently /dev/sdb1 is not where the floppy is loaded. The most likely alternative place for it to be loaded by the kernel is /dev/sda1. Since using usb as a Syslinux menu choice loads the kernel with the same parameters as usbfloppy except that it specifies /dev/sda1 as the root device, this may get the device properly loaded.

All times are GMT -5. The time now is 05:14 AM.