Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 12-07-2005, 10:09 PM   #1
LQ Newbie
Registered: Feb 2005
Location: CT
Distribution: Slackware 10.1
Posts: 21

Rep: Reputation: 15
fstab problem

First of all, I'm running Linux 2.6.11 on Slackware 10.1.
Alright, so my problem is fstab is gone, not there and it breaks all of my permissions.
So I edited my fstab. I guess I didn't look over it well enough. I saved and exited. Went to restart my computer and it was claiming i didn't have permission from a file 'urandom' I think. Well, I rebooted again, figured maybe my old kernel (2.4.6? the one that comes standard with 10.1) I get it booted, but it complains about LILO with the wrong permissions and stuff. I only get it in the recovery console. So I go to edit fstab to change what mistake I made. Only to find out it's not there. It says something like 'etc/ftsab: not readable. input-output error.' I reboot, and this time I enter some extra commands into LILO, I put in 'mount root=/dev/hda1 rw' So I get past the permission error, from the first time. I thought it was all fixed or something. Just a fluke. Well I start up X, and try to open a terminal. Nothing. I can't open anything in X. I ctrl+alt+backspace, get into CLI and check for my fstab, not there.
I don't know what to do right now? And ideas? I'd like to save all my data since I'm not backed up yet, but is there anything I can do to get fstab working again?
Old 12-07-2005, 11:54 PM   #2
Senior Member
Registered: Jun 2003
Location: California
Distribution: Slackware
Posts: 1,181

Rep: Reputation: 49
You mean the file `/etc/fstab` is not present?
Old 12-08-2005, 05:56 AM   #3
LQ Newbie
Registered: Feb 2005
Location: CT
Distribution: Slackware 10.1
Posts: 21

Original Poster
Rep: Reputation: 15
Yes. if I do 'ls /etc/fstab' it returns 'input/output error'.
Old 12-16-2005, 07:39 AM   #4
Registered: Nov 2005
Posts: 120

Rep: Reputation: 15
could it be the editor you used that didn't write back in the right format?

Last edited by yoron; 12-16-2005 at 07:49 AM.
Old 12-16-2005, 08:03 AM   #5
Registered: Nov 2005
Posts: 120

Rep: Reputation: 15
I think you should reinstall your liloconfig
Here is my etc/fstab:
Depending on what filesystems you use, maybe you can use/change it??

/dev/hda2 swap swap defaults 0 0
/dev/hda3 / reiserfs defaults 1 1
/dev/hda1 /Wxp vfat defaults 1 0

/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0

The first field, (fs_spec), describes the block special device or remote filesystem to be mounted.

The second field, (fs_file), describes the mount point for the filesystem

The third field, (fs_vfstype), describes the type of the filesystem. Linux supportslots of filesystem types

The fourth field, (fs_mntops), describes the mount options associated with thefilesystem.


The fifth field, (fs_freq), is used for these filesystems by the dump(8) command todetermine which filesystems need to be dumped. If the fifth field is not present, a value of zero is returned and dump will assume that the filesystem does not need to be dumped.


The sixth field, (fs_passno), is used by the fsck(8) program to determine the order in which filesystem checks are done at reboot time
If the sixth field is not present or zero, a value of zero is returned
and fsck will assume that the filesystem does not need to be checked.


/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
Old 12-21-2005, 03:11 PM   #6
Registered: Aug 2003
Location: Mallorca, Spain
Distribution: xubuntu
Posts: 551

Rep: Reputation: 38
here is mine if it helps:

# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/hda1 / ext2 defaults 1 1
/dev/hda7 /home ext3 defaults 1 2
#/dev/hda6 /misc ext3 defaults 1 2
none /mnt/cdrom supermount dev=/dev/hdb,fs=auto,--,umask=0,user,iocharset=iso8859-15,codepage=850,pamconsole,utf8,managed 0 0
#/dev/hdd1 /movies ext3 defaults 1 2
#/dev/hdc1 /music ext3 defaults 1 2
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0
Old 12-21-2005, 03:26 PM   #7
Registered: Oct 2003
Location: Florida
Distribution: Slackware
Posts: 273

Rep: Reputation: 30
If it's not there, you need to create it and make it look like some of those above, if it is there but it's still saying that, you might have it chmoded wrong, my permissions are set to
if that helps.

Good luck


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab problem: mount: can't find dvd in /etc/fstab or /etc/mtab Nikon01 Slackware 5 11-17-2006 06:15 AM
The fstab problem that should have been beebelo Ubuntu 10 11-03-2005 11:23 PM
Please help - fstab problem mickeyboa Fedora 16 02-25-2005 05:12 PM
Problem with fstab rgriffin Fedora 3 03-25-2004 06:23 PM
fstab problem element Linux - Software 2 06-17-2003 01:06 PM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:32 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration