-   Slackware (
-   -   Frustrating mouse acceleration (

Woodsman 04-19-2013 03:39 PM

Frustrating mouse acceleration
My mouse pointer does not always configure correctly with acceleration not working at all. Restarting X does not resolve the problem. Only a full reboot resolves the problem.

Without acceleration, moving the mouse pointer is like pushing peanuts.

At one time the problem occurred about once a month, so about once every 30 to 50 reboots. Lately the problem seems to occur about once every 5 reboots.

I have been unable to pinpoint any cause or reason.

The mouse is a generic Microsoft optical device, appearing in lsusb as:

Bus 002 Device 003: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical

I haven't tested a different mouse.

I appreciate any thoughts or ideas. :)

casualfred 04-19-2013 07:37 PM

I had a problem where my laptop trackpad had no acceleration. I discovered the xset program - maybe you could experiment with it. To make my mouse more sensitive, I gave the command:

xset m 5/3 0
The manpage tells you all about it and how to tweak the settings. I just set that command to run whenever my window manager (fluxbox) starts. Hopefully this is helpful for you.

Woodsman 04-19-2013 09:04 PM

Thanks. The problem is not the lack of acceleration but the lack of consistent acceleration. Sometimes the system boots fine and other times not.

casualfred 04-19-2013 09:54 PM

It might be interesting to double check if it is always loading the same driver/module... Or, that might be a silly suggestion - just thinking out loud. What window manager/desktop environment do you use by the way (though that probably has nothing to do with the problem)?

speck 04-20-2013 03:03 AM

I'm not a KDE/XFCE user so I don't know if those DE's somehow modify the mouse sensitivity/acceleration, but you may want to look at the output of xset when the mouse is acting fine and then run it again when it isn't to see if there are any differences in the output.


xset q | grep acceleration
I have an xset command (xset m 2 2) in my ~/.xinitrc file that gets called via the startx script and I've never had any issues with it changing (I use i3 as my window manager).

Woodsman 04-20-2013 12:46 PM

As far as I know, the system uses the evdev module for the keyboard and mouse. Is there anything else I can check other than lsmod?

I'll try to remember to run the xset command each time I reboot. I'm running fine today and the command returned:

acceleration: 20/10 threshold: 4

As everything is running fine today, I'll presume that result is my baseline for normalcy.

Mostly I run the Trinity Desktop and sometimes KDE4. Because restarting X never helps resolve the problem, I don't think the desktop environment is the culprit, although I won't discount that possibility. Conversely, if the xset query provides the same result when I lose acceleration then I'll have to look deeper into the desktop.

Another possibility could be the nvidia drivers.

The part that puzzles me is why restarting X fails and only a hard reboot helps. To me that implies the kernel and modules.

Woodsman 04-26-2013 01:05 PM


When I lose acceleration the xset command reports the same settings:

acceleration: 20/10 threshold: 4

fogpipe 04-26-2013 03:26 PM

I would just try a different mouse. A mouse or keyboard malfunction can look like a lot of other things. Good luck

All times are GMT -5. The time now is 06:23 AM.