-   Slackware (
-   -   Frustrated newbie Slackware hardware setup (

jimdaworm 09-15-2003 01:57 PM

Frustrated newbie Slackware hardware setup
I have about 3 weeks experience with Red Hat 9.0 I had very few problems appart so, I changed Red hat for Slack 9.0 and now have the following problems.

I have read lots of articles here for the following but trying to follow the instructions (as you do when you donīt know what your doing) has only caused more problems.

Radeon 9100 250mhz ddr128mb , was running default vga drivers I tried following the instructions on a post here and now it doesnīt work at all... canīt run x anymore.

Intel 810 ac97 onboard sound, this is detected as:
Silicon Integrated Systems [SiS] SiS7012 PC I Audio Accelerator (rev a0) Subsystem: C-Media Electronics Inc: Unknown device 0300

There are a million and one articles on this but I still donīt understand exactly what it is I need to do to make it work! I tried typing the following commands (as someone said in one of the articles on here) but they didnīt seem to make any difference:

modprobe soundcore
modprobe ac97_codec
modprobe i810_audio

If anyone can give me some really basic well explained step by step soluctions or even a push in the right direccion with either of these problems it would be REALLY appreciated.

I am off to try for the FIRST TIME to compile my kernal now as I canīt really see anyway I can do any damage :)


tangle 09-15-2003 02:21 PM

Did you edit your /etc/rc.d/rc.modules files and uncomment those lines in it? After you ran the modprobe command, did you restart X? You will need to do that. If you reboot and do not uncomment those lines it will not save the loaded modules.

So, run the modprobe command on those modules and then restart X (if you login from a GUI there should be a button to restart X, if not crtl+alt+backspace does it). Then if the that worked, edit the /etc/rc.d/rc.modules.

I have never used ATI drivers for Linux. But if they are anything like the Nvidia drivers, just follow the directions on the webstie.

jimdaworm 09-16-2003 12:53 PM

Thanks but recompiling my kernel seams to have worked
I have compliled my kernel (For the first time) and incoperated my 810 ac97 now it works! I donīt really understand how it all works but I just took out the other sound drivers for hardware I donīt have and included the one for my sound and it seems to work!


egh128 09-16-2003 04:41 PM

It works because a kernel compile is where you set up your kernel to support only the hardware you use. This makes the kernel smaller, hince, faster.

All times are GMT -5. The time now is 09:34 AM.