LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   frozen bubble (https://www.linuxquestions.org/questions/slackware-14/frozen-bubble-296657/)

acidjuice 03-02-2005 07:23 AM

frozen bubble
 
dear all,

i've tried installing this wonderful game from http://www.frozen-bubble.org. it all installed fine. however, when i run the game, just nothing happens.

i also tried getting the package from linuxpackages.net. it installed the same way, still i don't get it to run.

i just click on Actions / Run i type frozen_bubble and... nothing.

any ideas?

uman 03-02-2005 07:28 AM

try
Code:

frozen-bubble
that is, with a hyphen instead of an underscore. If that still doesn't work, try running it from the terminal and post the output.

Hope this helps,
uman

acidjuice 03-02-2005 08:12 AM

Can't locate SDL.pm in @INC (@INC contains: /usr/lib/perl5/5.8.6/i486-linux /usr/lib/perl5/5.8.6 /usr/lib/perl5/site_perl/5.8.6/i486-linux /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl .) at /usr/local/bin/frozen-bubble line 51.
BEGIN failed--compilation aborted at /usr/local/bin/frozen-bubble line 51.


this what i get...

reddazz 03-02-2005 08:26 AM

The website has a list of dependencies, make sure that all of them are installed.

acidjuice 03-02-2005 08:33 AM

ok real noob here...

exactly what am i sopposed to do to install dependencies...? just like a normal package, i get them from linuxpackages.net?

keefaz 03-02-2005 08:41 AM

Look at this thread :
http://www.linuxquestions.org/questi...oto=nextoldest

acidjuice 03-02-2005 10:09 AM

hello,

thank you but the linked post was useless to me, since i did not experience the same error.

well, i got back to the old school, got ALL dependencies and compiled them from source. using linuxpackages just didn't do.

i can happily play now :D

long lives slack :)

noxious 03-02-2005 03:39 PM

I had this problem also... what I did was to go back to the Frozen-Bubble site and download the dependencies - you shouldn't need Perl, that should already be on your system. Install SDL_image first, then SDL_mixer, then SDL, then perl-SDL.

Then you can install Frozen-Bubble. Even if you've already done all this, do it again in this order, and give it a try.

Try it without installing Perl - I'll bet it works now.


All times are GMT -5. The time now is 08:31 PM.