-   Slackware (
-   -   Fresh Copy of Slack 10.2 Won't Detect Hardware (

Mach Won 05-22-2006 09:21 PM

Fresh Copy of Slack 10.2 Won't Detect Hardware
Well, I finally got a working copy of Slackware up and running on my desktop, however, I'm having some hardware issues. First and foremost, my network card doesn't seem to be functioning properly because I cannot connect to my router. I tried running netconfig, but that hasn't helped me. Also, my monitor has not been properly detected, so I'm running at 1024x768 on a 1280x1024 LCD, which is harsh on the eyes.

Can anyone help walk me through this? I guess I should mention that my NIC is integrated and that my monitor is an LG Flatron 1720P.

forrest44 05-22-2006 09:33 PM

Does your NIC show up when you run 'lspci'?

Mach Won 05-22-2006 09:38 PM

I think so, this is what is listed:

00:03.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)

I'm probably just missing some sort of activation step for the network card.

gbonvehi 05-22-2006 09:44 PM

Mmm weird, it should be detected and the correct module (sis900) loaded. Which kernel did you choose to install? If you choose test26.s please read the RELEASE_NOTES and search this forum (there are tons of threads about this).

Mach Won 05-22-2006 09:55 PM

I believe I chose the standard kernel, I definitely didn't pick any special kernels like test.

EDIT: When I try to ping my router, I get this message: "connect: Network is unreachable"

I managed to fix the NIC issue by turning off Plug and Play. Now I need to fix the monitor and possibly the sound card.

cwwilson721 05-22-2006 11:16 PM

Monitor can 'usually' be set when you run 'xorgconfig'

But what video card do you have?

(Lets get video first, then audio)

forrest44 05-23-2006 04:29 AM

Mmm... you can usually get the sound working pretty easy by running 'alsaconf' as root.

Have you tried using 'xorgconfig' to set up your xorg.conf file?

All times are GMT -5. The time now is 08:53 PM.