LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   freetype upgrade for -current May 9 breaks wine (https://www.linuxquestions.org/questions/slackware-14/freetype-upgrade-for-current-may-9-breaks-wine-4175674948/)

kgha 05-10-2020 09:24 AM

freetype upgrade for -current May 9 breaks wine
 
After upgrading freetype to latest 2.10.2 version, wine applications either don't start or start partially (my wine version is Eric's wine-5.6 package).

Trying to run a wine app from terminal gave the message that freetype couldn't be found.
Downgraded to freetype-2.10.1 and all is well...

The sole difference between the old and new version seems to be that /usr/lib/libfreetype.so.6.17.1 is replaced with libfreetype.so.6.17.2.

Any clue to why wine can't handle that change?

Oh, and yes - I run -current multilib, and I did create a freetype compat32 version and upgraded that, too...

cwizardone 05-10-2020 09:34 AM

Working just fine here, but, then, I just run a simple ms-windows application from 1994, "The American Heritage Electronic Dictionary". All the fonts look as they should.

kgha 05-10-2020 09:57 AM

I only run four applications on wine:
Harzing's Publish or Perish - works with the latest freetype upgrade but leaves a residual "blob" on the desktop after closing.
A simple ms-application (church records database) - starts, but with broken search engine
Softmaker's FlexiPDF - won't start.
Adobe ADE - won't start.

Update - tried the following:

Reinstalling wine - no change
creating a fresh prefix - no change (I get the "Wine cannot find the FreeType font library" message)
tried a dirty trick creating a symlink /usr/lib/libfreetype.so.6.17.1 pointing at 6.17.2 (with symlinks libfreetype.so and so.6 pointing at the new symlink) - no change

To me it seems as there's something in the new libfreetype library that causes this.

kgha 05-11-2020 01:09 AM

Solved.
I remembered that I had one other 32 bit program installed, namely acrobat reader. Trying to start that with the latest freetype gave me the error message
Code:

/opt/Adobe/Reader9/Reader/intellinux/bin/acroread: error while loading shared libraries: libbrotlidec.so.1: cannot open shared object file: No such file or directory
et
This is a consequence of the latest freetype having support for woff 2:
https://www.phoronix.com/scan.php?pa....10.2-Released

Created/installed a brotli-1.0.7 compat32 package, acrobta reader and all my wine apps run again :D


All times are GMT -5. The time now is 04:33 PM.