LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-10-2010, 03:51 PM   #1
hgriggs
Member
 
Registered: Mar 2010
Location: Virginia USA
Distribution: Slackware
Posts: 32

Rep: Reputation: 2
Framebuffer, i915, and Slackware current and Asus eeepc


Got an Asus eeepc 900a. Runs Intel 915 graphics. Upgraded to slackware current last week. X would not start. Based on info here, I reverted back to earlier libdrm and xf86-video-intel. That got it working again.

Updated Slackware current again today. I think I got a new kernel. Now, halfway through boot time, the screen goes blank, then comes back and the font is tiny. Gone into framebuffer mode. If I start X, it just freezes. Nothing but a reboot will get out of it.

I have vga=normal in lilo.conf, but I read that this is no longer used. I can find no way to turn off framebuffer mode. From other threads here, I have tried append="i915.modeset=1" in lilo.conf. Has no effect.

I could revert Slackware to 13.0 from current, and that would make the eeepc useful again. Is there anything else I should try?
 
Old 03-10-2010, 05:23 PM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
i915.modeset=1 *enables* kernel modesetting (ie. the high resolution framebuffer). You could use the 'nomodeset' kernel option to disable KMS. Having said that, the Xorg intel driver on -current will not work if KMS is disabled, from what I've read.

Adam
 
Old 03-10-2010, 05:23 PM   #3
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
i915.modeset=1 *enables* kernel modesetting (ie. the high resolution framebuffer). You could use the 'nomodeset' kernel option to disable KMS. Having said that, the Xorg intel driver on -current will not work if KMS is disabled, from what I've read.

Adam
 
Old 03-10-2010, 05:50 PM   #4
DonnieP
Member
 
Registered: Jan 2008
Location: Richmond, VA USA
Distribution: Slackware
Posts: 144

Rep: Reputation: 29
Quote:
Originally Posted by hgriggs View Post
I could revert Slackware to 13.0 from current, and that would make the eeepc useful again. Is there anything else I should try?
Try this combination:
  • In your /etc/rc.d/rc.local: modprobe i915 modeset=1
  • In your /etc/lilo.conf comment out any vga= line
  • Nothing about modeset in your /etc/lilo.conf append line
Yes, this "turns on" kms, but in the latest kernel my understanding is that it's turned on anyway. And you cannot mix kms with a vga= line in your /etc/lilo.conf. And, yes, your virtual consoles will have smallish font by default in kms. This is the combination of settings I use with my 900a with Slackware 13.0 (not current) to use kms. Since the kms works beautifully with the 13.0 kernel on the 900a I would have thought it would work on the latest kernel as well, but perhaps not.
 
Old 03-10-2010, 06:50 PM   #5
hgriggs
Member
 
Registered: Mar 2010
Location: Virginia USA
Distribution: Slackware
Posts: 32

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by DonnieP View Post
  • In your /etc/rc.d/rc.local: modprobe i915 modeset=1
  • In your /etc/lilo.conf comment out any vga= line
  • Nothing about modeset in your /etc/lilo.conf append line
I followed your directions, made sure I ran lilo, rebooted, it went to framebuffer and the font got small. Started X and it went black and locked up tight. Ctl-Alt-Bckspc doesn't work, Ctrl-Alt-Del doesn't work, Ctrl-C doesn't work. I have to power the thing down and then back up again, fsck the SSD, reboot.

A look in /var/log/Xorg.0.log shows it getting ready to "Setting up VESA Mode 0x115 (800x600) and then kablooie, that's the end.

Xorg.0.log shows "VESA VBA OEM: Intel(r) 82945GM Chipset Family Graphics Chip Accelerated VGA BIOS". Does this still come under Intel 915 Graphics?

Near the start of Xorg.0.log, I see this:

(EE) module ABI major version (5) doesn't match the server's version (6)
(II) UnloadModule: "intel"
(II) Unloading /usr/lib/xorg/modules/drivers/intel_drv.so
(EE) Failed to load module "intel" (module requirement mismatch, 0)
(II) LoadModule: "vesa"

Is this significant?
 
Old 03-10-2010, 07:12 PM   #6
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Sounds like you are mixing and matching Xserver and X driver packages of different versions.

Adam
 
Old 03-10-2010, 08:16 PM   #7
DonnieP
Member
 
Registered: Jan 2008
Location: Richmond, VA USA
Distribution: Slackware
Posts: 144

Rep: Reputation: 29
The only other option I can think to try - following the theory that kms is now enabled by default - is to eliminate my first bullet (rc.local). So basically you have no "modeset" mumbo-jumbo anywhere - not in rc.local and not in lilo.conf and also you have no vga= line in lilo.conf either.
 
Old 03-10-2010, 08:27 PM   #8
DonnieP
Member
 
Registered: Jan 2008
Location: Richmond, VA USA
Distribution: Slackware
Posts: 144

Rep: Reputation: 29
Oh - another question: Are you using your own xorg.conf? If so, try without it.
 
Old 03-10-2010, 09:02 PM   #9
hgriggs
Member
 
Registered: Mar 2010
Location: Virginia USA
Distribution: Slackware
Posts: 32

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by DonnieP View Post
Oh - another question: Are you using your own xorg.conf? If so, try without it.
No, I have no xorg.conf.

I will try your other suggestions tomorrow when I have access to the machine again, and I'll report back. I'll also check the versions of everything and make sure I have no mismatches.

Thanks for all the help guys.
 
Old 03-11-2010, 09:31 AM   #10
hgriggs
Member
 
Registered: Mar 2010
Location: Virginia USA
Distribution: Slackware
Posts: 32

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by DonnieP View Post
The only other option I can think to try - following the theory that kms is now enabled by default - is to eliminate my first bullet (rc.local). So basically you have no "modeset" mumbo-jumbo anywhere - not in rc.local and not in lilo.conf and also you have no vga= line in lilo.conf either.
Okay, so I checked all these things:
I have no vga= line in lilo.conf.
I have no append with modeset in lilo.conf.
I have no modprobe and modeset in rc.local.
I downgraded libdrm and xf86-video-intel packages (previously mucked with to get it work after last upgrade), and forced an upgrade so I have current versions of both.

It now works. X starts and my netbook is useful again.

Thanks for the help. I sure learned a lot of stuff from this process.

I have one more question relating to my reading in the forums. If someone says "blacklist nouveau" and I think this relates to modules, what is this blacklist thing, and how do you do it? I don't need to to do anything more on my netbook, I just want to know what this means.
 
Old 03-11-2010, 11:49 AM   #11
DonnieP
Member
 
Registered: Jan 2008
Location: Richmond, VA USA
Distribution: Slackware
Posts: 144

Rep: Reputation: 29
Blacklist means /etc/slackpkg/blacklist. It's where you put packages you don't want slackpkg to ever upgrade or to ever install-new. For instance, I did not install the kde packages on my 900a originally, so I put /slackware/kde in my blacklist file so that slackpkg doesn't keep trying to install them.
 
Old 03-11-2010, 12:07 PM   #12
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
I think in this case blacklist actually means adding a module name to /etc/modprobe.d/blacklist.conf to keep it from getting loaded when the kernel boots.
 
Old 03-11-2010, 01:18 PM   #13
hgriggs
Member
 
Registered: Mar 2010
Location: Virginia USA
Distribution: Slackware
Posts: 32

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by adamk75 View Post
I think in this case blacklist actually means adding a module name to /etc/modprobe.d/blacklist.conf to keep it from getting loaded when the kernel boots.
Yes, this was it. Blacklisting drivers so they don't get loaded. Thanks. I'll dig further into this.
 
1 members found this post helpful.
Old 06-09-2010, 03:35 PM   #14
vit_r
LQ Newbie
 
Registered: Jun 2008
Posts: 14
Blog Entries: 1

Rep: Reputation: 0
If on booting Slackware 13.1 screen font becoms tiny next can be tried:

In lilo.conf delete any 'vga = XXX'. Then:

{{{

append=" vt.default_utf8=1 "

image = /boot/vmlinuz-huge-smp-2.6.33.4-smp
root = /dev/sdaP
label = aP # As it comes with KMS enabled
read-only

image = /boot/vmlinuz-huge-smp-2.6.33.4-smp
root = /dev/sdaP
label = aP_640x480 # LatArCyrHeb-16.psfu.gz COLUMNS=80 LINES=30
read-only
addappend=" video=VGA-1:640x480 " # Seems KMS is off

image = /boot/vmlinuz-huge-smp-2.6.33.4-smp
root = /dev/sdaP
label = aP_800x600 # LatArCyrHeb-19.psfu.gz COLUMNS=100 LINES=31
read-only
addappend=" video=VGA-1:800x600 " # Seems KMS is off

}}}

For VGA-DIGIT check /sys/class/drm/card0/card0-XXX-DIGIT
and try 'video=XXX-DIGIT:...' or dig dmesg

( LatArCyrHeb is for ru_RU.UTF-8 )


helpfull:
http://wiki.archlinux.org/index.php/KMS
http://bbs.archlinux.org/viewtopic.php?pid=755266
http://unixforum.org/index.php?showtopic=99485
https://wiki.ubuntu.com/X/KernelModeSetting
http://www.insidesocal.com/click/201...rnel-mode.html
http://www.linuxquestions.org/questi...urrent-736017/


With thanks

Vit
 
Old 06-09-2010, 08:05 PM   #15
mudflap
Member
 
Registered: Jul 2008
Location: Coffin Point
Distribution: Slackware - ttylinux - CPO
Posts: 53

Rep: Reputation: 15
Some of the other responses may be giving better advice, but here is my two cents:

In your lilo.conf:

1: hash out any line that says "vga=xxx", your penguin should re-appear.

If it worked, you would want an append that might included "video=intelfb ...", but current kernels are not up to this yet.
Intel graphics automatically detect and use the highest resolution available for their framebuffers.

2: to enlarge the text on your boot console, add an append that forces one of the built-in kernel fonts. eg:

append="fbcon=font:SUN12x22"

Your choices will be whatever was built with your kernel, check "/proc/config.gz"



In your xorg.conf:

In the Graphics Device Section:
Change the "Driver" line to ' Driver "Intel" '
Remove reference to specific Intel drivers. eg:change ' Driver "Intel..." ' to ' Driver "Intel" '
If that doesn't work, revert to the vesa framebuffer drivers: ' Driver "vesa" '

You will probably not notice any lack of performance with vesa framebuffers in X overall, but may have trouble with DVDs due to the lack of acceleration.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Asus eeePC with slackware? Laodiceans Slackware 32 02-13-2010 07:27 AM
ASUS EeePC EZOS ronald medei Linux - Newbie 2 06-16-2009 10:59 AM
debian on Asus EEEPC cccc Debian 6 10-26-2008 02:04 PM
asus eeepc ghodkiller Linux - Hardware 5 10-12-2008 01:37 PM
Reviews of Asus EeePC phantom_cyph General 20 03-13-2008 04:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration