-   Slackware (
-   -   forward and reverse DNS don't match (

Neoslak 12-14-2003 03:12 PM

forward and reverse DNS don't match
This is a confusing topic to me. I've tried to decipher the answer to this question... from FAQs, forums, google, etc. and figure out specifically what, if anything, it is I need to do.
It seems like everywhere I look to resolve this confusion, the how-tos, FAQs, etc. and all the examples I find are for servers with a static ip.

Here is the problem:

I have DSL connection with a dynamic IP on eth0 on my Slackware Linux firewall/nat/gateway. I'm using the IPTables/NetFilter NARC firewall and my lan behind my firewall is on my 192.168.0. network.

When I use XChat to connect to IRC I always get the following message and a lengthy delay before it finally connects:

--- Looking up
--- Connecting to ( port 6667..
--- Connected. Now logging in..
--- *** Looking up your hostname...
--- *** Checking ident
--- *** Your forward and reverse DNS don't match
--- *** No identd (auth) response

I don't have a true registered 'fully qualified domain name', although I do have an account on a DHS server that routes connections to me if needed.

On my lan I have various hosts on my 'made up' domain name. My /etc/hosts files look something like this: localhost jepetus azreal genesis lordsoth lenny zeus

my resolv.conf files point to my ISP's nameservers.

Is this 'reverse DNS' thing something that I need to put in named.conf? I haven't really tried to set up anything except a local caching name server... that I'm not even really using, and setting up it was simply following steps on a how-to...

So, what do I need to do? Edit named.conf? With what? Do I have to have a name server to resolve this? Do I edit some configuration file for identd? tcpd? inetd? What??? Does my ISP have to provide a reverse lookup or something? Is there some ports I need to enable on my firewall (53?)?

Dazed and Confused -


Linux, the free OS....except for your SOUL! MOUHAHAHAHA!

All times are GMT -5. The time now is 09:03 AM.