-   Slackware (
-   -   force eth0 to use e100 (

nutthick 11-13-2004 03:52 AM

force eth0 to use e100
I'm a newbie that's been trying to get my motherboard NIC to work with Slack, but no luck. I though I needed the manufacturer's drivers, but couldn't get them to install. Eventually, out of frustration I installed Redhat, which picked up on the NIC, without problems using e100. I really want to use Slack, as as far as I can see it is the best distro for what I want. I'm assuming the e100 driver on Redhat and Slack are the same. How do I force Slack to identify the NIC as e100, currently is doesn't find it at all.

mdarby 11-13-2004 09:37 AM

What NIC / Motherboard do you have?

nutthick 11-13-2004 09:43 AM

I haven't opened up the box to find out (it's a fanless system so is a bit of a jigsaw to pull apart). I think it's either an Intel 865G or 815, with a SiS 651/962/5.1 chipset. I've just taken that off the driver disk that came with it.

WMD 11-13-2004 11:50 AM

If Redhat picked it up as e100, then just modprobe e100 in Slackware and it should load up properly.
Then, edit /etc/rc.d/rc.modules so it loads e100 at bootup.

nutthick 11-13-2004 12:29 PM

Thanks, I'll give it a try when I reload Slack

nutthick 11-14-2004 06:00 AM

That worked perfectly, thanks WMD

gbonvehi 11-14-2004 06:12 AM

Glad you solved the problem nutthick, next time you can know about your hardware by typing lspci as root.

All times are GMT -5. The time now is 08:08 PM.