LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-27-2003, 02:15 PM   #1
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
fonts problem


when i copy my windows .ttf fonts to /usr/X11/lib/fonts/TTF and reboot, the fonts show up in the selection lists (using KDE right now), but when i select them all i get is little square boxes. the same thing happens if i make a /usr/share/fonts directory and put them in there. if i put them in ~/.fonts they're not even recognized, but i'm okay with that for now b/c i'd rather have them in one of the other directories.

the bitsream vera fonts i installed work fine (except in mozilla still working on that) -- do i need to install the win .ttf fonts somehow also? all of the other threads i read here said just to copy them into the directories mentioned and reboot. i uncommented the load .ttf lines in XF86Config, if that matters (apparently it doesn't ).
 
Old 07-27-2003, 03:57 PM   #2
lfur
Member
 
Registered: Jul 2003
Location: Slovenia
Distribution: Slackware & FreeBSD
Posts: 209

Rep: Reputation: 30
Well this is not a sollution to your problem, but I've seen alot of people rebooting after adding some fonts. Why?? if you can just (after the fonts are added to the dir):
Code:
xset +fp /font/path
mkfontdir
xset fp rehash
And, if you haven't already done it, add the font-path to font section in XF86Config.

Sorry that I didn't answer your question, but at least you won't reboot the next time you add fonts.

Enjoy

Last edited by lfur; 07-27-2003 at 04:01 PM.
 
Old 07-27-2003, 04:32 PM   #3
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Original Poster
Rep: Reputation: 47
here's what i get with xset:

Code:
$ xset +fp /usr/share/fonts
xset:  bad font path element (#64), possible causes are:
    Directory does not exist or has wrong permissions
    Directory missing fonts.dir
    Incorrect font server address or syntax
as root it says command not found.

yes, the path (/usr/share/fonts) is in XF86Config, but again the MS ttf fonts are showing up as the little boxes in KDE, and not showing up in mozilla at all. thx.

>edit: i'm just wondering if i missed something during slackware installation that i need to make the fonts available?

Last edited by synaptical; 07-27-2003 at 04:43 PM.
 
Old 07-27-2003, 06:14 PM   #4
lfur
Member
 
Registered: Jul 2003
Location: Slovenia
Distribution: Slackware & FreeBSD
Posts: 209

Rep: Reputation: 30
Hmmm ... are you sure you executed the:
Code:
mkfontdir
inside the directory which contains your fonts, and:
Code:
xset fp rehash
after that?

And another thing. Does this fonts have any specific encoding (character set)? Becouse i had the same problem when setting my X to show Slovenian fonts which have iso8859-2 (latin2) encoding. And than I had to specify in .Xdefaults which fonts xterm should use. It looks like this:
Code:
XTerm*font:         -*-fixed-medium-r-*-*-14-*-*-*-*-*-iso8859-2
XTerm*boldFont:  -*-fixed-bold-r-*-*-14-*-*-*-*-*-iso8859-2
Use xfontsel in X to see what each * may be used for.
 
Old 07-27-2003, 06:59 PM   #5
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Original Poster
Rep: Reputation: 47
okay, it's partially working, here's an update:

i downloaded some microsoft TT fonts and extracted them with the cabextract utility. then i copied them to /usr/share/fonts, with that path still added in XF86Config. so far that has worked (only tried a couple), but they still don't show up in mozilla. i guess that is an "xtt" problem? though the only fixes i have seen for that say to just download the xtt rpm, which i don't want to do w/slack. if anyone has any pointers on documentation to fix that without using rpm, appreciate.

so i guess now the question is, why would fonts get corrupted just copying them from my windows drive to slack? maybe burning them to cd and then copying them into linux would work (would like t know b4 wasting a CD)? or maybe this is now a "linux general" question and not a slack question? (mods feel free to move it )

thanks lfur, appreciate your time.
 
Old 07-27-2003, 07:10 PM   #6
lfur
Member
 
Registered: Jul 2003
Location: Slovenia
Distribution: Slackware & FreeBSD
Posts: 209

Rep: Reputation: 30
I can't help you around mozilla, but when it comes to RPM, you can use rpm2tgz (rpm2gz) command to convert the packages. There are no man pages for this command, just run it withhout any options and it will give you some information.

Glad I was helpfull

Enjoy

Last edited by lfur; 07-27-2003 at 07:11 PM.
 
Old 07-27-2003, 08:39 PM   #7
XPediTioN
Member
 
Registered: Jun 2003
Location: Illinois
Distribution: Slackware 9.1
Posts: 305

Rep: Reputation: 30
How do I use cabextract?
 
Old 07-27-2003, 09:06 PM   #8
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Original Poster
Rep: Reputation: 47
install the source

type:

cabextract filename.exe

done!
 
Old 07-27-2003, 10:20 PM   #9
appler
LQ Newbie
 
Registered: Mar 2003
Location: New Jersey
Distribution: Slackware 9.0
Posts: 22

Rep: Reputation: 15
Try the XFree86 Font De-uglification HOWTO-- it explains about adding TrueType fonts to your system.
www.tldp.org/HOWTO/mini/FDU/
 
Old 07-27-2003, 10:57 PM   #10
Rodrin
Member
 
Registered: May 2003
Location: Upstate NY, U.S.
Distribution: Slackware
Posts: 248

Rep: Reputation: 31
This sounds like it might be a permissions problem. By the way, Mozilla in Slack 9 uses fontconfig, and synaptical took the correct approach for adding True Type fonts to it and other fontconfig programs. It's true that he does not need to reboot to get the fonts to work for these programs. He could just run fc-cache on the directories he installed the fonts in, but rebooting in Slack 9 does this automatically for fonts in the directory /usr/X11R6/lib/fonts and its subdirectories as well as /usr/share/fonts and its subdirectories. Since he already did this, the most likely problem would seem to be that he failed to grant world read permission to the fonts he installed.

If you want to grant read permission to those fonts, just go, as root, to the directories you installed the fonts in and run the command

chmod 644 *.ttf *.TTF
or
chmod +r *.ttf *.TTF

See if that improves your situation at all.

By the way, here is the full procedure that I use to make True Type fonts available to my X Window programs that don't use fontconfig. Run, as root, in the directory where you have put the fonts the following commands:

/usr/X11R6/bin/mkfontscale
(don't leave this out) and
/usr/X11R6/bin/mkfontdir
(the order is important; I accidentally had it the wrong way around before)

Then also add fontpath statements pointing to the directories you have the fonts in under the Files section of your XF86Config file, if they're not already there. For example:
fontpath "/usr/share/fonts/TTF/"

Then add a
Load "freetype"
line under the Modules section of your XF86Config file, again, if it's not already there.

Also most font related questions for Slackware 9 are fairly unique to it, so these aren't really general Linux questions. Fonts setup approaches vary from distribution to distribution.

P.S. Incidentally, I have recently run into a machine where True Type fonts were installed to the directory /usr/share/fonts, not a subdirectory of it, and the fonts were no properly recognized by fontconfig until I moved them to a subdirectory. So this also could be a problem.

Last edited by Rodrin; 07-30-2003 at 11:20 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with fonts oDyman Linux - Newbie 2 11-11-2004 05:05 PM
Problem with fonts Adan Linux - Newbie 3 08-31-2004 08:24 PM
fonts problem jaina2 Linux - Newbie 1 08-05-2003 08:44 AM
fonts problem cyberia_2ooo Slackware 3 04-22-2003 03:52 PM
please help FONTS PROBLEM !!!!!!! jasonk Linux - General 7 11-02-2002 11:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration