LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-10-2018, 05:31 PM   #1
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 914

Rep: Reputation: 204Reputation: 204Reputation: 204
Fontconfig errors: Slackware -current (March 8)


Just updated -current to the most recent: March 8th 2018. I see a lot of fontconfig errors with some applications. A typical sample of these errors is:

Code:
Fontconfig error: Cannot load config file from /etc/fonts/fonts.conf
Fontconfig warning: "/etc/fonts/fonts.conf", line 5: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/fonts.conf", line 6: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/fonts.conf", line 6: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/fonts.conf", line 6: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/fonts.conf", line 7: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/fonts.conf", line 7: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/fonts.conf", line 9: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/30-metric-aliases.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/30-metric-aliases.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/30-metric-aliases.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/30-metric-aliases.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/40-nonlatin.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/40-nonlatin.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/40-nonlatin.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/40-nonlatin.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/40-nonlatin.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/40-nonlatin.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/40-nonlatin.conf", line 8: unknown element "description"
And this is a small sample from a long output of errors...

So I suspect that I am missing something basic here, can somebody point me in the right direction?
 
Old 03-11-2018, 05:17 AM   #2
GazL
Senior Member
 
Registered: May 2008
Posts: 4,770
Blog Entries: 14

Rep: Reputation: Disabled
Which applications?

I saw this from google-chrome which is obviously an alien executable built on a non-slackware system, but I've not seen it from anything else yet.
 
1 members found this post helpful.
Old 03-11-2018, 06:14 AM   #3
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 914

Original Poster
Rep: Reputation: 204Reputation: 204Reputation: 204
Best example is using qaac following this fine guide. A full paste of the errors here. I shall hunt out the other examples on my system...
 
Old 03-12-2018, 03:33 AM   #4
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 914

Original Poster
Rep: Reputation: 204Reputation: 204Reputation: 204
Quote:
Originally Posted by GazL View Post
Which applications?
I am a little slow these days but I can now see that the error occurs with wine applications that run from the command line. So the error is seen with applications such as qaac, fhgaacenc and also foobar200 when I open these from the commandline.

This is using alienbob's wine package:

Code:
andrew@illium~$ wine --version
wine-2.21 (Staging)
andrew@illium~$
So I am not sure if this a fontconfig issue or a wine issue or something amiss on my system?...

Last edited by andrew.46; 03-12-2018 at 03:35 AM.
 
Old 03-12-2018, 06:00 AM   #5
GazL
Senior Member
 
Registered: May 2008
Posts: 4,770
Blog Entries: 14

Rep: Reputation: Disabled
Perhaps wine just needs rebuilding against the new fontconfig library.
 
Old 03-13-2018, 07:29 AM   #6
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 914

Original Poster
Rep: Reputation: 204Reputation: 204Reputation: 204
Quote:
Originally Posted by GazL View Post
Perhaps wine just needs rebuilding against the new fontconfig library.
It is a bit of a beast to recompile . And unfortunately the errors persist...
 
Old 03-13-2018, 01:38 PM   #7
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 1,601

Rep: Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870
The new fontconfig was just something that was recommended as a version bump in -current, so it got upgraded. But is there really anything "better" about it? Perhaps the lucky number 13 (and the even luckier .0 ending) should have been a hint.

What say you all, should this be reverted to the previous version for a while to let things catch up, similar to what we did with freetype?
 
1 members found this post helpful.
Old 03-13-2018, 02:23 PM   #8
number22
Member
 
Registered: Sep 2006
Location: Earth
Distribution: Slackware 14.1 Slackware64-current multilib
Posts: 278
Blog Entries: 7

Rep: Reputation: Disabled
since you only say wine has problem, you probably has mismatch compat32 version of fontconfig with a 64bit system. Just a guess.
 
2 members found this post helpful.
Old 03-13-2018, 05:08 PM   #9
GazL
Senior Member
 
Registered: May 2008
Posts: 4,770
Blog Entries: 14

Rep: Reputation: Disabled
Other than the error/warning messages on stderr I haven't noticed any operational issues, so I'm inclined to say we just live with it. Slackware's not going to be the only distro shipping 2.13.0 and google and other 3rd party vendors will soon catch up.

Having said that, I've no *need* for the latest version, so if you think it prudent to revert while things adjust then that's also fine by me.
 
1 members found this post helpful.
Old 03-13-2018, 06:36 PM   #10
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 914

Original Poster
Rep: Reputation: 204Reputation: 204Reputation: 204
Quote:
Originally Posted by volkerdi View Post
What say you all, should this be reverted to the previous version for a while to let things catch up, similar to what we did with freetype?
The warnings / errors that I have found with wine are a nuisance rather than a problem for me, running qaac + wine with abcde (where I discovered the issue) still produces great audio, just with a spray of font error messages.

I have reverted to fontconfig 2.12.6 on my own system and the errors disappeared so I am happy enough to have found the culprit at least.
 
Old 03-13-2018, 07:58 PM   #11
linuxbawks
Member
 
Registered: Apr 2013
Distribution: Snuckware
Posts: 240

Rep: Reputation: 17
I've more often than not have had to clear out the crud from /etc/fonts/* and /etc/fonts/conf.d/* whenever doing a fontconfig update or dare I say it [upgrade]. The config files are put in /usr/share/fontconfig and symlink from there to /etc.
 
Old 03-19-2018, 02:08 PM   #12
1337_powerslacker
Member
 
Registered: Nov 2009
Distribution: Slackware64-current
Posts: 653
Blog Entries: 1

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
Quote:
Originally Posted by andrew.46 View Post
The warnings / errors that I have found with wine are a nuisance rather than a problem for me, running qaac + wine with abcde (where I discovered the issue) still produces great audio, just with a spray of font error messages.

I have reverted to fontconfig 2.12.6 on my own system and the errors disappeared so I am happy enough to have found the culprit at least.
Alas, the errors I had were showstoppers; wine would not run Unreal Gold/Tournament 99 (two of my fave retro games) and reverting to the previous version corrected the problem.

It would appear that staying with the previous version is a wise course of action, at least for now.
 
1 members found this post helpful.
Old 03-21-2018, 03:13 AM   #13
Petri Kaukasoina
Member
 
Registered: Mar 2007
Posts: 353

Rep: Reputation: 199Reputation: 199
Quote:
Originally Posted by number22 View Post
since you only say wine has problem, you probably has mismatch compat32 version of fontconfig with a 64bit system.
So, no one told whether they actually installed fontconfig-compat32-2.13.0-x86_64-1compat32 or tried to read the new 2.13.0 config files using the old 2.12.6 32-bit compatibility library.
 
Old 03-23-2018, 10:22 PM   #14
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 914

Original Poster
Rep: Reputation: 204Reputation: 204Reputation: 204
Thanks PV:

Code:
x/fontconfig-2.12.6-x86_64-1.txz:  Upgraded.
  Reverted to previous version. There are problem reports with the latest
  version, and I see no upside to staying on the bleeding edge right now.
No other distro that I have ever tried has been this responsive to an ordinary user's problems... Thanks!!
 
2 members found this post helpful.
Old 03-24-2018, 12:23 AM   #15
1337_powerslacker
Member
 
Registered: Nov 2009
Distribution: Slackware64-current
Posts: 653
Blog Entries: 1

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
Quote:
Originally Posted by andrew.46 View Post
Thanks PV:

Code:
x/fontconfig-2.12.6-x86_64-1.txz:  Upgraded.
  Reverted to previous version. There are problem reports with the latest
  version, and I see no upside to staying on the bleeding edge right now.
No other distro that I have ever tried has been this responsive to an ordinary user's problems... Thanks!!
One of the many reasons I stay with Slackware, other than the rock-solid stability and performance, that is. Thanks from myself as well, PV. It is much appreciated!!
 
2 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] setup fails on most current Slackware-current March 26, 2012 AlleyTrotter Slackware 15 04-09-2012 07:05 AM
fontconfig make errors in -current TSquaredF Slackware 4 11-06-2010 05:42 PM
nano How-To for using X with nVidia GPUs on slackware-current after March 1 updates Didier Spaier Slackware 38 04-06-2010 12:37 PM
[SOLVED] KDE desktop effects not working with Intel graphics (Slackware-Current; March 7, 2010 piratesmack Slackware 5 03-09-2010 09:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration