LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-05-2018, 12:43 AM   #1
narke
Member
 
Registered: Apr 2010
Posts: 169

Rep: Reputation: 2
Fontconfig: Aliasing serif/sans-serif takes no effect


Hi,

On my system, the 'fc-match serif' will reports:

wqy-zenhei.ttc: "文泉驿正黑" "中等"

Then I want to change the default serif font, so I write a file: ~/.config/fontconfig/fonts.conf as below:

<?xml version="1.0"?><!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<dir>~/.fonts</dir>
<alias>
<family>serif</family>
<prefer><family>Times New Roman</family></prefer>
</alias>
<alias>
<family>sans-serif</family>
<prefer><family>Arial</family></prefer>
</alias>
<alias>
<family>monospace</family>
<prefer><family>Courier New</family></prefer>
</alias>
</fontconfig>

I learned this from web. But still, even after reboot the system, I still get the same 'fc-match serif' outputs as before.

Why my aliasing operation not work?

Thanks.
-woody
 
Old 06-05-2018, 04:36 AM   #2
solarfields
Member
 
Registered: Feb 2006
Location: Outer Shpongolia
Distribution: Slackware
Posts: 867

Rep: Reputation: 391Reputation: 391Reputation: 391Reputation: 391
are you using 14.2 or -current? For -current i fixed all my fonts issues by specifying the DejaVu versions of the fonts i use. For example I define the default monospace font in Xfce's preferences to be DejaVu Sans Mono.
 
Old 06-06-2018, 12:11 AM   #3
narke
Member
 
Registered: Apr 2010
Posts: 169

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by solarfields View Post
are you using 14.2 or -current? For -current i fixed all my fonts issues by specifying the DejaVu versions of the fonts i use. For example I define the default monospace font in Xfce's preferences to be DejaVu Sans Mono.
Thanks. I am using Slackware 14.2. But my question is why the family aliasing did not work.
 
Old 06-09-2018, 02:26 PM   #4
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 8,283

Rep: Reputation: 3363Reputation: 3363Reputation: 3363Reputation: 3363Reputation: 3363Reputation: 3363Reputation: 3363Reputation: 3363Reputation: 3363Reputation: 3363Reputation: 3363
Remove /etc/fonts/conf.d/44-wqy-zenhei.conf. It's what's overriding your overrides.
 
1 members found this post helpful.
Old 06-11-2018, 01:07 AM   #5
narke
Member
 
Registered: Apr 2010
Posts: 169

Original Poster
Rep: Reputation: 2
Smile

Quote:
Originally Posted by dugan View Post
Remove /etc/fonts/conf.d/44-wqy-zenhei.conf. It's what's overriding your overrides.
Yes, it works! Thanks you very much!
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fatal error: fontconfig/fontconfig.h: No such file or directory bogzab Slackware 3 11-07-2011 03:13 PM
setsockopt(fd, SOL_SOCKET, SO_SNDBUF.....) still takes no effect after connect() ? tclwp Programming 1 04-17-2010 03:32 AM
looking for font "sans-serif symbol" kaz2100 Linux - General 1 05-11-2007 08:25 PM
been told I can load Serif programmes on linux as well as windows xp denise1929 Linux - Newbie 2 12-16-2006 04:44 PM
Wanted Sans, but got Serif in WindowMaker Cyber_Paladin Linux - Desktop 0 09-15-2006 11:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration