LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 02-27-2013, 05:57 AM   #1
burdi01
Member
 
Registered: Dec 2010
Location: The Netherlands
Distribution: Slackware, Xubuntu, PartedMagic
Posts: 68

Rep: Reputation: 7
fontconfig-2.10.2-i486-1.txz and firefox/thunderbird


Current: After applying this morning's updates (Wed Feb 27 04:58:17 UTC 2013) the texts in Firefox and Thunderbird look somewhat "corroded" (thinner). I think fontconfig-2.10.2-i486-1.txz is the obvious candidate to blame.
Anyone (other than me ) seeing this?
 
Old 02-27-2013, 06:04 AM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,336

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
Yes, i have seen it too when i tried to write something on Echofon
 
Old 02-27-2013, 07:14 AM   #3
lonestar_italy
Member
 
Registered: Nov 2010
Location: Italy
Distribution: Slackware
Posts: 62

Rep: Reputation: 0
Yes, fonts are looking "weird" everywhere, not just Firefox/Thunderbird.
 
Old 02-27-2013, 07:24 AM   #4
GazL
Senior Member
 
Registered: May 2008
Posts: 3,231

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
Based on observation and playing around with the font setting in xfce, it seems that the defaults might have changed and fontconfig is using full or medium hinting by default, making the characters look anorexic.

I have put the following in my ~/.Xresources file
Code:
xft.antialias: true
Xft.hinting:    true
Xft.hintstyle:  hintslight
...and that seems to make the gtk based apps look like they used to - and much better to my eyes.

If you're using xfce or another desktop you might have to play with their respective font settings dialogs as they are likely to override the Xresources. I suspect you'll also find a option somewhere in /etc/fonts/conf.d to set the same values, but as I'm an old-school, basic window-manager kind of guy, the Xresources seem to do the job for me.
 
Old 02-27-2013, 08:06 AM   #5
lonestar_italy
Member
 
Registered: Nov 2010
Location: Italy
Distribution: Slackware
Posts: 62

Rep: Reputation: 0
I noticed the new package is missing a file:

/etc/fonts/conf.avail/20-fix-globaladvance.conf

Copied it over from another machine, things seem slightly better but still not exactly back to how they were before upgrading the package.
 
Old 02-27-2013, 01:12 PM   #6
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,313

Rep: Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816
Don't want to confuse things more, but I seem to have spotted a deprecation warning of the file /etc/fonts/conf.d/50-user.conf.

I removed it (it's a symlink), renamed also ~/.fonts.conf, rebooted and set Slight font hinting and antialiasing with lxappearance (I could have used for this also the ~/.Xresources file, like GazL hints above, because it's checked in my ~/.xinitrc file for LXDE): this seems to have fixed things here.

I've just one web page where I still see unhinted fonts (scaled), really dunno why http://github.com.

EDIT: added a sample of the effect when opening a new window (the small preview) and part of the webpage.
Attached Images
File Type: png screen1.png (42.7 KB, 56 views)
File Type: png screen2.png (25.5 KB, 44 views)

Last edited by ponce; 02-27-2013 at 02:34 PM.
 
Old 02-28-2013, 03:00 AM   #7
cgorac
Member
 
Registered: Oct 2009
Posts: 41

Rep: Reputation: 0
I've noticed the same. In my case, the fix was to move ~/.fonts.conf to ~/.config/fontconfig/fonts.conf (I think ~/.fonts.conf is/was where anti-aliasing/hinting/etc. should be set, to be DE independent). It also fixes annoying warning emitted by /etc/fonts/conf.d/50-user.conf.
 
Old 02-28-2013, 04:11 AM   #8
matusz
LQ Newbie
 
Registered: Feb 2013
Distribution: Slackware-current
Posts: 5

Rep: Reputation: Disabled
It didn't fix the problem for me. After downgrading fontconfig everything is fine.
 
Old 02-28-2013, 05:01 AM   #9
burdi01
Member
 
Registered: Dec 2010
Location: The Netherlands
Distribution: Slackware, Xubuntu, PartedMagic
Posts: 68

Original Poster
Rep: Reputation: 7
For XFCE 4.10 (which is what I use) the font properties are set via Start > Settings > Appearance > Fonts. These properties are kept in ~/.config/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml.
Changing these rendering settings has no effect on my ~/.fonts.conf file: it keeps saying "hintfull". (Manually) editing the file to read "hintslight" resolved the firefox/thunderbird font change.

Actually my ~/.fonts.conf file has not changed since 2011-05-03. Interesting might be which Feb 27 update (fontconfig, mesa, xorg-server ?) made firefox/thunderbird react differently.

To get rid of the nasty "reading configurations from ~/.fonts.conf is deprecated" messages I created a ~/.config/fontconfig/conf.d directory and moved my ~/.fonts.conf file to ~/.config/fontconfig/fonts.conf .

Last edited by burdi01; 02-28-2013 at 11:52 AM.
 
Old 02-28-2013, 12:27 PM   #10
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 498

Rep: Reputation: Disabled
My fonts changed too and I'm unable to get them as they were before. Tried all the tricks in the thread.
 
Old 02-28-2013, 12:48 PM   #11
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 419

Rep: Reputation: Disabled
I don't know about anybody else, but in my $HOME directory I'm also getting a "fontconfig" directory which has a bunch of cache's since the fontconfig upgrade.
 
Old 02-28-2013, 01:49 PM   #12
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 498

Rep: Reputation: Disabled
Quote:
Originally Posted by TommyC7 View Post
I don't know about anybody else, but in my $HOME directory I'm also getting a "fontconfig" directory which has a bunch of cache's since the fontconfig upgrade.
I have that directory too, but the last modification date is from Feb 16, the same as the most recent file in there, so it seems unrelated to the fontconfig upgrade.
 
Old 02-28-2013, 01:53 PM   #13
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 498

Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
Don't want to confuse things more, but I seem to have spotted a deprecation warning of the file /etc/fonts/conf.d/50-user.conf.

I removed it (it's a symlink), renamed also ~/.fonts.conf, rebooted and set Slight font hinting and antialiasing with lxappearance (I could have used for this also the ~/.Xresources file, like GazL hints above, because it's checked in my ~/.xinitrc file for LXDE): this seems to have fixed things here.

I've just one web page where I still see unhinted fonts (scaled), really dunno why http://github.com.

EDIT: added a sample of the effect when opening a new window (the small preview) and part of the webpage.
Same effect here. I can fix that by removing the link to 70-yes-bitmaps.conf and adding the one to 70-no-bitmaps.conf in /etc/fonts/conf.d.
 
Old 02-28-2013, 02:08 PM   #14
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 419

Rep: Reputation: Disabled
Quote:
I have that directory too, but the last modification date is from Feb 16, the same as the most recent file in there, so it seems unrelated to the fontconfig upgrade.
For mine it's Feb. 27th and I know for a fact I never had it before.
 
Old 02-28-2013, 02:26 PM   #15
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 836

Rep: Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620
Quote:
Originally Posted by rg3 View Post
Same effect here. I can fix that by removing the link to 70-yes-bitmaps.conf and adding the one to 70-no-bitmaps.conf in /etc/fonts/conf.d.
As far as I know, the Slackware fontconfig package has never linked either of those files in /etc/font/conf.d. I've been applying a patch to fonts.conf to keep fontconfig from using the 100dpi and 75dpi directories by default, but it wouldn't help if bitmapped fonts were in any of the other directories. Perhaps it would be better (and more flexible) to drop the patch and include a link to 70-no-bitmaps.conf?

I also had a report that the new fontconfig was trying to use the Helvetica font (Liberation fonts claims this one), and that could possibly be causing some of the font changes. Maybe this as 70-no-helvetica.conf could help:

Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<!-- Disable Helvetica, it doesn't look nice with everything else -->
  <selectfont>
    <rejectfont>
      <pattern>
        <patelt name="family"><string>Helvetica</string></patelt>
      </pattern>
    </rejectfont>
  </selectfont>
</fontconfig>
BTW, I've always thought that the default font choices in most browsers are somewhat subpar and have long set my own local font preferences. This might be why I didn't see much of a difference when I upgraded fontconfig here.
 
2 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Glibc rpcsvc vanished in l/glibc-2.14.1-i486-2.txz Jeronimo Barros Slackware 16 02-14-2012 07:08 AM
No qt-doc after installation of qt-r1008952-i486-1.txz from dvd Squall90 Slackware 3 07-13-2010 10:52 PM
kdebase-workspace-4.3.4-i486-1.txz anyone? antitu Slackware 2 06-09-2010 02:21 PM
[SOLVED] slackpkg upgrade-all is not showing "bsd-games-2.13-i486-11.txz" piratesmack Slackware 2 05-16-2010 05:33 PM
[-CURRENT] QScintilla-2.4-i486-1.txz corrupted? raffaele181188 Slackware 3 10-29-2009 02:49 AM


All times are GMT -5. The time now is 05:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration