LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   fluxbox themes (https://www.linuxquestions.org/questions/slackware-14/fluxbox-themes-235130/)

spidna 09-25-2004 02:32 PM

fluxbox themes
 
Just wanted to find out if there is anyone who has install fluxbox 0.9.10 and how did you get it done. also very important how do i install the themes from the website. i have downloaded few of them untar it with tar xzf command, but don't know what to do next.

shilo 09-25-2004 02:44 PM

I don't know about the themes. I would guess that reading throught the ~/.fluxbox files would give you a good clue as to where to put the untarred packages.

As for installing 0.9.10, I went with the proven method of:

A) Download the package from an official mirror (It's available in -current since Sept. 7)
B) installpkg fluxbox-0.9.10-i486-1.tgz

If you already had fluxbox installed, I would guess that "upgradepkg fluxbox-0.9.10-i486-1.tgz" would be the way to go. Can't beat them official packages! (Unless you like compiling your own of course :) )

Also, you might want to check on the themes. A bunch were included when I installed.

predator.hawk 09-25-2004 11:15 PM

Stick Themes is ~/.fluxbox/styles. That generaly Works and for a few styles (designed for 0.9.10) vist my deviantart gallery at http://zeroto9.deviantart.com :).

Netizen 09-26-2004 09:10 AM

Re: fluxbox themes
 
Quote:

Originally posted by spidna
Just wanted to find out if there is anyone who has install fluxbox 0.9.10 and how did you get it done. also very important how do i install the themes from the website. i have downloaded few of them untar it with tar xzf command, but don't know what to do next.
I believe the FAQs on Fluxbox's site explains how to install themes. As far as installing the new version of flux box, if your using Slack you could use slapt-get or swaret.

spidna 09-26-2004 10:23 AM

fluxbox themes
 
i successfully upgraded fluxbox on slackware 10 to flux 0.9.10, still having problem with styles. Now there are no styles, before the upgrade i had plenty of them that came with slackware. Any ideas.

also want to thank those who have been responding to my post. A very big thank you for your time.

Cedrik 09-26-2004 01:48 PM

try a 'fluxbox-generate_menu'

erraticassassin 09-27-2004 03:39 AM

Open up your favourite text editor and have a look at your menu file in /home/USERNAME/.fluxbox. That will tell you where fluxbox is looking for your style files, though I think you can alter the settings to look in another location. On my system I think they're in /home/USERNAME/.fluxbox/styles (user styles) and also in /usr/share/X11R6/fluxbox/styles (system styles). (Not sure about that last one - I'm at work at the moment ;) )

Just your the styles you've downloaded into the appropriate directory and you should be ok. You may need to restart fluxbox for the menu to pick them up.

Raptor Ramjet 09-27-2004 11:17 AM

Just to add my tuppence worth...

I've found that any Fluxbox/Blackbox styles downloaded from the net are likely to be very variable in the way they're defined. Quite often you'll find that the theme files don't unpack in a way that makes them work on your box (usually due to the links to the background wallpapers/pixmaps being different to the directory structure on your box)

So my top tip is to open the packed theme files using file-roller (or whatever) and then to manually copy the files to the appropriate directories which will usually be.

Background wallpapers go in ~/.fluxbox/backgrounds
Styles go in ~/.fluxbox/styles
Pixmaps go in ~/.fluxbox/pixmaps/THEMENAME/ (where THEMENAME is the name of the theme)

Although having said this on my box I keep all my backgrounds in /opt/share/wallpapers

You'll then have to go through the themes style file to make sure all the links are to the correct directory. On this note I also find I usually have to set the "rootCommand" to use "bsetbg" as many use something else which I haven't got.

Anyway have a look at one of your style files (look in ~/.fluxbox/styles) as they're all plain text and it's quite straight forward to see what's going on.

fcaraballo 09-27-2004 11:37 AM

When you updated to fluxbox 0.9.10, did you delete your old .fluxbox folder under your home directory? You might want to try deleting it (of course, don't do this while your in fluxbox) and let the new fluxbox version create those files again. If you have any personal styles, you will want to back them up first.

MagicMan

hXc 09-27-2004 12:31 PM

In your .fluxbox/init there is a line that reads

Code:

session.styleFile:        /usr/X11R6/share/fluxbox/styles/
Change that to your styles path and there you go.


All times are GMT -5. The time now is 07:30 AM.